当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 20 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : PPPoE重启失效( bug 已修复,请大家改回到原来的设置)
帖子发表于 : 2005-09-20 19:56 

注册: 2005-09-18 17:47
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
小弟利用pppoeconf命令设置完配置文件之后,使用pon和poff可以正常的启动或者断开adsl连接。
但是每次机器重启之后,pon就不能正常启动adsl了,一定要pppoeconf再配置一次后,利用pon才会有效。
不知这个是什么毛病,应该如何解决才好?
先谢了


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-09-20 20:46 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10110
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 127
试试 sudo pon dsl-provider


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-09-21 19:57 
头像

注册: 2005-08-14 21:55
帖子: 58436
地址: 长沙
送出感谢: 4
接收感谢: 272
有提示没有。比如dsl-provider缺省就是root的。sudo配置以后,一段时间内,你还是sudo权限。可以直接修改dsl-provider文件的权限或者宿主。ls -l看一下。


_________________
● 鸣学


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-10-01 13:05 

注册: 2005-09-30 9:02
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
我也遇到这种情况了,每次系统重启就运行一次pppoeconf :(
用sudo pon dsl-provider不管用,郁闷了.....
求解呀


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-10-01 13:14 
头像

注册: 2005-05-19 18:38
帖子: 1989
地址: 湖南永州
送出感谢: 0 次
接收感谢: 1
我的有时也这样,但

把 pppd 进程杀死,

再 sudo pon 就能上网

试了没有


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-10-01 13:20 

注册: 2005-09-30 9:02
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
没有试呀.我试试看
另外难道 sudo运行pon不行吗?我一会再把dsl-provider的权限设成755试试,郁闷... :cry:


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-10-01 13:51 

注册: 2005-09-30 9:02
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
还是不行..... :cry: :cry:


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2005-10-02 21:50 
头像

注册: 2005-08-14 21:55
帖子: 58436
地址: 长沙
送出感谢: 4
接收感谢: 272
~$ cat /etc/rcS.d/S44adsl
#!/bin/sh
sudo eciadsl-start
sleep 2
pon dsl-provider
#sleep 1
#ping -c 5 202.103.96.112

~$ ls -l /etc/ppp/peers/dsl-provider
-rw-r--r-- 1 root root 2184 2005-09-17 01:34 /etc/ppp/peers/dsl-provider

说明。pppoeconf产生dsl-provider。pon不带参数是调用provider。而不是dsl-provider。


_________________
● 鸣学


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2005-10-06 21:47 

注册: 2005-09-30 9:02
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
:( 我还知道pon的用法....
重启之后sudo pon dsl-provider之后,shell显示dsl-provider plugin loaded.之后也没别的了,可依然上不了网...
还是ppponconf吧....


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2005-10-06 21:57 
头像

注册: 2005-08-14 21:55
帖子: 58436
地址: 长沙
送出感谢: 4
接收感谢: 272
if this, you can modify your dsl-provider file to let it work. that' can let you know why, and also favorable to us.


_________________
● 鸣学


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2005-10-06 23:14 

注册: 2005-08-20 3:56
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
用 plog 看看出错信息。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2005-10-06 23:21 
头像

注册: 2005-08-14 21:55
帖子: 58436
地址: 长沙
送出感谢: 4
接收感谢: 272
http://my.opera.com/eexpress/blog/
这里有些可以看的。包括出错的信息。


_________________
● 鸣学


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2005-10-10 11:50 
头像

注册: 2005-05-19 18:38
帖子: 1989
地址: 湖南永州
送出感谢: 0 次
接收感谢: 1
我升级到 5.10

也是一样,

好象网络没工作


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2005-10-10 12:01 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10110
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 127
没有啊,我这边的breezy下的网路很正常。


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2005-10-11 7:15 

注册: 2005-05-02 15:29
帖子: 105
送出感谢: 0 次
接收感谢: 0 次
经过多次折腾
在这的兄弟和sir上兄弟的帮助下
我这的问题已经解决了

系统刚刚安装时连网卡都不能自动激活
发现/etc/network/interfaces文件末尾有很多类似auto eth0的信息
将多余的删除只留一个auto eth0就可以了
这样网卡就能被自动激活

然后是自动pppoe连接
sir上的兄弟说5.10现在还不会自动激活pppo3
但会自动激活ppp
所以到/etc/ppp目录下建立一个链接就可以了
ln -s /etc/ppp/pppoe_on_boot /etc/ppp/ppp_on_boot

果然全部问题解决


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 20 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译