transmission 1.93编译安装失败,求解

上网、浏览、聊天、下载等
回复
头像
hbxtght
帖子: 191
注册时间: 2011-01-17 22:23
送出感谢: 0
接收感谢: 1 次

transmission 1.93编译安装失败,求解

#1

帖子 hbxtght » 2011-05-04 13:37

由于更新系统,transmission被更新,导致我不能为ipv6 pt做种了,于是我在网上下了个transmission1.93的源码包,无奈,编译出现问题,如下

代码: 全选

ght@ght-laptop:~/software/transmission-1.93$ sudo make
[sudo] password for ght: 
Making all in doc
make[1]: 正在进入目录 `/home/ght/software/transmission-1.93/doc'
make[1]: 没有什么可以做的为 `all'。
make[1]:正在离开目录 `/home/ght/software/transmission-1.93/doc'
Making all in third-party
make[1]: 正在进入目录 `/home/ght/software/transmission-1.93/third-party'
Making all in libnatpmp
make[2]: 正在进入目录 `/home/ght/software/transmission-1.93/third-party/libnatpmp'
make[2]: 没有什么可以做的为 `all'。
make[2]:正在离开目录 `/home/ght/software/transmission-1.93/third-party/libnatpmp'
Making all in miniupnp
make[2]: 正在进入目录 `/home/ght/software/transmission-1.93/third-party/miniupnp'
./updateminiupnpcstrings.sh ./miniupnpcstrings.h.in miniupnpcstrings.h
Detected OS [Ubuntu] version [11.04]
setting OS_STRING macro value to Ubuntu/11.04 in miniupnpcstrings.h.
make  all-am
make[3]: 正在进入目录 `/home/ght/software/transmission-1.93/third-party/miniupnp'
  CC     minisoap.o
  CC     miniwget.o
miniwget.c: In function ‘miniwget3’:
miniwget.c:48:24: warning: unused parameter ‘url’
  AR     libminiupnp.a
make[3]:正在离开目录 `/home/ght/software/transmission-1.93/third-party/miniupnp'
make[2]:正在离开目录 `/home/ght/software/transmission-1.93/third-party/miniupnp'
Making all in libevent
make[2]: 正在进入目录 `/home/ght/software/transmission-1.93/third-party/libevent'
make  all-recursive
make[3]: 正在进入目录 `/home/ght/software/transmission-1.93/third-party/libevent'
Making all in .
make[4]: 正在进入目录 `/home/ght/software/transmission-1.93/third-party/libevent'
make[4]:正在离开目录 `/home/ght/software/transmission-1.93/third-party/libevent'
Making all in sample
make[4]: 正在进入目录 `/home/ght/software/transmission-1.93/third-party/libevent/sample'
make[4]: 没有什么可以做的为 `all'。
make[4]:正在离开目录 `/home/ght/software/transmission-1.93/third-party/libevent/sample'
Making all in test
make[4]: 正在进入目录 `/home/ght/software/transmission-1.93/third-party/libevent/test'
make  all-am
make[5]: 正在进入目录 `/home/ght/software/transmission-1.93/third-party/libevent/test'
make[5]: 没有什么可以做的为 `all-am'。
make[5]:正在离开目录 `/home/ght/software/transmission-1.93/third-party/libevent/test'
make[4]:正在离开目录 `/home/ght/software/transmission-1.93/third-party/libevent/test'
make[3]:正在离开目录 `/home/ght/software/transmission-1.93/third-party/libevent'
make[2]:正在离开目录 `/home/ght/software/transmission-1.93/third-party/libevent'
Making all in dht
make[2]: 正在进入目录 `/home/ght/software/transmission-1.93/third-party/dht'
make[2]: 没有什么可以做的为 `all'。
make[2]:正在离开目录 `/home/ght/software/transmission-1.93/third-party/dht'
make[2]: 正在进入目录 `/home/ght/software/transmission-1.93/third-party'
make[2]: 没有什么可以做的为 `all-am'。
make[2]:正在离开目录 `/home/ght/software/transmission-1.93/third-party'
make[1]:正在离开目录 `/home/ght/software/transmission-1.93/third-party'
Making all in libtransmission
make[1]: 正在进入目录 `/home/ght/software/transmission-1.93/libtransmission'
  CC     metainfo.o
  CC     peer-io.o
peer-io.c: In function ‘tr_evbuffer_write’:
peer-io.c:268:31: error: dereferencing pointer to incomplete type
make[1]: *** [peer-io.o] 错误 1
make[1]:正在离开目录 `/home/ght/software/transmission-1.93/libtransmission'
make: *** [all-recursive] 错误 1

望高手帮忙解决下,另外问一下,transmission所有版本都要修改源文件后才能为v6做种吗?
或者给个deb包也可以,只要支持v6
苏东坡问佛印道:“人人皆念观世音菩萨,观世音菩萨念谁?”
佛印答道:“念观世音菩萨。”
苏东坡诧异:“为何亦念观世音菩萨?”
曰:“求人不如求己。”
头像
nmsfan
帖子: 18958
注册时间: 2009-10-16 22:46
来自: finland
送出感谢: 16 次
接收感谢: 36 次

Re: transmission 1.93编译安装失败,求解

#2

帖子 nmsfan » 2011-05-04 17:20

好多都支持v6啊,qbittorrent可以,gtk的,ktorrent可以,qt的
transmission在别的论坛有改好的,如果你能登上去的话........
http://bt.neu6.edu.cn/viewthread.php?tid=660405
>>>>推Ubuntu 桌面培训~~<<<<
>>>>想加入/了解gimp汉化吗,点我吧~<<<<
——————————————————————
不推荐wubi,也不推荐你给别人推荐wubi…………
随心而为的感觉真好……
强推mayhem!!
强推ensiferum
头像
hbxtght
帖子: 191
注册时间: 2011-01-17 22:23
送出感谢: 0
接收感谢: 1 次

Re: transmission 1.93编译安装失败,求解

#3

帖子 hbxtght » 2011-05-04 17:25

已经解决,我找到的一个方法在这里:https://forum.transmissionbt.com/viewto ... =2&p=48723
是我libevent版本的问题
苏东坡问佛印道:“人人皆念观世音菩萨,观世音菩萨念谁?”
佛印答道:“念观世音菩萨。”
苏东坡诧异:“为何亦念观世音菩萨?”
曰:“求人不如求己。”
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

Re: transmission 1.93编译安装失败,求解

#4

帖子 leeaman » 2011-05-04 17:25

这么老的版本啊,干嘛自己编译?
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
头像
nyfair
帖子: 1064
注册时间: 2007-12-07 12:49
系统: winnux10
来自: Tree New Bee
送出感谢: 2 次
接收感谢: 13 次

Re: transmission 1.93编译安装失败,求解

#5

帖子 nyfair » 2011-05-04 18:17

自己编译bt软件可以混pt作弊 :em05
本人在此论坛仅负责吐槽,问题急需解决请支付宝转账5毛至{我的id@qq.com},将会竭诚为您服务

linux常见多媒体问题处理指南

1. 视频播放有问题->卸载gstreamer
2. 音频播放有问题->卸载pulseaudio
3. 远程播放有问题->卸载avahi
4. 系统全都有问题->卸载systemd,远离Lennart这傻逼让你从此轻松自在

⇩自由网络⇩
https://github.com/nyfair/freeweb
头像
hbxtght
帖子: 191
注册时间: 2011-01-17 22:23
送出感谢: 0
接收感谢: 1 次

Re: transmission 1.93编译安装失败,求解

#6

帖子 hbxtght » 2011-05-04 21:33

老版本让我有种亲切感,哈哈
苏东坡问佛印道:“人人皆念观世音菩萨,观世音菩萨念谁?”
佛印答道:“念观世音菩萨。”
苏东坡诧异:“为何亦念观世音菩萨?”
曰:“求人不如求己。”
回复

回到 “因特网相关软件”