当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 请问cream DE安装的问题..
帖子发表于 : 2011-05-05 23:07 
头像

注册: 2010-01-03 19:58
帖子: 631
地址: 杭州
系统: OS X, Ubuntu(server)
送出感谢: 4
接收感谢: 0 次
新闻看到的cream desktop environment桌面,,
喜欢那个概念就想装,,环境是ubuntu11.04..
先用ppa装了,,结果不知道是哪个包..
搜到个论坛说要用melange启动,,
一看melange搜索结果有的..但是装的时候不满足依赖..
然后找git,,按照说面先装好了virtualenv,,
然后make setup,,等了半天显示Installing distribute....我只好ctrl+c了..
参考的文档是..:
http://cream-project.org/install/
会是什么问题呢?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 请问cream DE安装的问题..
帖子发表于 : 2011-05-06 2:55 
头像

注册: 2010-11-08 13:19
帖子: 389
地址: 广东省广州市黄埔区
系统: openSUSE
送出感谢: 2
接收感谢: 4
看了你的帖子,我折腾了半天,也没弄好。等待神人吧!


_________________
openSUSE还不错呢!
围脖:http://weibo.com/theair
Twitter:https://twitter.com/Zerta_D
邮箱/Gtalk:yuhuayang07@gmail.com
人生最悲哀的两点:生不醒目,死不瞑目。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 请问cream DE安装的问题..
帖子发表于 : 2011-05-06 9:03 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
看新闻说ppa有源的啊


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 请问cream DE安装的问题..
帖子发表于 : 2011-05-08 14:42 
头像

注册: 2011-05-08 14:08
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
图片
用源码装的,跟awesome共存,没有背景图片,但是插件都能用。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 请问cream DE安装的问题..
帖子发表于 : 2011-05-08 16:58 
头像

注册: 2010-01-03 19:58
帖子: 631
地址: 杭州
系统: OS X, Ubuntu(server)
送出感谢: 4
接收感谢: 0 次
我忘了去考虑依赖的问题了,,
不过这里也有问题..大部分的包都找不到,,
楼上是怎么解决这个问题呢?
代码:
sudo aptitude install python python-lxml pygobject pygtk python-cairo vte libev librsvg dbus-python python-elixir pywebkitgtk python-feedparser libxcb python-virtualenv bzr cython gstreamer0.10-python
[sudo] password for chin:
Couldn't find any package matching "pygobject".  However, the following
packages contain "pygobject" in their description:
  python-gobject-dev
Couldn't find package "pygtk".  However, the following
packages contain "pygtk" in their name:
  python-zbarpygtk
Couldn't find package "vte".  However, the following
packages contain "vte" in their name:
  libghc6-vte-doc libvte-ruby1.8 gir1.2-vte-0.0 libvte-2.90-dev evtest libvte-ruby1.8-dbg libvte-dev evilvte libvte-doc libvte-2.90-9
  python-vte-dev python-vte libvte9 libvte-ruby libvte0.16-cil libvte0.16-cil-dev libghc6-vte-dev-0.11.0-ef262 gir1.2-vte-2.90 libvte-common
  libghc6-vte-dev
Couldn't find package "libev", and more than 40
packages contain "libev" in their name.
Couldn't find package "librsvg".  However, the following
packages contain "librsvg" in their name:
  librsvg2-2.18-cil librsvg2-2.0-cil-dev librsvg2-ruby1.8-dbg librsvg2-2 librsvg2-bin librsvg2-dbg librsvg2-dev librsvg2-ruby1.8 librsvg2-ruby
  librsvg2-common libimage-librsvg-perl
Couldn't find any package whose name or description matched "dbus-python"
Couldn't find any package matching "pywebkitgtk".  However, the following
packages contain "pywebkitgtk" in their description:
  python-jswebkit
Couldn't find package "libxcb", and more than 40
packages contain "libxcb" in their name.
Couldn't find any package whose name or description matched "gstreamer0.10-python"
Couldn't find any package matching "pygobject".  However, the following
packages contain "pygobject" in their description:
  python-gobject-dev
Couldn't find package "pygtk".  However, the following
packages contain "pygtk" in their name:
  python-zbarpygtk
Couldn't find package "vte".  However, the following
packages contain "vte" in their name:
  libghc6-vte-doc libvte-ruby1.8 gir1.2-vte-0.0 libvte-2.90-dev evtest libvte-ruby1.8-dbg libvte-dev evilvte libvte-doc libvte-2.90-9
  python-vte-dev python-vte libvte9 libvte-ruby libvte0.16-cil libvte0.16-cil-dev libghc6-vte-dev-0.11.0-ef262 gir1.2-vte-2.90 libvte-common
  libghc6-vte-dev
Couldn't find package "libev", and more than 40
packages contain "libev" in their name.
Couldn't find package "librsvg".  However, the following
packages contain "librsvg" in their name:
  librsvg2-2.18-cil librsvg2-2.0-cil-dev librsvg2-ruby1.8-dbg librsvg2-2 librsvg2-bin librsvg2-dbg librsvg2-dev librsvg2-ruby1.8 librsvg2-ruby
  librsvg2-common libimage-librsvg-perl
Couldn't find any package whose name or description matched "dbus-python"
Couldn't find any package matching "pywebkitgtk".  However, the following
packages contain "pywebkitgtk" in their description:
  python-jswebkit
Couldn't find package "libxcb", and more than 40
packages contain "libxcb" in their name.
Couldn't find any package whose name or description matched "gstreamer0.10-python"
The following NEW packages will be installed:
  bzr bzrtools{a} cython libtidy-0.99-0{a} python-bzrlib{a} python-configobj{a} python-elixir python-feedparser python-paramiko{a}
  python-sqlalchemy{a} python-sqlalchemy-ext{a} python-utidylib{a}
0 packages upgraded, 12 newly installed, 0 to remove and 2 not upgraded.
Need to get 6,118 kB of archives. After unpacking 41.2 MB will be used.
Do you want to continue? [Y/n/?] n
Abort.


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 请问cream DE安装的问题..
帖子发表于 : 2011-05-09 0:35 
头像

注册: 2011-05-08 14:08
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
jiyinyiyong 写道:
我忘了去考虑依赖的问题了,,
不过这里也有问题..大部分的包都找不到,,
楼上是怎么解决这个问题呢?
代码:
sudo aptitude install python python-lxml pygobject pygtk python-cairo vte libev librsvg dbus-python python-elixir pywebkitgtk python-feedparser libxcb python-virtualenv bzr cython gstreamer0.10-python
[sudo] password for chin:
Couldn't find any package matching "pygobject".  However, the following
packages contain "pygobject" in their description:
  python-gobject-dev
Couldn't find package "pygtk".  However, the following
packages contain "pygtk" in their name:
  python-zbarpygtk
Couldn't find package "vte".  However, the following
packages contain "vte" in their name:
  libghc6-vte-doc libvte-ruby1.8 gir1.2-vte-0.0 libvte-2.90-dev evtest libvte-ruby1.8-dbg libvte-dev evilvte libvte-doc libvte-2.90-9
  python-vte-dev python-vte libvte9 libvte-ruby libvte0.16-cil libvte0.16-cil-dev libghc6-vte-dev-0.11.0-ef262 gir1.2-vte-2.90 libvte-common
  libghc6-vte-dev
Couldn't find package "libev", and more than 40
packages contain "libev" in their name.
Couldn't find package "librsvg".  However, the following
packages contain "librsvg" in their name:
  librsvg2-2.18-cil librsvg2-2.0-cil-dev librsvg2-ruby1.8-dbg librsvg2-2 librsvg2-bin librsvg2-dbg librsvg2-dev librsvg2-ruby1.8 librsvg2-ruby
  librsvg2-common libimage-librsvg-perl
Couldn't find any package whose name or description matched "dbus-python"
Couldn't find any package matching "pywebkitgtk".  However, the following
packages contain "pywebkitgtk" in their description:
  python-jswebkit
Couldn't find package "libxcb", and more than 40
packages contain "libxcb" in their name.
Couldn't find any package whose name or description matched "gstreamer0.10-python"
Couldn't find any package matching "pygobject".  However, the following
packages contain "pygobject" in their description:
  python-gobject-dev
Couldn't find package "pygtk".  However, the following
packages contain "pygtk" in their name:
  python-zbarpygtk
Couldn't find package "vte".  However, the following
packages contain "vte" in their name:
  libghc6-vte-doc libvte-ruby1.8 gir1.2-vte-0.0 libvte-2.90-dev evtest libvte-ruby1.8-dbg libvte-dev evilvte libvte-doc libvte-2.90-9
  python-vte-dev python-vte libvte9 libvte-ruby libvte0.16-cil libvte0.16-cil-dev libghc6-vte-dev-0.11.0-ef262 gir1.2-vte-2.90 libvte-common
  libghc6-vte-dev
Couldn't find package "libev", and more than 40
packages contain "libev" in their name.
Couldn't find package "librsvg".  However, the following
packages contain "librsvg" in their name:
  librsvg2-2.18-cil librsvg2-2.0-cil-dev librsvg2-ruby1.8-dbg librsvg2-2 librsvg2-bin librsvg2-dbg librsvg2-dev librsvg2-ruby1.8 librsvg2-ruby
  librsvg2-common libimage-librsvg-perl
Couldn't find any package whose name or description matched "dbus-python"
Couldn't find any package matching "pywebkitgtk".  However, the following
packages contain "pywebkitgtk" in their description:
  python-jswebkit
Couldn't find package "libxcb", and more than 40
packages contain "libxcb" in their name.
Couldn't find any package whose name or description matched "gstreamer0.10-python"
The following NEW packages will be installed:
  bzr bzrtools{a} cython libtidy-0.99-0{a} python-bzrlib{a} python-configobj{a} python-elixir python-feedparser python-paramiko{a}
  python-sqlalchemy{a} python-sqlalchemy-ext{a} python-utidylib{a}
0 packages upgraded, 12 newly installed, 0 to remove and 2 not upgraded.
Need to get 6,118 kB of archives. After unpacking 41.2 MB will be used.
Do you want to continue? [Y/n/?] n
Abort.


大部分包的名字都不是官网列出来的,在ubuntu下。名字好像都是源码包的名字,这个要查一下的,还有,python和python2换换试试。而且最好别装python3。我看着源码,里面很乱,有直接调用python2,有调用env python的,要是装了python3而且python 》》python3的话,就肯定启动不了了。最后就是权限的问题,代码要启动一个python的webserver进程,用户要在有这个权限的组里面。还有调用其他模块的权限。感觉开发的时候就使用root开发的。没有注意到ubuntu用户权限的问题。sudo启动是没有问题的~~ 。以上。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 请问cream DE安装的问题..
帖子发表于 : 2011-05-09 12:04 
头像

注册: 2010-01-03 19:58
帖子: 631
地址: 杭州
系统: OS X, Ubuntu(server)
送出感谢: 4
接收感谢: 0 次
多谢楼上..
没想到ubuntu反而成了这么麻烦的发行版了,
redshiftkeying是在ubuntu装的吗?
我没办法保证找出全不对应的包,,算了搁浅了,,
等以后虚拟机装个arch想到再试试看.


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 请问cream DE安装的问题..
帖子发表于 : 2011-05-10 18:02 
头像

注册: 2011-05-08 14:08
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
jiyinyiyong 写道:
多谢楼上..
没想到ubuntu反而成了这么麻烦的发行版了,
redshiftkeying是在ubuntu装的吗?
我没办法保证找出全不对应的包,,算了搁浅了,,
等以后虚拟机装个arch想到再试试看.


arch和ubuntu11。04都装上了。现在正试着写小控件,感觉这个桌面很好玩。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 请问cream DE安装的问题..
帖子发表于 : 2011-06-18 18:56 
头像

注册: 2010-01-03 19:58
帖子: 631
地址: 杭州
系统: OS X, Ubuntu(server)
送出感谢: 4
接收感谢: 0 次
发现5-19cream的ppa更新了一次,于是又去装了一次
还是broken package的提示,,,这个提示我都没搞清什么意思,,为什么破损?
然后决定仔细看官网说的各个发行版对应软件包名称不同
再找了cython bzr python-elixir python-feedparser 大概几个继续装上
还有另外几个应该,,还有几个名字改变的,还有搞不清那个包的
然后git上的安装了,比原来好点,但是还是出现了如下错误
我只能猜测是还有包缺少了..

想问楼上在ubuntu11.04上装当时用的是哪些包?

代码:
.....
Installed /home/chin/kit/cream/dev/lib/python2.7/site-packages/ooxcb-1.2-py2.7.egg
Processing dependencies for ooxcb
Finished processing dependencies for ooxcb
easy_install bjoern
Searching for bjoern
Reading http://pypi.python.org/simple/bjoern/
Reading https://github.com/jonashaag/bjoern
Best match: bjoern 1.2
Downloading http://pypi.python.org/packages/source/b/bjoern/bjoern-1.2.tar.gz#md5=e236ff11b52835f13c51fb7aad39bdee
Processing bjoern-1.2.tar.gz
Running bjoern-1.2/setup.py -q bdist_egg --dist-dir /tmp/easy_install-IfTU_8/bjoern-1.2/egg-dist-tmp-rK76Iv
In file included from bjoern/common.c:1:0:
bjoern/common.h:24:1: warning: function declaration isn’t a prototype
bjoern/common.c:29:6: warning: function declaration isn’t a prototype
In file included from bjoern/server.h:1:0,
                 from bjoern/bjoernmodule.c:2:
bjoern/request.h:4:16: fatal error: ev.h: No such file or directory
compilation terminated.
error: Setup script exited with error: command 'gcc' failed with exit status 1
make[1]: *** [_setup2] Error 1
make[1]: Leaving directory `/home/chin/kit/cream'
make: *** [setup] Error 2


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 请问cream DE安装的问题..
帖子发表于 : 2011-06-18 20:51 
头像

注册: 2008-04-26 12:41
帖子: 11000
送出感谢: 11
接收感谢: 38
:em09


_________________
[新手必读]wubi安装常见问题(FAQ)
[分享]装双系统的同学必看——Windows与Linux系统共享交换分区的方法
kde下唯美的暗黑内透主题(无需编译)
无穷老机上的Trinity Desktop Environment


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 请问cream DE安装的问题..
帖子发表于 : 2011-12-28 23:21 
头像

注册: 2009-03-09 12:00
帖子: 42
送出感谢: 1
接收感谢: 0 次
我也遇到了ev.h找不到的问题 咋整啊 :em20


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译