当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 【求助】MLDonkey 3.0.7无法编译安装
帖子发表于 : 2011-05-20 2:48 
头像

注册: 2010-07-10 1:19
帖子: 420
地址: G+阿卡林部
系统: 洗发水
送出感谢: 0 次
接收感谢: 0 次
make的时候出现错误:
代码:
src/networks/fasttrack/fst_crypt_ml.c:56:3: warning: pointer targets in passing argument 2 of ‘fst_cipher_crypt’ differ in signedness [-Wpointer-sign]
src/networks/fasttrack/fst_crypt.h:54:6: note: expected ‘unsigned char *’ but argument is of type ‘char *’
g++ -g -O2 -fno-omit-frame-pointer -mno-omit-leaf-frame-pointer -o src/utils/lib/CryptoPP.o "-I/usr/lib/ocaml" -c src/utils/lib/CryptoPP.cc
src/utils/lib/CryptoPP.cc:1684:3: warning: #warning "You do not have GCC 3.3 or later, or did not specify -msse2 compiler option, so use of SSE2 intrinsics will be disabled." [-Wcpp]
src/utils/lib/CryptoPP.cc:165:26: error: uninitialized const ‘CryptoPP::g_nullNameValuePairs’ [-fpermissive]
src/utils/lib/CryptoPP.h:694:20: note: ‘const class CryptoPP::NullNameValuePairs’ has no user-provided default constructor
make: *** [src/utils/lib/CryptoPP.o] Error 1
可我的gcc是4.X的。求前辈们指点


_________________
     ∧_∧::
    (´・ω・`)::
   /⌒  ⌒)::
  / へ__/ /::
  (_\\ミ)/::
   | `-イ::
   /y  )::
  // /::
  / /::
 ( く:::
 |\ ヽ:::


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Exabot [Bot] 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译