安装firefox 3.0 a2的问题,求解---已解决,方法见本贴内容

上网、浏览、聊天、下载等
回复
头像
coffer
帖子: 673
注册时间: 2006-12-22 21:05
来自: 上海
送出感谢: 0
接收感谢: 0
联系:

安装firefox 3.0 a2的问题,求解---已解决,方法见本贴内容

#1

帖子 coffer » 2007-01-20 17:39

从网上下载了firefox3.0a2版 ,解压后进入firefox目录,
1、在终端下运行./firefox ,系统提示:Segmentation fault (core dumped)。

2、运行./firefox-bin,系统提示:./firefox-bin: error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory

3、运行sudo sh ./sh-mozilla.sh,系统提示:run-mozilla.sh: Cannot execute . (run-mozilla.sh的属性为:-rwxr-xr-x 1 xxx xxx 11683 2007-01-08 20:45 run-mozilla.sh)

请教高手,此问题应该如何解决?


文件内容如下:
xxx@ubuntu:~/Linux Soft/firefox$ ls
browserconfig.properties libmozjs.so libxpistub.so
chrome libnspr4.so mozilla-xremote-client
components libnss3.so plugins
defaults libnssckbi.so readme.txt
dictionaries libplc4.so removed-files
extensions libplds4.so res
firefox libsmime3.so run-mozilla.sh
firefox-bin libsoftokn3.chk searchplugins
greprefs libsoftokn3.so updater
icons libssl3.so updater.ini
libfreebl3.chk libxpcom_core.so xpicleanup
libfreebl3.so libxpcom.so
xxx@ubuntu:~/Linux Soft/firefox$ ./firefox-bin
./firefox-bin: error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory


xxx@ubuntu:~/Linux Soft/firefox$ ./firefox
[/img]
上次由 coffer 在 2007-01-20 22:02,总共编辑 1 次。
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 zhan » 2007-01-20 18:15

没有用过 3.0 不明白,但是我觉得默认直接解压运行应该是没有问题的。
莫非楼主是 64 位的?
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
头像
coffer
帖子: 673
注册时间: 2006-12-22 21:05
来自: 上海
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 coffer » 2007-01-20 18:56

To: zhan

firefox 3.0 a1版解压后直接就可以运行,但a2版却不能运行,我的电脑不是64位的,intel c 2.0的CPU。
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 karron » 2007-01-20 19:41

可能还是scim和它冲突,解决方法就是在firefox文件里面加一行字,具体的我忘记了.你搜索一下scim firefox.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
coffer
帖子: 673
注册时间: 2006-12-22 21:05
来自: 上海
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 coffer » 2007-01-20 22:01

To:Karron

谢谢Karron的提示,按你的提示,我搜索了一下论坛,在http://forum.ubuntu.org.cn/viewtopic.php?t=12456&highlight=firefox+scim 看到解决方案,按这个贴子的方法解决了firefox3.0 a2不能运行的问题。

解决方法:
编辑firefox.sh,加入如下语句:export GTK_IM_MODULE=xim
[/quote]
回复

回到 “因特网相关软件”