[问题]刚刚发现升级5.10之后lumaqq和Azureus不能用了。

上网、浏览、聊天、下载等
回复
头像
paul
帖子: 510
注册时间: 2005-09-01 20:48
送出感谢: 0
接收感谢: 0

[问题]刚刚发现升级5.10之后lumaqq和Azureus不能用了。

#1

帖子 paul » 2005-10-15 19:29

估计和Java有关,睡觉了,明天有时间再设.
头像
Arete
帖子: 74
注册时间: 2005-10-05 11:15
来自: http://bulaoge.com/?arete
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 Arete » 2005-10-15 23:21

估计是。510的源里头好像没有了j2se。
有人知道这是怎么回事吗?
头像
Arete
帖子: 74
注册时间: 2005-10-05 11:15
来自: http://bulaoge.com/?arete
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 Arete » 2005-10-16 8:00

从archive.ubuntu.org.cn装了sun-j2se1.5。运行qq出错。

Exception in thread "main" java.lang.NoClassDefFoundError: while resolving class: edu.tsinghua.lumaqq.LumaQQ
at ._ZN4java4lang11VMThrowable16fillInStackTraceEPNS0_9ThrowableE (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang9Throwable16fillInStackTraceEv (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang9ThrowableC1EPNS0_6StringE (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang5ErrorC1EPNS0_6StringE (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang12LinkageErrorC1EPNS0_6StringE (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang20NoClassDefFoundErrorC1EPNS0_6StringE (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang13VMClassLoader18transformExceptionEPNS0_5ClassEPNS0_9ThrowableE (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang13VMClassLoader12resolveClassEPNS0_5ClassE (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang5Class15initializeClassEv (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang5Class7forNameEPNS0_6StringEbPNS0_11ClassLoaderE (/usr/lib/libgcj.so.6.0.0)
at ._ZN3gnu4java4lang10MainThread3runEv (/usr/lib/libgcj.so.6.0.0)
at ._Z13_Jv_ThreadRunPN4java4lang6ThreadE (/usr/lib/libgcj.so.6.0.0)
at ._Z11_Jv_RunMainP14_Jv_VMInitArgsPN4java4lang5ClassEPKciPS6_b (/usr/lib/libgcj.so.6.0.0)
at .main (/usr/lib/libgij.so.6.0.0)
at .__libc_start_main (/lib/tls/i686/cmov/libc-2.3.5.so)
Caused by: java.lang.ClassNotFoundException: java.lang.StringBuilder not found in gnu.gcj.runtime.SystemClassLoader{urls=[file:/opt/LumaQQ/lib/xerces.jar,file:./,file:/opt/LumaQQ/lib/swt.jar,file:/opt/LumaQQ/lib/poifs.jar,file:./,file:/opt/LumaQQ/lib/org.eclipse.ui.workbench_3.1.0.jar,file:/opt/LumaQQ/lib/org.eclipse.osgi_3.1.0.jar,file:./,file:/opt/LumaQQ/lib/org.eclipse.jface_3.1.0.jar,file:/opt/LumaQQ/lib/org.eclipse.core.runtime_3.1.0.jar,file:./,file:/opt/LumaQQ/lib/lumaqq.jar,file:/opt/LumaQQ/lib/log4j-1.2.8.jar,file:./,file:/opt/LumaQQ/lib/jql-20050817231959.jar,file:/opt/LumaQQ/lib/jdom.jar,file:./,file:/opt/LumaQQ/lib/commons-logging.jar,file:/opt/LumaQQ/lib/commons-codec-1.3.jar,file:./], parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
at ._ZN4java4lang11VMThrowable16fillInStackTraceEPNS0_9ThrowableE (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang9Throwable16fillInStackTraceEv (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang9ThrowableC1EPNS0_6StringE (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang9ThrowableC1EPNS0_6StringEPS1_ (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang9ExceptionC1EPNS0_6StringEPNS0_9ThrowableE (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang22ClassNotFoundExceptionC1EPNS0_6StringEPNS0_9ThrowableE (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang22ClassNotFoundExceptionC1EPNS0_6StringE (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java3net14URLClassLoader9findClassEPNS_4lang6StringE (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang11ClassLoader9loadClassEPNS0_6StringEb (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang11ClassLoader9loadClassEPNS0_6StringE (/usr/lib/libgcj.so.6.0.0)
at ._Z13_Jv_FindClassP13_Jv_Utf8ConstPN4java4lang11ClassLoaderE (/usr/lib/libgcj.so.6.0.0)
at ._ZN4java4lang5Class7forNameEPNS0_6StringEbPNS0_11ClassLoaderE (/usr/lib/libgcj.so.6.0.0)
at ._ZN20_Jv_BytecodeVerifier21verify_instructions_0Ev (/usr/lib/libgcj.so.6.0.0)
at ._Z16_Jv_VerifyMethodP16_Jv_InterpMethod (/usr/lib/libgcj.so.6.0.0)
at ._ZN21_Jv_InterpreterEngine9do_verifyEPN4java4lang5ClassE (/usr/lib/libgcj.so.6.0.0)
at ._ZN10_Jv_Linker12verify_classEPN4java4lang5ClassE (/usr/lib/libgcj.so.6.0.0)
at ._ZN10_Jv_Linker14wait_for_stateEPN4java4lang5ClassEi (/usr/lib/libgcj.so.6.0.0)
...8 more
头像
Tenyears
帖子: 2245
注册时间: 2005-06-30 15:46
来自: 成都
送出感谢: 0
接收感谢: 0

#4

帖子 Tenyears » 2005-10-16 9:20

我的lumaqq能用。
Humanity to others // 己所不欲,勿施与人
Laptop: ThinkPad X220 --- Win7 Home / Ubuntu 12.04
Desktop: Win7/Ubuntu 12.04
Server: Ubuntu12.04
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#5

帖子 firehare » 2005-10-16 9:26

原因是你的/usr/bin/java没有指向/usr/lib/j2sdk1.5-sun/bin/java了
好象是用gcj代替了,原因当然是许可证的问题了!所以你只要在LumaQQ的起动脚本中直接写该路径,保证不但能启动,而且速度会快得多!
我心无畏,源自于我心无知。
图片
yee
帖子: 125
注册时间: 2005-08-14 18:16
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 yee » 2005-10-16 11:00

楼上的麻烦讲详细点
操作系统应该可以更优雅一些
头像
Arete
帖子: 74
注册时间: 2005-10-05 11:15
来自: http://bulaoge.com/?arete
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 Arete » 2005-10-16 15:44

搞定!
命令行:ln -sf /usr/lib/j2re1.5-sun/bin/java /usr/bin/java
不是:/usr/lib/j2sdk1.5-sun/bin/java,因为我装的不是j2sdk,而是j2se。
谢谢firehare!
头像
paul
帖子: 510
注册时间: 2005-09-01 20:48
送出感谢: 0
接收感谢: 0

#8

帖子 paul » 2005-10-16 16:52

恩,我的试试,先装J2SDK的先。
头像
max0000
帖子: 310
注册时间: 2005-04-08 14:54
送出感谢: 0
接收感谢: 0

#9

帖子 max0000 » 2005-10-16 19:36

我的能跑,但是对中文的种子信息没法识别。以前还可以列出几种中文编码来选一下,现在只有两个乱码了。
回复

回到 “因特网相关软件”