求助,chrome播放mp3的问题。

上网、浏览、聊天、下载等
回复
niu541412
帖子: 4
注册时间: 2012-04-16 16:38
送出感谢: 0
接收感谢: 0

求助,chrome播放mp3的问题。

#1

帖子 niu541412 » 2013-04-13 20:59

没有仔细搜索论坛,不知道有解决方法没。但是搜到有类似问题的
望高人指点。我就直接复制粘贴我的博客里的了。有点罗嗦.我的是ubuntu 12.04 64位

大概去年时发现用chrome播放豆瓣电台网页版,经常会变成滋滋啦啦的噪音。而且播放很久都不能回复正常状态。
播放某些在线视频的声音也是有这个问题的。
当时google半天的结果是,别人说是flash插件的问题,因为chrome是自带flash的。
只要在chrome://plugins这个页面下关掉自带的flash就行了,使用系统的就行了。
但是最近发现某些网页的mp3又有这个问题了。而且以上方法无效。
经过半天折腾,发现并不是flash的问题了。比如下面这两个mp3文件。
http://www.vizualrecords.com/wordpress/ ... 01_128.mp3
http://mr4.douban.com/201304131847/00a1 ... 394993.mp3
(如果后一个不能链接,可以试试这个http://media.shanbay.com/audio/us/test.mp3
前一个就能播,后面豆瓣电台的这个就是滋滋啦啦的噪音。
但并不是mp3本身的问题。因为这个如果是在网页版的豆瓣音乐里就能正常播放(因为豆瓣音乐是靠flash插件里mp3解码器的,而直接chrome调用的mp3解码器就有问题。)
下载下来后,系统播放器都能播放,但是观察系统的文件信息,你会发现两个文件的编码是不同的,见下图,
然后我试了很多个mp3文件,只要是是和后一种一样的,拖到chrome地址栏播放就是滋滋啦啦的声音。
QQ截图20130413203554.jpg
目前猜想是chrome的解码器的lib文件是有问题的。这个文件是/opt/google/chrome/libffmpegsumo.so。
但是我水平有限,搞不定。。。又或者ubuntu的解码器问题?但是自带的播放器和firefox是正常的
上次由 niu541412 在 2013-04-14 10:03,总共编辑 1 次。
头像
b33e
论坛版主
帖子: 3862
注册时间: 2011-06-07 14:20
系统: Mint18
送出感谢: 16 次
接收感谢: 62 次

Re: 求助,chrome播放mp3的问题。

#2

帖子 b33e » 2013-04-13 22:04

niu541412 写了:但是自带的播放器和firefox是正常的
那就好了啊
头像
温习江湖
帖子: 580
注册时间: 2012-06-06 18:20
送出感谢: 4 次
接收感谢: 11 次

Re: 求助,chrome播放mp3的问题。

#3

帖子 温习江湖 » 2013-04-14 7:17

应该是解码器的问题,楼主的问题我也遇到过。

我用的是chromium+pepflash这个组合。播放mp3一直是安装受限解码库解决。

曾经看到网上有人说chrome的那个ffmpeg的文件支持更多的格式,就人肉换过一次。出来了如描述症状,换回就好了。

楼主可以重装试试,要不也用chromium,需要chrome的什么东西就自己安装
Vimwiki建的小博客 wweir.org

历史的车轮压过一切,任何人或事物都留在了车辙里,只有思想和智慧或附在车辄上走上那么一段时间
头像
温习江湖
帖子: 580
注册时间: 2012-06-06 18:20
送出感谢: 4 次
接收感谢: 11 次

Re: 求助,chrome播放mp3的问题。

#4

帖子 温习江湖 » 2013-05-03 15:43

温习江湖 写了:应该是解码器的问题,楼主的问题我也遇到过。

我用的是chromium+pepflash这个组合。播放mp3一直是安装受限解码库解决。

曾经看到网上有人说chrome的那个ffmpeg的文件支持更多的格式,就人肉换过一次。出来了如描述症状,换回就好了。

楼主可以重装试试,要不也用chromium,需要chrome的什么东西就自己安装
我理解的错误,问题现象如楼主所言。

终端报错

代码: 全选

ALSA lib pcm.c:7963:(snd_pcm_set_params) Unable to get period size for PLAYBACK: 无效的参数
Vimwiki建的小博客 wweir.org

历史的车轮压过一切,任何人或事物都留在了车辙里,只有思想和智慧或附在车辄上走上那么一段时间
头像
nyfair
帖子: 1064
注册时间: 2007-12-07 12:49
系统: winnux10
来自: Tree New Bee
送出感谢: 2 次
接收感谢: 13 次

Re: 求助,chrome播放mp3的问题。

#5

帖子 nyfair » 2013-05-04 2:10

windows版chrome测试没有问题,3L应该就是正解
本人在此论坛仅负责吐槽,问题急需解决请支付宝转账5毛至{我的id@qq.com},将会竭诚为您服务

linux常见多媒体问题处理指南

1. 视频播放有问题->卸载gstreamer
2. 音频播放有问题->卸载pulseaudio
3. 远程播放有问题->卸载avahi
4. 系统全都有问题->卸载systemd,远离Lennart这傻逼让你从此轻松自在

⇩自由网络⇩
https://github.com/nyfair/freeweb
头像
温习江湖
帖子: 580
注册时间: 2012-06-06 18:20
送出感谢: 4 次
接收感谢: 11 次

Re: 求助,chrome播放mp3的问题。

#6

帖子 温习江湖 » 2013-05-24 17:53

找到症结,这次重装发现chromium居然对PulseAudio有依赖。

如果我没记错,应该是安装PulseAudio-alsa(安装系统过程中解决的,不方便记录,可能记错)解决问题
Vimwiki建的小博客 wweir.org

历史的车轮压过一切,任何人或事物都留在了车辙里,只有思想和智慧或附在车辄上走上那么一段时间
回复

回到 “因特网相关软件”