当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu 12.04 安装Chromium 问题
帖子发表于 : 2013-04-14 5:12 

注册: 2013-04-14 5:08
帖子: 3
系统: 12.04
送出感谢: 0 次
接收感谢: 0 次
Package dependencies cannot be resolved
This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time


The following packages have unmet dependencies:

chromium-browser: Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is to be installed
Depends: libudev0 (>= 147) but 175-0ubuntu9.2 is to be installed
Depends: zlib1g (>= 1:1.2.3.3.dfsg) but 1:1.2.3.4.dfsg-3ubuntu4 is to be installed


页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu 12.04 安装Chromium 问题
帖子发表于 : 2013-04-14 9:30 
头像

注册: 2009-12-12 19:29
帖子: 5059
地址: 随便一个地方
系统: 本地大型发行版除外
送出感谢: 0 次
接收感谢: 166
试试在新立得安装。


_________________
Github见!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu 12.04 安装Chromium 问题
帖子发表于 : 2013-04-14 19:24 

注册: 2013-04-14 5:08
帖子: 3
系统: 12.04
送出感谢: 0 次
接收感谢: 0 次
mraandtux 写道:
试试在新立得安装。

就是在新立得安装的出现这个错误,
自己下载google-chrome-stable_current_i386。deb包
手动安装 sudo dpkg -i google-chrome-stable_current_i386.deb
还是出现依赖包问题
sudo apt-get -f install 无果,这样直接把刚才未完全安装的会删掉。
不知到咋办


页首
 用户资料  
 
4 楼 
 文章标题 : Re: ubuntu 12.04 安装Chromium 问题
帖子发表于 : 2013-04-14 19:58 

注册: 2013-04-14 5:08
帖子: 3
系统: 12.04
送出感谢: 0 次
接收感谢: 0 次
已经解决 用aptitude

sudo aptitude install chromium-browser-l10n
The following NEW packages will be installed:
chromium-browser{a} chromium-browser-l10n chromium-codecs-ffmpeg{a}
libnss3-1d{ab}
0 packages upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 24.1 MB of archives. After unpacking 92.8 MB will be used.
The following packages have unmet dependencies:
libnss3-1d : Depends: libnss3 (= 3.13.1.with.ckbi.1.88-1ubuntu6) but 3.14.1-0ckbi1.93ubuntu.0.12.04.1 is installed.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
1) chromium-browser [Not Installed]
2) chromium-browser-l10n [Not Installed]
3) chromium-codecs-ffmpeg [Not Installed]
4) libnss3-1d [Not Installed]



Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

Downgrade the following packages:
1) libnss3 [3.14.1-0ckbi1.93ubuntu.0.12.04.1 (now) -> 3.13.1.with.ckbi.1.88-



Accept this solution? [Y/n/q/?] y
The following packages will be DOWNGRADED:
libnss3
The following NEW packages will be installed:
chromium-browser{a} chromium-browser-l10n chromium-codecs-ffmpeg{a} libnss3-1d{a}
0 packages upgraded, 4 newly installed, 1 downgraded, 0 to remove and 0 not upgraded.
Need to get 25.3 MB of archives. After unpacking 92.7 MB will be used.
Do you want to continue? [Y/n/?] y
Get: 1 http://cn.archive.ubuntu.com/ubuntu/ precise/main libnss3 i386 3.13.1.with.ckbi.1.88-1ubuntu6 [1,215 kB]
Get: 2 http://cn.archive.ubuntu.com/ubuntu/ precise/main libnss3-1d i386 3.13.1.with.ckbi.1.88-1ubuntu6 [13.4 kB]
Get: 3 http://cn.archive.ubuntu.com/ubuntu/ precise/universe chromium-codecs-ffmpeg i386 18.0.1025.151~r130497-0ubuntu1 [402 kB]
Get: 4 http://cn.archive.ubuntu.com/ubuntu/ precise/universe chromium-browser i386 18.0.1025.151~r130497-0ubuntu1 [21.7 MB]
Get: 5 http://cn.archive.ubuntu.com/ubuntu/ precise/universe chromium-browser-l10n all 18.0.1025.151~r130497-0ubuntu1 [2,041 kB]
Fetched 25.3 MB in 3min 13s (131 kB/s)
dpkg: warning: downgrading libnss3 from 3.14.1-0ckbi1.93ubuntu.0.12.04.1 to 3.13.1.with.ckbi.1.88-1ubuntu6.
(Reading database ... 213205 files and directories currently installed.)
Preparing to replace libnss3 3.14.1-0ckbi1.93ubuntu.0.12.04.1 (using .../libnss3_3.13.1.with.ckbi.1.88-1ubuntu6_i386.deb) ...
Unpacking replacement libnss3 ...
Selecting previously unselected package libnss3-1d.
Unpacking libnss3-1d (from .../libnss3-1d_3.13.1.with.ckbi.1.88-1ubuntu6_i386.deb) ...
Selecting previously unselected package chromium-codecs-ffmpeg.
Unpacking chromium-codecs-ffmpeg (from .../chromium-codecs-ffmpeg_18.0.1025.151~r130497-0ubuntu1_i386.deb) ...
Selecting previously unselected package chromium-browser.
Unpacking chromium-browser (from .../chromium-browser_18.0.1025.151~r130497-0ubuntu1_i386.deb) ...
Selecting previously unselected package chromium-browser-l10n.
Unpacking chromium-browser-l10n (from .../chromium-browser-l10n_18.0.1025.151~r130497-0ubuntu1_all.deb) ...
Processing triggers for man-db ...
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for gnome-menus ...
Processing triggers for hicolor-icon-theme ...
Setting up libnss3 (3.13.1.with.ckbi.1.88-1ubuntu6) ...
Setting up libnss3-1d (3.13.1.with.ckbi.1.88-1ubuntu6) ...
Setting up chromium-codecs-ffmpeg (18.0.1025.151~r130497-0ubuntu1) ...
Setting up chromium-browser (18.0.1025.151~r130497-0ubuntu1) ...
Setting up chromium-browser-l10n (18.0.1025.151~r130497-0ubuntu1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place


页首
 用户资料  
 
5 楼 
 文章标题 : Re: ubuntu 12.04 安装Chromium 问题
帖子发表于 : 2013-04-28 2:34 

注册: 2007-09-16 9:55
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
谢谢 搜索了半天找到这个帖子 我也解决了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译