无线网卡的问题

上网、浏览、聊天、下载等
回复
ubantu
帖子: 154
注册时间: 2007-03-01 22:54
送出感谢: 0
接收感谢: 0

无线网卡的问题

#1

帖子 ubantu » 2007-03-29 22:14

我电脑无线网卡驱动正常的,但是连接有问题,哪位高人指点一下阿.

jiang@jiang-laptop:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 802.11b ESSID:"jiang"
Mode:Managed Frequency:2.422 GHz Access Point: Not-Associated
Bit Rate=11 Mb/s Sensitivity=80/85
Retry:on Fragment thr:off
Power Management:off
Link Quality:31/100 Signal level:-114 dBm Noise level:-187 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.


也能找到网络,
jiang@jiang-laptop:~$ iwlist scanning
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wlan0 Scan completed :
Cell 01 - Address: 02:19:D2:00:7F:F2
ESSID:"hp"
Protocol:IEEE 802.11bg
Mode:Ad-Hoc
Channel:11
Encryption key:on
Bit Rates:54 Mb/s
Extra: Rates (Mb/s): 1 2 5.5 6 9 11 12 18 24 36 48 54
Quality:223 Signal level:0 Noise level:99
Extra: Last beacon: 727ms ago


可是就是连接不上.
jiang@jiang-laptop:~$ route
内核 IP 路由表
目标 网关 子网掩码 标志 跃点 引用 使用 接口
192.168.0.0 * 255.255.255.0 U 0 0 0 wlan0
default 192.168.0.1 0.0.0.0 UG 0 0 0 wlan0


jiang@jiang-laptop:~$ ifconfig
eth0 链路封装:以太网 硬件地址 00:C0:9F:72:2F:3F
UP BROADCAST MULTICAST MTU:1500 跃点数:1
接收数据包:0 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:0 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:1000
接收字节:0 (0.0 b) 发送字节:0 (0.0 b)
中断:193 基本地址:0x6800

lo 链路封装:本地环回
inet 地址:127.0.0.1 掩码:255.0.0.0
inet6 地址: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 跃点数:1
接收数据包:34 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:34 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:0
接收字节:2500 (2.4 KiB) 发送字节:2500 (2.4 KiB)

wlan0 链路封装:以太网 硬件地址 00:20:ED:07:98:DE
inet 地址:192.168.0.2 广播:192.168.0.255 掩码:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 跃点数:1
接收数据包:0 错误:0 丢弃:538 过载:0 帧数:0
发送数据包:232 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:1000
接收字节:0 (0.0 b) 发送字节:8584 (8.3 KiB)
中断:169 Memory:f8aea000-f8aea100
ziyun
帖子: 262
注册时间: 2007-03-29 12:59
送出感谢: 0
接收感谢: 0

#2

帖子 ziyun » 2007-03-30 22:00

你设置DNS了吗,我第一次装linux时指定了ip和网关没设置DNS只能访问局域网,不能访问外网
DNS在/etc/resolv.conf中指定一般是网关地址
格式这样的
nameserver 192.168.0.1
ubantu
帖子: 154
注册时间: 2007-03-01 22:54
送出感谢: 0
接收感谢: 0

#3

帖子 ubantu » 2007-03-31 17:54

gateway 已经设了,可是就是不能连接,郁闷。
头像
RegentW
帖子: 1486
注册时间: 2007-02-27 21:47
来自: NN
送出感谢: 2 次
接收感谢: 0

#4

帖子 RegentW » 2007-04-03 20:35

ESSID要一致才能连通吧
找到一个AP记下名称,把你自己的ESSID设成一样的名称试试
Core i5, 512G + SSD 20G, DDRIII 8G
zhengw
帖子: 62
注册时间: 2006-09-21 9:42
送出感谢: 0
接收感谢: 0

#5

帖子 zhengw » 2007-04-06 9:43

我也遇到同样问题,能找到网络,就是连不上,请高手指点啊
无线设置已经查过很多遍了,应该是没有问题的。
zhengw
帖子: 62
注册时间: 2006-09-21 9:42
送出感谢: 0
接收感谢: 0

#6

帖子 zhengw » 2007-04-06 12:30

最奇怪的是除了ath0之外又多出了一个wifi0, 硬件地址和ath0相似,只不过后面又有N个00。这是怎么回事呢?会不会和我不能连上有关系?

w@zw-bookpc:~$ ifconfig
ath0 链路封装:以太网 硬件地址 00:0E:9B:A3:74:E0
inet 地址:192.168.0.11 广播:192.168.0.255 掩码:255.255.255.0
inet6 地址: fe80::20e:9bff:fea3:74e0/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 跃点数:1
接收数据包:229 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:21 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:0
接收字节:15219 (14.8 KiB) 发送字节:2675 (2.6 KiB)

wifi0 链路封装:未指定 硬件地址 00-0E-9B-A3-74-E0-00-00-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 跃点数:1
接收数据包:6728 错误:0 丢弃:0 过载:0 帧数:4
发送数据包:36 错误:2 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:199
接收字节:825623 (806.2 KiB) 发送字节:3681 (3.5 KiB)
中断:16
回复

回到 “因特网相关软件”