firefox 54 垂直滑条问题!

上网、浏览、聊天、下载等
回复
头像
xw712
帖子: 482
注册时间: 2009-04-25 9:26
送出感谢: 0
接收感谢: 3 次

firefox 54 垂直滑条问题!

#1

帖子 xw712 » 2017-07-16 14:13

linuxmint 18.2,自带firefox 54,以前我只用27版本。

右边垂直滑条是拉动页面的,以前,鼠标左键点击滑条下面,页面往下滑一页(类似pagedown)。但是现在不同了,页面会滑到鼠标点击处,指哪就滑到哪!
头像
tang.zhe
帖子: 1423
注册时间: 2010-07-15 13:31
送出感谢: 71 次
接收感谢: 22 次

Re: firefox 54 垂直滑条问题!

#2

帖子 tang.zhe » 2017-07-17 11:02

按下空格键试试?
头像
xw712
帖子: 482
注册时间: 2009-04-25 9:26
送出感谢: 0
接收感谢: 3 次

Re: firefox 54 垂直滑条问题!

#3

帖子 xw712 » 2017-07-17 18:36

tang.zhe 写了:按下空格键试试?
no work
头像
astolia
论坛版主
帖子: 3013
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 495 次

Re: firefox 54 垂直滑条问题!

#4

帖子 astolia » 2017-07-17 20:29

这跟firefox没关系,是gtk3的锅。现在firefox已经是用gtk3编译的了,滚动条的行为也是gtk3默认的行为。
如果怀念gtk2时代的行为,可以自己修改gtk3配置文件~/.config/gtk-3.0/settings.ini,给Settings段加上gtk-primary-button-warps-slider = false

代码: 全选

[Settings]
gtk-primary-button-warps-slider = false
头像
xw712
帖子: 482
注册时间: 2009-04-25 9:26
送出感谢: 0
接收感谢: 3 次

Re: firefox 54 垂直滑条问题!

#5

帖子 xw712 » 2017-07-22 18:12

astolia 写了:这跟firefox没关系,是gtk3的锅。现在firefox已经是用gtk3编译的了,滚动条的行为也是gtk3默认的行为。
如果怀念gtk2时代的行为,可以自己修改gtk3配置文件~/.config/gtk-3.0/settings.ini,给Settings段加上gtk-primary-button-warps-slider = false

代码: 全选

[Settings]
gtk-primary-button-warps-slider = false
目录下没有setting.ini文件。

就算是我自己加了,还是不行啊!

=== chrome完全没有这个问题,点一下翻一下。
头像
vickycq
论坛版主
帖子: 4552
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 994 次
联系:

Re: firefox 54 垂直滑条问题!

#6

帖子 vickycq » 2017-07-22 18:50

多换几个gtk3主题试试
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
buntutu
帖子: 61
注册时间: 2009-11-25 1:38
送出感谢: 0
接收感谢: 6 次

Re: firefox 54 垂直滑条问题!

#7

帖子 buntutu » 2017-07-22 21:29

shift-左键
头像
xw712
帖子: 482
注册时间: 2009-04-25 9:26
送出感谢: 0
接收感谢: 3 次

Re: firefox 54 垂直滑条问题!

#8

帖子 xw712 » 2017-07-27 17:56

buntutu 写了:shift-左键
还真是!
回复

回到 “因特网相关软件”