哪位大佬能帮帮我啊。。安装minidwep时,依赖库不能安装

上网、浏览、聊天、下载等
回复
asd2019
帖子: 2
注册时间: 2017-09-17 6:26
系统: ubuntu
送出感谢: 0
接收感谢: 0

哪位大佬能帮帮我啊。。安装minidwep时,依赖库不能安装

#1

帖子 asd2019 » 2017-09-17 6:45

安装minidwep时,依赖库不能安装
这个是截图
图片
poloshiao
论坛版主
帖子: 18274
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1948 次

Re: 哪位大佬能帮帮我啊。。安装minidwep时,依赖库不能安装

#2

帖子 poloshiao » 2017-09-17 7:33

終端機指令及文字回應 不必擷圖 直接複製貼上來
asd2019
帖子: 2
注册时间: 2017-09-17 6:26
系统: ubuntu
送出感谢: 0
接收感谢: 0

Re: 哪位大佬能帮帮我啊。。安装minidwep时,依赖库不能安装

#3

帖子 asd2019 » 2017-09-17 10:08

poloshiao 写了:終端機指令及文字回應 不必擷圖 直接複製貼上來
linuxidc@www:~$ sudo apt-get install build-essential libssl-dev iw libpcap-dev sqlite3 libsqlite3-dev libpcap0.8-dev libssl0.9.8 libnl libnl-dev
[sudo] linuxidc 的密码:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
E: 无法定位软件包 libnl
linuxidc@www:~$ sudo apt-get install build-essential libssl-dev iw libpcap-dev sqlite3 libsqlite3-dev libpcap0.8-dev libssl0.9.8
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
build-essential 已经是最新版 (12.1ubuntu2)。
iw 已经是最新版 (3.17-1)。
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
libssl-dev : 依赖: libssl1.0.0 (= 1.0.2g-1ubuntu4) 但是 1.0.2g-1ubuntu4.8 正要被安装
依赖: zlib1g-dev 但是它将不会被安装
推荐: libssl-doc 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。
linuxidc@www:~$ sudo dpkg -i aircrack-ng_1.0-1_amd64.deb
正在选中未选择的软件包 aircrack-ng。
(正在读取数据库 ... 系统当前共安装有 211670 个文件和目录。)
正准备解包 aircrack-ng_1.0-1_amd64.deb ...
正在解包 aircrack-ng (1:1.0-1) ...
dpkg: 依赖关系问题使得 aircrack-ng 的配置工作不能继续:
aircrack-ng 依赖于 libssl0.9.8 (>= 0.9.8f-5);然而:
未安装软件包 libssl0.9.8。

dpkg: 处理软件包 aircrack-ng (--install)时出错:
依赖关系问题 - 仍未被配置
正在处理用于 man-db (2.7.5-1) 的触发器 ...
在处理时有错误发生:
aircrack-ng
linuxidc@www:~$
回复

回到 “因特网相关软件”