[问题]运行qbittorrent失败,请问是怎么回事?

上网、浏览、聊天、下载等
回复
永恒不永恒
帖子: 124
注册时间: 2007-03-17 18:57
来自: 广东广州
送出感谢: 0
接收感谢: 0

[问题]运行qbittorrent失败,请问是怎么回事?

#1

帖子 永恒不永恒 » 2007-04-28 21:20

我编译并安装了qbittorrent,但是为何还是无法运行qbittorrent?

代码: 全选

xzw@VIA-PC1500:~/BT_Download/qbittorrent-0.9.2$ sudo ./configure
Configuring qbittorrent ...
Verifying Qt 4 build environment ... ok
Checking for Qt >= 4.2 ... yes
Checking for libtorrent >= 0.11 (>= 0.12 ADVISED) ...Libtorrent >= v0.12 was not detected, PeX will be disabled.
 yes
Checking for libboost ... yes
Checking for libcurl ... yes
Checking for python >= 2.3 ... yes

Good, your configure finished.  Now run /usr/bin/make.

xzw@VIA-PC1500:~/BT_Download/qbittorrent-0.9.2$

xzw@VIA-PC1500:~/BT_Download/qbittorrent-0.9.2$ sudo make && sudo make install
cd src && make -f Makefile
make[1]: Entering directory `/home/xzw/BT_Download/qbittorrent-0.9.2/src'
make[1]: Nothing to be done for `first'.
make[1]: Leaving directory `/home/xzw/BT_Download/qbittorrent-0.9.2/src'
cd src && make -f Makefile install
make[1]: Entering directory `/home/xzw/BT_Download/qbittorrent-0.9.2/src'
install -m 755 -p "qbittorrent" "/usr/local/bin/qbittorrent"
strip "/usr/local/bin/qbittorrent"
install -m 644 -p /home/xzw/BT_Download/qbittorrent-0.9.2/doc/qbittorrent.1.gz /usr/local/share/man/man1/
install -m 644 -p /home/xzw/BT_Download/qbittorrent-0.9.2/src/Icons/qBittorrent.desktop /usr/local/share/applications/
cp -f -r /home/xzw/BT_Download/qbittorrent-0.9.2/src/menuicons/128x128 /usr/local/share/icons/hicolor/
cp -f -r /home/xzw/BT_Download/qbittorrent-0.9.2/src/menuicons/16x16 /usr/local/share/icons/hicolor/
cp -f -r /home/xzw/BT_Download/qbittorrent-0.9.2/src/menuicons/192x192 /usr/local/share/icons/hicolor/
cp -f -r /home/xzw/BT_Download/qbittorrent-0.9.2/src/menuicons/22x22 /usr/local/share/icons/hicolor/
cp -f -r /home/xzw/BT_Download/qbittorrent-0.9.2/src/menuicons/24x24 /usr/local/share/icons/hicolor/
cp -f -r /home/xzw/BT_Download/qbittorrent-0.9.2/src/menuicons/32x32 /usr/local/share/icons/hicolor/
cp -f -r /home/xzw/BT_Download/qbittorrent-0.9.2/src/menuicons/36x36 /usr/local/share/icons/hicolor/
cp -f -r /home/xzw/BT_Download/qbittorrent-0.9.2/src/menuicons/48x48 /usr/local/share/icons/hicolor/
cp -f -r /home/xzw/BT_Download/qbittorrent-0.9.2/src/menuicons/64x64 /usr/local/share/icons/hicolor/
cp -f -r /home/xzw/BT_Download/qbittorrent-0.9.2/src/menuicons/72x72 /usr/local/share/icons/hicolor/
cp -f -r /home/xzw/BT_Download/qbittorrent-0.9.2/src/menuicons/96x96 /usr/local/share/icons/hicolor/
make[1]: Leaving directory `/home/xzw/BT_Download/qbittorrent-0.9.2/src'
xzw@VIA-PC1500:~/BT_Download/qbittorrent-0.9.2$

xzw@VIA-PC1500:~/BT_Download/qbittorrent-0.9.2$ qbittorrent
qbittorrent: error while loading shared libraries: libtorrent.so.0: cannot open shared object file: No such file or directory
xzw@VIA-PC1500:~/BT_Download/qbittorrent-0.9.2$
看提示好像应该是找不到libtorrent库的问题,但是我之前也同样 make install 了 libtorrent 0.11版本了。
我用ubuntu 6.06,gnome桌面~
结果装个qBittorrent搞不定,
然后就换到ubuntu 7.04了..同样是gnome桌面~
定制才是王道!
wu9506
帖子: 29
注册时间: 2007-04-27 15:00
送出感谢: 0
接收感谢: 0

#2

帖子 wu9506 » 2007-05-04 23:54

设置LD_LIBRARY_PATH,LD_RUN_PATH环境变量
回复

回到 “因特网相关软件”