[问题]rtorrent 编译出现错误

上网、浏览、聊天、下载等
回复
260009610
帖子: 7
注册时间: 2007-05-30 22:52
送出感谢: 0
接收感谢: 0
联系:

[问题]rtorrent 编译出现错误

#1

帖子 260009610 » 2007-05-30 22:54

checking for STUFF... Unknown keyword 'URL' in '/usr/local/lib/pkgconfig/libcurl.pc'
configure: error: Package requirements (sigc++-2.0 libcurl >= 7.12.0 libtorrent >= 0.11.3) were not met:



Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables STUFF_CFLAGS
and STUFF_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


其中
/usr/local/lib/pkgconfig
目录已经包含了

libcurl.pc
libtorrent.pc
sigc++-2.0.pc
这3个文件,但还是编译不了。。是什么原因呀?

我的系统是centos的。。
头像
zmcbb30
帖子: 2717
注册时间: 2006-09-30 0:32
来自: 巴拉特星系第四行星──海尼森
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 zmcbb30 » 2007-05-31 13:04

注意这两个的版本
libcurl.pc libtorrent.pc
头可断,血可流,靓女不可不追求
相艾唔好口,够姜就只抽

BARTON 2500+/1536MDDR400
EP8RDA3G/MX4000 128M64bit 8X
DiamondPlus9-6Y080L0-ATA133
Samsung743DF
HiweedDesktop-1.0
260009610
帖子: 7
注册时间: 2007-05-30 22:52
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 260009610 » 2007-05-31 18:53

libtorrent.pc
是libtorrent-0.11.4

libcurl.pc
是curl-7.16.2

都是最新版了的啊

试了N个办法还是不行
回复

回到 “因特网相关软件”