[原创]编译安装mldonkey2.9.2

上网、浏览、聊天、下载等
回复
头像
haige
帖子: 315
注册时间: 2006-03-16 16:29
送出感谢: 0
接收感谢: 0

[原创]编译安装mldonkey2.9.2

#1

帖子 haige » 2007-10-26 11:05

1 安装apt-get install ocaml-native-compilers
2 下载mldonkey-2.9.2.tar.bz2
http://downloads.sourceforge.net/mldonk ... g_mirror=0
3 解压,进入mldonkey-2.9.2
4 ./configure --enable-batch --disable-gui
5 make
下面的不用我说了吧
消除浮躁,静心学习,每天都在进步。
头像
ibear
帖子: 787
注册时间: 2006-10-19 8:43
来自: 长江口
送出感谢: 1 次
接收感谢: 2 次

#2

帖子 ibear » 2007-10-26 19:31

如果我要gui,应该怎么弄?

我编译安装了labelgtk,也加了--enable-gui,但configure似乎找不到,最后也没有make出gui来
头像
kqueenc
帖子: 630
注册时间: 2007-05-27 20:29
送出感谢: 0
接收感谢: 0

#3

帖子 kqueenc » 2007-10-26 19:46

用SANCHO不就行了嘛?
lisir
帖子: 1187
注册时间: 2006-04-29 14:54
来自: 山东
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 lisir » 2007-10-26 22:46

编译出来的mlnet却无法在浏览器中查看Bandwidth stats,提示“Gd support was not compiled”,搜索后才知道需要安装一个libgd2-dev之类的包,但在新立得中搜索却没有,去掉dev找到并安装libgd2-xpm和libgd2-xpm-dev。重新编译mldonkey.
需要安装的库:
libbz2-dev:支持bzip2
libmagic-dev:支持libmagic
libpthread-stubs0-dev:thread support
libclthread2-dev
libgtk2.0-dev:
libiconv-hook-dev:
librsvg2-dev


代码: 全选

./configure --enable-batch --enable-pthread-lib 
make
学会看置顶帖、精华帖。
学会使用搜索。
常见问题解答和发帖需知
头像
haige
帖子: 315
注册时间: 2006-03-16 16:29
送出感谢: 0
接收感谢: 0

#5

帖子 haige » 2007-10-27 22:21

我不用gui.
我是在老版本上直接覆盖安装的,没什么问题.
消除浮躁,静心学习,每天都在进步。
willie1981
帖子: 3
注册时间: 2006-08-24 6:38
送出感谢: 0
接收感谢: 0

#6

帖子 willie1981 » 2007-11-01 3:12

头像
vvoody
帖子: 749
注册时间: 2007-01-21 20:10
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 vvoody » 2007-11-01 14:00

怎么流行用叶子作头像
头像
qkthomas
帖子: 503
注册时间: 2006-12-16 22:05
来自: 肇庆
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 qkthomas » 2007-11-15 18:57

要gui不用输入命令,本来就会安装gui
回复

回到 “因特网相关软件”