当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]Lumaqq在amd64下不能起动
帖子发表于 : 2006-01-18 12:25 

注册: 2006-01-18 11:42
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
~/LumaQQ$ Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/cgtong/LumaQQ/swt/libswt-pi-gtk-3138.so: /home/cgtong/LumaQQ/swt/libswt-pi-gtk-3138.so: cannot open shared object file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(Unknown Source)
at java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.lang.Runtime.loadLibrary0(Unknown Source)
at java.lang.System.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:19)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
at org.eclipse.swt.widgets.Display.<clinit>(Display.java:122)
at edu.tsinghua.lumaqq.ui.MainShell.<init>(MainShell.java:167)
at edu.tsinghua.lumaqq.LumaQQ.main(LumaQQ.java:117)

这是错误信息
请帮助


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-01-19 8:29 
头像

注册: 2005-06-21 20:24
帖子: 715
地址: 甘肃
送出感谢: 0 次
接收感谢: 0 次
跟amd64没关系啦
是java没有设置正确的原故


_________________
ubuntu 6.06
我是初学者 大家多多关照


页首
 用户资料  
 
3 楼 
 文章标题 : 我还是无法解决
帖子发表于 : 2006-01-20 10:03 

注册: 2006-01-18 11:42
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
java以安装,但还是那个错误,我在命令行里打java也有信息


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-01-20 21:06 
头像

注册: 2005-09-22 10:15
帖子: 570
地址: 北京
送出感谢: 0 次
接收感谢: 0 次
看样子要么是jdk的路径没有设置对,或者你的LumaQQ没有下载全,再或者就是你试图运行别人目录下的qq。

试试:
$ export JAVA_HOME=/usr/lib/j2sdk1.5-sun
$ sudo chown cgtong:cgtong /home/cgtong/LumaQQ -R
$ /home/cgtong/LumaQQ/lumaqq


_________________
空手把锄头,步行骑水牛;人在桥上过,人流水不流。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-12-27 23:54 

注册: 2005-08-19 21:46
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
**#sudo update-alternatives --config java
There are 2 alternatives which provide `java'.

Selection Alternative
-----------------------------------------------
+ 1 /usr/lib/jvm/ia32-java-1.5.0-sun/jre/bin/java
* 2 /usr/lib/jvm/java-1.5.0-sun/jre/bin/java
选 1 即可


页首
 用户资料  
 
6 楼 
 文章标题 : 搞定QQ:GNOME X86_64环境下编译安装eva0.4.1
帖子发表于 : 2007-01-03 0:42 
头像

注册: 2006-02-05 13:53
帖子: 120
送出感谢: 0 次
接收感谢: 0 次
搞定QQ:GNOME X86_64环境下编译安装eva0.4.1

由于使用的是SUSE 10.1 X86_64的系统,又是在GNOME环境下,所以QQ一直是个问题。偏偏LUMA QQ突然挂了,让我一下不知道如何联系好友了。因为玩 Ubuntu6.06的时候使用过EVA,所以对它情有独钟,经过一晚上折腾终于搞定了 EVA。
以下是我整理的网上资料,经过实践检验确实可行,给想在 GNOME下使用 EVA但是尚未成功的朋友,相信大家一定也可以做到!

(1) 前期准备:

系统安装
(下面组件在编译时要用到,其版本号是参考值,系统上的安装版本必须高于或至少等于它们):

arts-devel-1.3.1-2
kdelibs-3.3.1-3.2
kdelibs-devel-3.3.1-3.2
pcre-devel-4.5-3
qt-3.3.3-9.3
qt-devel-3.3.3-9.3

下载:
eva-0.4.1.tar.bz2 下载地址:http://software.lupaworld.com/show.php?id=147

(2) 解压缩、编译安装
# tar jxvf eva-0.4.1.tar.bz2
# cd /eva
# ./configure --with-qt-dir=/usr/lib/qt3 --with-qt-includes=/usr/lib/qt3/include --with-qt-libs=/usr/lib/qt3/lib64 --enable-libsuffix=64 --prefix=`kde-config --prefix`

然后就是等待........

# make

再等会儿................

# make install

等到最后................

#

^_^ 可以用了

整个过程中的 # ./configure是成败关键。
常见出错就是 Qt... configure: error: Qt (>= Qt 3.0) (headers and libraries) not found. Please check your installation!
主要问题就是configure时参数没有写全,所以要把dir、includes、libraries都写全才行的!

参考文章:
(1) 在RHEL4的GNOME环境下编译安装eva0.4.1
网址:http://blog.csdn.net/scottsiu/archiv...8/1297853.aspx

(2) 求助:SuSE 10.1 x86_64编译qterm-0.4.0和eva报错!
网址:http://www.linuxsir.org/bbs/printthread.php?t=270277


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译