当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : amule编译教程
帖子发表于 : 2007-11-20 18:43 

注册: 2007-05-17 13:41
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
amule用源里的deb包安装完后有好多问题,现在编译安装最新版可以完美的解决这些问题。
首先下载最新的CVS源码http://www.hirnriss.net/?area=cvs

不过aMule有两个特殊的开发包需要我们安装,在终端下安装(假如你从来没有安装过编译环境,还需要安装build-essential):
sudo apt-get install libwxbase2.8-dev libwxgtk2.8-dev
安装好后,就可以进入解压后的amule-cvs,依次执行:

./configure --prefix=/usr
make
sudo make install

编译并安装以后,就可以在“应用程序”-“Internet”找到aMule了。。
。/configure的时间遇到了些问题,说zlib错误。可以到http://sourceforge.net/project/downloading.php?groupname=libpng&filename=zlib-1.2.3.tar.gz&use_mirror=jaist
下载zlib,然后
./configure
make
sudo make install
解决这个问题。
编译完成后kad可以瞬间连上并且下载。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-12-01 2:10 
头像

注册: 2007-11-06 22:58
帖子: 149
地址: 武汉
送出感谢: 0 次
接收感谢: 0 次
这个文章好像是转载的吧


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-12-01 13:38 
头像

注册: 2007-11-26 22:40
帖子: 132
送出感谢: 0 次
接收感谢: 0 次
下载zlib后怎么样呢


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-12-01 14:04 
头像

注册: 2007-11-26 22:40
帖子: 132
送出感谢: 0 次
接收感谢: 0 次
呵呵整好了原来zlib也要./configure 一次啊


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-12-01 14:05 
头像

注册: 2007-11-26 22:40
帖子: 132
送出感谢: 0 次
接收感谢: 0 次
不过还是不能连上服务器呢


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-12-01 23:11 

注册: 2007-04-24 21:43
帖子: 165
送出感谢: 0 次
接收感谢: 0 次
我的amule怎么就突然打不开了呢?点它什么反映都没有,执行 $ amule
结果出来这堆这个:
代码:
Initialising aMule
Checking if there is an instance already running...
No other instances are running.
        aMule Version: aMule CVS using wxGTK2 v2.8.4 (Snapshot: Fri Nov 30 07:01:54 CET 2007)

Terminated after throwing an instance of 'CInvalidStateEx'
        what(): CRunTimeException::CInvalidStateException: CFile: Cannot get length of closed file.
        backtrace:
[2] CamuleApp::OnUnhandledException() in amule.cpp:2137
[3] wxEntry(int&, wchar_t**) in /usr/lib/libwx_baseu-2.8.so.0[0xb7a0d29d]
[4] wxEntry(int&, char**) in /usr/lib/libwx_baseu-2.8.so.0[0xb7a0d307]
[5] main in amule-gui.cpp:95
[6] __libc_start_main in /lib/tls/i686/cmov/libc.so.6[0xb7718050]
[7] wxAppBase::MainLoop() in amule[0x8071ed1]

忽略


无论是从源里安装2.13版本,还是跟楼主说的一样下载源代码编译,结果都是这样!我还有那么多数据没下完呢~~
各位高手有解决方案吗?
谢谢!!!


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-12-02 18:17 

注册: 2006-09-20 19:56
帖子: 768
送出感谢: 0 次
接收感谢: 1
源码里面不是有现成的debian目录么,最好不要sudo make install。

sudo apt-get install fakeroot
dpkg-buildpackage -rfakeroot

然后安装生成的包。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译