安装eva-0.4.1的依赖问题

上网、浏览、聊天、下载等
回复
arxor
帖子: 40
注册时间: 2005-12-13 23:00
送出感谢: 0
接收感谢: 0

安装eva-0.4.1的依赖问题

#1

帖子 arxor » 2006-02-13 17:09

kdelibs4c2a
是什么包?安装ubuntu中文源里的eva-0.4.1时出现的,找不到这个包呢

下列的软件包有不能满足的依赖关系:
eva: 预依赖: kdelibs4c2a 但却无法安装它
The Toilet Paper Problem
Donald E. Knuth
The American Mathematical Monthly, Vol. 91, No. 8 (Oct., 1984), pp. 465-470

Feisty 7.04 on ASUS Z99H56JN-SL with Core 2 Duo T5600/ 1GB/ 120GB/ 7300 go
头像
yang119345
帖子: 570
注册时间: 2005-06-19 14:22
来自: 上海
送出感谢: 0
接收感谢: 1 次
联系:

#2

帖子 yang119345 » 2006-02-13 21:37

头像
dongmh
帖子: 715
注册时间: 2005-06-21 20:24
来自: 甘肃
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 dongmh » 2006-02-13 22:53

上面个是我亲手用checkinstall做得

我做得第一个deb阿 :D :D
ubuntu 6.06
我是初学者 大家多多关照
arxor
帖子: 40
注册时间: 2005-12-13 23:00
送出感谢: 0
接收感谢: 0

#4

帖子 arxor » 2006-02-14 11:58

to yang119345:

我的系统装有kdelibs4c2,它要求的是kdelibs4c2a
运行eva没有问题,但是系统标记它依赖性没有解决依赖性,apt-get总要提示把它删掉,

链接里的包是可以用的,家里就是用这个,现在出问题的是cvs-20060204

to dongmh:

用checkinstall做的么?
似乎用这个做的都没有带有依赖性检查的,只是跟踪安装脚本记录文件的拷贝安装然后打包...
The Toilet Paper Problem
Donald E. Knuth
The American Mathematical Monthly, Vol. 91, No. 8 (Oct., 1984), pp. 465-470

Feisty 7.04 on ASUS Z99H56JN-SL with Core 2 Duo T5600/ 1GB/ 120GB/ 7300 go
头像
roylez
论坛版主
帖子: 1928
注册时间: 2005-10-04 10:59
来自: 上海
送出感谢: 0
接收感谢: 1 次

#5

帖子 roylez » 2006-02-14 13:25

checkinstall应该有依赖型检查的吧。
它会自己帮你做make和make install的事情,如果依赖型没有解决,应该是不能成功打包的。
弄个dropbox空间来备份文件或者做私人代码服务器
配置:[url]git://github.com/roylez/dotfiles.git[/url]
主页:http://roylez.heroku.com
各种稀奇玩意儿:http://dooloo.info
头像
dongmh
帖子: 715
注册时间: 2005-06-21 20:24
来自: 甘肃
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 dongmh » 2006-02-14 20:10

没有问题的

经过南湖乐善的小米帮助测试了

我自己为了解决兼容性问题 下载了小半个kde

因为那些东西删不掉还特别重装了系统 :)
ubuntu 6.06
我是初学者 大家多多关照
arxor
帖子: 40
注册时间: 2005-12-13 23:00
送出感谢: 0
接收感谢: 0

#7

帖子 arxor » 2006-02-15 16:32

nkzealot 写了:checkinstall应该有依赖型检查的吧。
它会自己帮你做make和make install的事情,如果依赖型没有解决,应该是不能成功打包的。
看了这个

viewtopic.php?t=9470

似乎没有记录依赖性信息吧,文中最后这样说:
当然,你得考虑软件包的相互依赖性,不过,这在同类的机器上一般并不是什么问题。
The Toilet Paper Problem
Donald E. Knuth
The American Mathematical Monthly, Vol. 91, No. 8 (Oct., 1984), pp. 465-470

Feisty 7.04 on ASUS Z99H56JN-SL with Core 2 Duo T5600/ 1GB/ 120GB/ 7300 go
glorry
帖子: 72
注册时间: 2006-02-21 15:25
送出感谢: 0
接收感谢: 0

#8

帖子 glorry » 2006-03-24 12:25

error while loading shared libraries: libkhtml.so.4: cannot open shared object file: No such file or directory

under gnome
回复

回到 “因特网相关软件”