[问题]开启ATI7.11驱动的对FIGLX的支持后,播放影片屏幕闪烁

Totem,mplayer,sopcast,realplayer,bmp
回复
Awper
帖子: 19
注册时间: 2007-11-22 0:32
送出感谢: 0
接收感谢: 0

[问题]开启ATI7.11驱动的对FIGLX的支持后,播放影片屏幕闪烁

#1

帖子 Awper » 2008-01-10 11:49

开启ATI7.11驱动的对FIGLX的支持后,播放影片屏幕闪烁

如题,就连播放音乐时开启可视化效果都闪,请问题能解决不
dorice
帖子: 94
注册时间: 2006-06-22 1:52
送出感谢: 0
接收感谢: 0

#2

帖子 dorice » 2008-01-10 13:04

totem修改~/.gnome2/Totem/xine_config,找到#video.driver:auto改成video.driver:xshm,注意把#去掉
mplayer直接在选项里面修改video驱动为XImage/Shm
Awper
帖子: 19
注册时间: 2007-11-22 0:32
送出感谢: 0
接收感谢: 0

#3

帖子 Awper » 2008-01-10 13:30

XImage/Shm就不能全屏啦
头像
jarryson
帖子: 4002
注册时间: 2005-08-14 19:53
送出感谢: 1 次
接收感谢: 2 次
联系:

#4

帖子 jarryson » 2008-01-10 22:42

开启ati的xv。需要在xorg.conf里面添加,记得如果有的,直接加进去就好了

代码: 全选

Section "Device"
        ...
   Option       "OpenGLOverlay" "off"   #这个是关闭视频opengl加速的。应该可以不需要这句
   Option       "VideoOverlay" "on"    #这个是开启xv加速的
        ...
Section "Device"


代码: 全选

Section "Extensions"
   Option      "XVideo" "Enable"  #这个是开启xv的
   Option       "Composite" "Enable"   #这个是开启混合的,可以选择不开。
EndSection


ati如果不这样设置,看电影会很卡
dorice
帖子: 94
注册时间: 2006-06-22 1:52
送出感谢: 0
接收感谢: 0

#5

帖子 dorice » 2008-01-10 23:16

开启了xv照样闪,不过我的totem用xshm可以全屏阿!
头像
henry_yue
帖子: 35
注册时间: 2006-07-11 18:25
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 henry_yue » 2008-02-12 14:46

我的问题一样啊 ?有解决办法吗?
liangyichina
帖子: 29
注册时间: 2007-11-25 12:07
送出感谢: 0
接收感谢: 0
联系:

Re: [问题]开启ATI7.11驱动的对FIGLX的支持后,播放影片屏幕闪烁

#7

帖子 liangyichina » 2008-02-21 19:34

Awper 写了:开启ATI7.11驱动的对FIGLX的支持后,播放影片屏幕闪烁

如题,就连播放音乐时开启可视化效果都闪,请问题能解决不


我的也是!自从安装新的ati驱动8.02后就出现了!

不能正常播放电影!3D cube的时候也会出现闪烁!而且屏幕会出现斜的屏裂(图像被一斜条线切开)!

不知道有什么办法!?
头像
aiikii
帖子: 268
注册时间: 2008-03-05 23:45
送出感谢: 2 次
接收感谢: 0

#8

帖子 aiikii » 2008-06-10 13:17

jarryson 写了:开启ati的xv。需要在xorg.conf里面添加,记得如果有的,直接加进去就好了

代码: 全选

Section "Device"
        ...
   Option       "OpenGLOverlay" "off"   #这个是关闭视频opengl加速的。应该可以不需要这句
   Option       "VideoOverlay" "on"    #这个是开启xv加速的
        ...
Section "Device"


代码: 全选

Section "Extensions"
   Option      "XVideo" "Enable"  #这个是开启xv的
   Option       "Composite" "Enable"   #这个是开启混合的,可以选择不开。
EndSection


ati如果不这样设置,看电影会很卡



学习一下解释。
回复

回到 “影音多媒体”