当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]安装w32codecs需要libstdc++5但是已经安装libstdc++6
帖子发表于 : 2008-01-26 12:53 

注册: 2005-07-30 0:57
帖子: 34
地址: shenzhen
送出感谢: 0 次
接收感谢: 0 次
想播放rmvb,看论坛帖子说安装w32codecs,但是它需要安装libstdc++5

可是Ubuntu7.10已经安装了libstdc++6

无法继续安装。


:~/download$ sudo dpkg -i w32codecs_20071007-0.1_i386.deb

选中了曾被取消选择的软件包 w32codecs。
(正在读取数据库 ... 系统当前总共安装有 90070 个文件和目录。)
正在解压缩 w32codecs (从 w32codecs_20071007-0.1_i386.deb) ...
dpkg:依赖关系问题使得 w32codecs 的配置工作不能继续:
w32codecs 依赖于 libstdc++5 (>= 1:3.3.4-1);然而:
未曾安装软件包“libstdc++5”。
dpkg:处理 w32codecs (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
w32codecs


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-01-26 13:16 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
那你就装一个 libstdc++5


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-01-26 16:05 
头像

注册: 2006-12-23 13:46
帖子: 9203
地址: Azores Islands
送出感谢: 0 次
接收感谢: 1
用命令安装干什么呢? 直接双击后点安装就会自动解决依赖问题的


_________________
no security measure is worth anything if an attacker has physical access to the machine


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-01-26 19:54 

注册: 2005-07-30 0:57
帖子: 34
地址: shenzhen
送出感谢: 0 次
接收感谢: 0 次
是的。我双击之后就安装了.现在libstdc++5 和 libstdc++6 都安装了。

重启电脑之后就可以播放rmvb了。谢谢。

也谢谢 http://forum.ubuntu.org.cn/viewtopic.ph ... 7600a64618 介绍安装w32codecs。

学习一下,双击 和 dpkg 命令 安装有什么不同啊?为什么双击就可以了呢?


页首
 用户资料  
 
5 楼 
 文章标题 : [已解决]
帖子发表于 : 2008-02-16 4:32 
头像

注册: 2005-10-05 11:31
帖子: 775
送出感谢: 0 次
接收感谢: 0 次
我也想知道,是否图形界面的deb安装工具和命令行的dpkg不同所以处理依赖关系的能力也不同呢?

weekend 写道:
双击 和 dpkg 命令 安装有什么不同啊?


libstdc++6 和 libstdc++5是C语言编写的程序的库文件?两者是同一样东西不同版本还是就不同呢?为什么EeePC Xandros默认这两个包都安装了呢?


_________________
我的网志: http://feed.fenglu.name/


最后由 oliver 编辑于 2008-02-17 20:24,总共编辑了 1 次

页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-02-16 9:51 
头像

注册: 2006-05-19 9:54
帖子: 1822
地址: Shanghai
送出感谢: 2
接收感谢: 11
没办法,编译的时候依赖的版本不相同,而且还往往互相不能替代
就像gtk2,gtk1有的时候也要同时装一样


_________________
ニンニク入れますか?
x60 with gentoo


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-05-31 16:22 

注册: 2008-05-16 22:14
帖子: 79
送出感谢: 0 次
接收感谢: 0 次
我的也是这样啊...有谁能提供libstdc++5的下载地址啊....

我的MP3也不能播放啊,好象是缺了解码包...我也要这个解码包地址...最好附件上来...

我的机器不能上网...所以...无奈


页首
 用户资料  
 
8 楼 
 文章标题 : Re: [已解决]
帖子发表于 : 2008-05-31 16:28 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
oliver 写道:
我也想知道,是否图形界面的deb安装工具和命令行的dpkg不同所以处理依赖关系的能力也不同呢?

weekend 写道:
双击 和 dpkg 命令 安装有什么不同啊?


libstdc++6 和 libstdc++5是C语言编写的程序的库文件?两者是同一样东西不同版本还是就不同呢?为什么EeePC Xandros默认这两个包都安装了呢?


两个东西


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: [问题]安装w32codecs需要libstdc++5但是已经安装libstdc++6
帖子发表于 : 2008-12-19 16:09 

注册: 2008-12-19 15:12
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
http://mimieye.javaeye.com/blog/103304 这儿有个解决办法


linux命令行

1. #ln -s /usr/local/lib/libstdc++.so.5 /usr/lib/libstdc++.so.5
2. #ln -s /usr/local/lib/libgcc_s.so.1 /usr/lib/libgcc_s.so.1


页首
 用户资料  
 
10 楼 
 文章标题 : Re: [问题]安装w32codecs需要libstdc++5但是已经安装libstdc++6
帖子发表于 : 2009-09-11 9:50 

注册: 2006-08-02 23:02
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
看提示么……,sudo apt-get install -f就可以了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译