当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]mplayer 一半是乱码,一半是正常!
帖子发表于 : 2008-02-09 13:43 
头像

注册: 2006-09-24 12:54
帖子: 78
送出感谢: 0 次
接收感谢: 0 次
如图,mplayer 编码unicode cp9**都试过了,srt文件utf8编码

哪位遇到过同样的问题?怎么解决呢?


附件:
Screenshot-MPlayer - Video.png
Screenshot-MPlayer - Video.png [ 253.66 KiB | 被浏览 513 次 ]



_________________
Aut viam inveniam aut faciam
页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-02-09 16:49 
头像

注册: 2007-10-06 18:40
帖子: 4313
送出感谢: 0 次
接收感谢: 5
search the forum.


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-02-10 11:02 

注册: 2008-02-06 11:11
帖子: 38
送出感谢: 0 次
接收感谢: 0 次
我的编码选cp936,再设置一个中文字体就正常了


附件:
.png
.png [ 11.21 KiB | 被浏览 443 次 ]
页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-02-10 21:40 
头像

注册: 2006-09-24 12:54
帖子: 78
送出感谢: 0 次
接收感谢: 0 次
[quote="yh163"]我的编码选cp936,再设置一个中文字体就正常了[/quote]

我的编码选cp936,再设置一个中文字体,结果还是不正常。


_________________
Aut viam inveniam aut faciam


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-02-10 21:48 
头像

注册: 2007-10-06 18:40
帖子: 4313
送出感谢: 0 次
接收感谢: 5
sudo aptitude install ttf-arphic-ukai
sudo do ~/.mplayer/gui.conf

修改下面的选项
sub_cp = "cp936"
font_factor = "0.750000"
font_name = "/usr/share/fonts/truetype/arphic/ukai.ttf"

我的完整的gui.conf

enable_audio_equ = "no"
vo_driver = "xv"
vo_panscan = "0.000000"
vo_doublebuffering = "yes"
vo_direct_render = "no"
vo_dxr3_device = "/dev/em8300-0"
v_framedrop = "0"
v_flip = "0"
v_ni = "no"
v_idx = "-1"
vf_pp = "no"
vf_autoq = "0"
vf_lavc = "no"
ao_driver = "alsa"
ao_volnorm = "no"
softvol = "no"
ao_surround = "no"
ao_extra_stereo = "no"
ao_extra_stereo_coefficient = "1.000000"
dvd_device = "/dev/dvd"
cdrom_device = "/dev/cdrom"
osd_level = "1"
sub_auto_load = "yes"
sub_unicode = "no"
ass_enabled = "no"
ass_use_margins = "no"
ass_top_margin = "0"
ass_bottom_margin = "0"
sub_pos = "100"
sub_overlap = "no"
sub_cp = "cp936"
font_factor = "0.750000"
font_name = "/usr/share/fonts/truetype/arphic/ukai.ttf"
font_encoding = "unicode"
font_text_scale = "3.630000"
font_osd_scale = "6.000000"
font_blur = "2.000000"
font_outline = "2.000000"
font_autoscale = "3"
cache = "yes"
cache_size = "8192"
playbar = "yes"
load_fullscreen = "no"
show_videowin = "yes"
stopxscreensaver = "yes"
autosync = "no"
autosync_size = "0"
gui_skin = "default"
gui_save_pos = "yes"
gui_main_pos_x = "387"
gui_main_pos_y = "634"
gui_video_out_pos_x = "0"
gui_video_out_pos_y = "0"
equ_channel_1 = "Front Right"
equ_channel_2 = "Front Left"
equ_channel_3 = "Rear Right"
equ_channel_4 = "Rear Left"
equ_channel_5 = "Center"
equ_channel_6 = "Bass"
equ_band_00 = "0.000000"
equ_band_01 = "0.000000"
equ_band_02 = "0.000000"
equ_band_03 = "0.000000"
equ_band_04 = "0.000000"
equ_band_05 = "0.000000"
equ_band_06 = "0.000000"
equ_band_07 = "0.000000"
equ_band_08 = "0.000000"
equ_band_09 = "0.000000"
equ_band_10 = "0.000000"
equ_band_11 = "0.000000"
equ_band_12 = "0.000000"
equ_band_13 = "0.000000"
equ_band_14 = "0.000000"
equ_band_15 = "0.000000"
equ_band_16 = "0.000000"
equ_band_17 = "0.000000"
equ_band_18 = "0.000000"
equ_band_19 = "0.000000"
equ_band_20 = "0.000000"
equ_band_21 = "0.000000"
equ_band_22 = "0.000000"
equ_band_23 = "0.000000"
equ_band_24 = "0.000000"
equ_band_25 = "0.000000"
equ_band_26 = "0.000000"
equ_band_27 = "0.000000"
equ_band_28 = "0.000000"
equ_band_29 = "0.000000"
equ_band_30 = "0.000000"
equ_band_31 = "0.000000"
equ_band_32 = "0.000000"
equ_band_33 = "0.000000"
equ_band_34 = "0.000000"
equ_band_35 = "0.000000"
equ_band_36 = "0.000000"
equ_band_37 = "0.000000"
equ_band_38 = "0.000000"
equ_band_39 = "0.000000"
equ_band_40 = "0.000000"
equ_band_41 = "0.000000"
equ_band_42 = "0.000000"
equ_band_43 = "0.000000"
equ_band_44 = "0.000000"
equ_band_45 = "0.000000"
equ_band_46 = "0.000000"
equ_band_47 = "0.000000"
equ_band_48 = "0.000000"
equ_band_49 = "0.000000"
equ_band_50 = "0.000000"
equ_band_51 = "0.000000"
equ_band_52 = "0.000000"
equ_band_53 = "0.000000"
equ_band_54 = "0.000000"
equ_band_55 = "0.000000"
equ_band_56 = "0.000000"
equ_band_57 = "0.000000"
equ_band_58 = "0.000000"
equ_band_59 = "0.000000"


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-02-11 11:06 
头像

注册: 2006-09-24 12:54
帖子: 78
送出感谢: 0 次
接收感谢: 0 次
老问题解决了,新问题出现了

字幕编码可以在/etc/mplayer/mplayer.conf里配 么?


附件:
Screenshot-MPlayer-gd.png
Screenshot-MPlayer-gd.png [ 242.55 KiB | 被浏览 478 次 ]



_________________
Aut viam inveniam aut faciam
页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-02-11 12:20 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
用smplayer做前端, 就不需要去手工改配置文件了, 选项里面设置很方便


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-02-11 13:11 
头像

注册: 2007-10-06 18:40
帖子: 4313
送出感谢: 0 次
接收感谢: 5
uzi 写道:
老问题解决了,新问题出现了

字幕编码可以在/etc/mplayer/mplayer.conf里配 么?

貌似可以。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-02-12 11:05 
头像

注册: 2006-10-19 14:08
帖子: 416
地址: 西夏
送出感谢: 0 次
接收感谢: 0 次
karron 写道:
用smplayer做前端, 就不需要去手工改配置文件了, 选项里面设置很方便


自从用了smplayer。。。。。。。。。。。。。


_________________
学习linux中。。。
http://blog.sina.com.cn/u/1259792077
http://hi.baidu.com/bwchaos
http://bwchaos.yo2.cn


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-02-13 11:56 
头像

注册: 2007-07-02 0:03
帖子: 181
送出感谢: 0 次
接收感谢: 0 次
uzi 写道:
老問題解決了,新問題出現了


請問你是如何解決"mplayer 一半是亂碼,一半是正常"這問題的?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译