当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 22 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : Totem 缺少 library or a decoder (cook.so)(drvc.so)
帖子发表于 : 2008-03-23 21:29 
头像

注册: 2007-09-23 17:06
帖子: 1051
送出感谢: 1
接收感谢: 8
自己的是Ubuntu7.10 Guesty !原本Totem用的好好的,可是在一次更新后,就不能打开Rmvb和Rm方式了,提示为:
A problem occurred while loading a library or a decoder (cook.so)有时会是(drvc.so)
中文提示为:装入库或解码器(cook.so)时发生问题

google了很久总算是找到了答案了:
编辑: ~/.gnome2/Totem/xine_config
sudo gedit ~/.gnome2/Totem/xine_config
找到以下两段进行修改:
# path to RealPlayer codecs
# string, default:
#decoder.external.real_codecs_path:

# path to Win32 codecs
# string, default: /usr/lib/codecs
#decoder.external.win32_codecs_path:

修改为:

# path to RealPlayer codecs
# string, default:
decoder.external.real_codecs_path:/usr/lib/win32

# path to Win32 codecs
# string, default: /usr/lib/codecs
decoder.external.win32_codecs_path:/usr/lib/win32

保存就可以了,这个问题困扰了我N 久了,总算是解决了,又可以看电影了,爽呀!


附件:
文件注释: A problem occurred while loading a library or a decoder (cook.so)提示截图
Screenshot-totem-1.png
Screenshot-totem-1.png [ 30.7 KiB | 被浏览 2460 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-03-23 21:31 
头像

注册: 2006-04-12 20:05
帖子: 8495
地址: 杭州
送出感谢: 0 次
接收感谢: 8
干的不错,哈哈


_________________
关注我的blog: ε==3


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-03-24 11:57 
头像

注册: 2005-11-17 15:45
帖子: 2996
地址: 湖北
送出感谢: 0 次
接收感谢: 1
顶你没商量! :D :D


_________________
代码:
枪杆子里面出政权


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-03-27 1:06 

注册: 2008-01-04 21:31
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
怪了,我的怎么找不到这行?
# path to Win32 codecs
# string, default: /usr/lib/codecs
#decoder.external.win32_codecs_path:


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-03-27 8:54 

注册: 2008-02-03 10:27
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
高手,,这个问题也困了我好长时间,以至于我只好用上MPLAYER,后来看到有人说发个命令就可以sudo ln -s /usr/lib/codecs/ /usr/local/lib/,试了一下,问题解决了。。可我不知道是什么原因。。今天看了楼主的内容,明白了。。。感谢!!


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-03-27 12:12 

注册: 2008-01-11 16:06
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
我也是这个问题,搞的我只好用Mplayer。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-03-27 16:10 
头像

注册: 2008-03-05 16:16
帖子: 58
送出感谢: 0 次
接收感谢: 0 次
顶,太好了 ,我的 问题也解决了


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-03-27 18:36 
头像

注册: 2008-02-02 23:05
帖子: 471
地址: 天津
送出感谢: 0 次
接收感谢: 0 次
解决了也没用,呵呵,我的64位系统用Totem播放RM音乐有杂音~~
可是Mplayer就没事


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-03-27 19:14 
头像

注册: 2005-08-22 14:05
帖子: 1743
地址: 离开北京
送出感谢: 1
接收感谢: 3
都没有人用gstream的?


_________________
错过好多好贴,没占到广告位后悔啊


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-04-01 9:04 

注册: 2008-02-04 7:39
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
搂住绝对高手


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-04-01 14:53 

注册: 2008-03-24 9:00
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
tgwen 写道:
高手,,这个问题也困了我好长时间,以至于我只好用上MPLAYER,后来看到有人说发个命令就可以sudo ln -s /usr/lib/codecs/ /usr/local/lib/,试了一下,问题解决了。。可我不知道是什么原因。。今天看了楼主的内容,明白了。。。感谢!!

其他的都没解决,你这条命令正确


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-04-02 0:36 

注册: 2007-03-31 12:56
帖子: 279
送出感谢: 0 次
接收感谢: 0 次
其实wiki就有啊。
http://wiki.ubuntu.org.cn/Xine%E5%89%8D ... E%E9%A2%98


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-04-02 14:48 

注册: 2006-09-23 22:42
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
这个问题还是不能解决,修改后重新启动Totem,文件有恢复原来的样子了。


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2008-04-03 10:55 
头像

注册: 2007-03-15 16:58
帖子: 2796
地址: 湖北武汉
送出感谢: 2
接收感谢: 4
还行
谢谢


_________________
引用:


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2008-04-04 1:33 

注册: 2007-05-11 12:21
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
顶了 今天更新完就出现这问题 谢谢达人啊


_________________
compaq 3202 au
AMD Turion64/XL56/2G/120G/nv6150
Ubuntu 7.10 Gutsy Gibbon/2.6.22-15


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 22 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:yushuibo 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译