当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 17 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : MPlayer不能播放DVDRip
帖子发表于 : 2005-07-02 9:37 

注册: 2005-07-02 9:33
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
我的MPlayer不能播放DVDRip文件,一播放就自动退出,怎么回事?好像是音频解码的时候出问题了。我加上nosound参数就可以播放,但是没有声音很不爽啊。

下面是出错信息:
代码:
MPlayer 1.0pre6-3.3.5 (C) 2000-2004 MPlayer Team
CPU: Intel Pentium 4/Xeon/Celeron Northwood (Family: 8, Stepping: 4)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for Debian.


Linux RTC init error in ioctl (rtc_irqp_set 1024): 权限不够
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : 没有那个文件或目录
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: 没有那个文件或目录
Failed to open LIRC support.
You will not be able to use your remote control.
Playing The.Terminal.2004.DVDRip.XviD-DEiTY.CD1.avi.
AVI file format detected.
VIDEO:  [XVID]  640x352  12bpp  23.976 fps  1403.7 kbps (171.3 kbyte/s)
Clip info:
 Software: Nandub v1.0rc2
SUB: Detected subtitle file format: subviewer
SUB: Read 788 subtitles.
SUB: Adjusted 5 subtitle(s).
SUB: added subtitle file (1): ./The.Terminal.2004.DVDRip.XviD-DEiTY.CD1.srt
==========================================================================
Trying to force audio codec driver family libmad...
Opening audio decoder: [liba52] AC3 decoding with liba52
AC3: 2.0 (dolby)  48000 Hz  192.0 kbit/s
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, 16 bit (0x10), ratio: 24000->192000 (192.0 kbit)
Selected audio codec: [a52] afm:liba52 (AC3-liba52)
==========================================================================
vo: X11 running at 1280x960 with depth 24 and 32 bpp (":0.0" => local display)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm:ffmpeg (FFmpeg MPEG-4)
==========================================================================
Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 48000 hz, little endian signed int
AF_pre: 48000Hz 2ch Signed 16-bit (Little-Endian)
alsa-init: got device=0, subdevice=0
alsa-init: 1 soundcard found, using: default
alsa: 48000 Hz/2 channels/4 bpf/17832 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 48000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
Starting playback...


MPlayer interrupted by signal 11 in module: decode_audio
- MPlayer crashed by bad usage of CPU/FPU/RAM.
  Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
  disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.
alsa-uninit: pcm closed
[/code]


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-07-02 12:35 
头像

注册: 2005-05-23 13:38
帖子: 771
地址: gdsz
送出感谢: 0 次
接收感谢: 0 次
试试用xine……

反正我的Mplayer是很有问题,

又删不掉……


_________________
……


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-07-02 13:23 

注册: 2005-07-02 9:33
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
我用Totem-xine用同样的codecs包解码AC3也不会有问题啊。为什么MPlayer就不行呢。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-07-04 2:55 

注册: 2005-07-03 3:46
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
我也有这个问题。。郁闷阿。。我原来的gentoo不会这样的。能不能自己编译一个?

好像xine和mplayer使用的liba52是不同的。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-07-04 8:12 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
GGGo 写道:
我也有这个问题。。郁闷阿。。我原来的gentoo不会这样的。能不能自己编译一个?

好像xine和mplayer使用的liba52是不同的。

肯定可以啦。


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-07-04 13:00 

注册: 2005-07-03 3:46
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
我昨晚编译了。不过功能少好多阿。连esd输出都没有。。

不会在ubuntu里编译软件。水平不够阿!

跟其他发行版相比,在ubuntu里编译软件有没有特别的方法或要求吗?


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-07-05 18:20 

注册: 2005-07-02 9:33
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
我编译后不能用vo=xv。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2005-07-05 20:16 

注册: 2005-07-02 9:33
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
不能编译xv扩展的问题解决了,原来要先装上libxv-dev这个软件包,否这没有xv的头文件和链接库。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2005-07-06 1:03 
头像

注册: 2005-05-15 3:09
帖子: 427
送出感谢: 0 次
接收感谢: 0 次
我这里mplayer比xine好点,因为xine播不了的,它却能播,让它静静的播,就不会卡。不过xine好像很酷的界面,重机械工业型的界面给人安全感。


_________________
琴声如我


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2005-07-06 16:19 

注册: 2005-07-02 9:33
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
我现在自己编译了一遍MPlayer什么问题都解决了。


页首
 用户资料  
 
11 楼 
 文章标题 : 也帮我看看吧?难道这个sub文件坏的?
帖子发表于 : 2005-07-07 23:51 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
我可以播放,但不能加载字幕。

代码:
yongyi@yongyi:~/Desktop/7seconds$ mplayer edrp-7s.avi -sub edrp-7s.sub -font /us r/share/fonts/simsun.ttf -subcp cp936
MPlayer 1.0pre6-3.3.5 (C) 2000-2004 MPlayer Team
CPU: Intel Celeron 2/Pentium III Tualatin (Family: 6, Stepping: 1)
Detected cache-line size is 32 bytes
MMX2 supported but disabled
CPUflags:  MMX: 1 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX SSE



Syntax error in font desc: ttcfCannot load font: /usr/share/fonts/simsun.ttf
Linux RTC init error in ioctl (rtc_irqp_set 1024): 权限不够
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : 没有那个文件或目录
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: 没有那个文件或目录
Failed to open LIRC support.
You will not be able to use your remote control.
Playing edrp-7s.avi.
No matching VOBSUB language found!
Cache fill:  9.38% (98304 bytes)    AVI file format detected.
AVI: ODML: Building odml index (2 superindexchunks)
VIDEO:  [XVID]  576x304  12bpp  23.976 fps  880.1 kbps (107.4 kbyte/s)
Clip info:
 Software: AVI-Mux GUI 1.16.11, Dec 15 2004  14:51:34
SUB: Could not determine file format
Cannot load subtitles: edrp-7s.sub
SUB: Could not determine file format
Cannot load subtitles: ./edrp-7s.sub
==========================================================================
Trying to force audio codec driver family libmad...
Opening audio decoder: [libmad] libmad mpeg audio decoder
AUDIO: 48000 Hz, 2 ch, 16 bit (0x10), ratio: 16000->192000 (128.0 kbit)
Selected audio codec: [mad] afm:libmad (libMAD MPEG layer 1-2-3)
==========================================================================
vo: X11 running at 800x600 with depth 24 and 32 bpp (":0.0" => local display)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm:ffmpeg (FFmpeg MPEG-4)
==========================================================================
Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 48000 hz, little endian signed int
AF_pre: 48000Hz 2ch Signed 16-bit (Little-Endian)
alsa-init: got device=0, subdevice=0
alsa-init: 1 soundcard found, using: default
alsa: 48000 Hz/2 channels/4 bpf/17832 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 48000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
Starting playback...


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2005-07-08 7:37 

注册: 2005-07-03 3:46
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
Syntax error in font desc: ttcfCannot load font: /usr/share/fonts/simsun.ttf

这里有没有问题??

还有,,如果你的字幕是sub+idx的话,,请使用-vobsub参数(不要写.和扩展名)


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2005-07-08 8:32 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
GGGo 写道:
Syntax error in font desc: ttcfCannot load font: /usr/share/fonts/simsun.ttf

这里有没有问题??

还有,,如果你的字幕是sub+idx的话,,请使用-vobsub参数(不要写.和扩展名)


simsun.ttf的路径是正确的。

我的是sub+idx,刚才试了一下 -vobsub 可是,还是一样,提示:
引用:
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: 没有那个文件或目录
Failed to open LIRC support.
You will not be able to use your remote control.
Playing edrp-7s.avi.
VobSub: Can't open IFO file
No matching VOBSUB language found!
Cache fill: 0.00% (0 bytes) AVI file format detected.
AVI: ODML: Building odml index (2 superindexchunks)
VIDEO: [XVID] 576x304 12bpp 23.976 fps 880.1 kbps (107.4 kbyte/s)
Clip info:
Software: AVI-Mux GUI 1.16.11, Dec 15 2004 14:51:34
SUB: Could not determine file format
Cannot load subtitles: ./edrp-7s.sub


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2005-07-08 19:52 

注册: 2005-07-03 3:46
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
idx+sub的字幕我比较少见到,,目前见到的都还能正常显示。
举个例子,有abc.avi和字幕def.idx、def.sub
mplayer abc.avi -font /xxx/simsun.ttc -vobsub def

这样应该行的。有种情况,在命令行中显示类似的错误
SUB: Could not determine file format
Cannot load subtitles: edrp-7s.sub
SUB: Could not determine file format
Cannot load subtitles: ./edrp-7s.sub
但实际上字幕已经加载了。我这里就有一个文件是这样。


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2005-07-08 20:18 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
我是加了字幕,但加的是英文的。

但我在win下用realplayer试了一下,可以加中文的。

算了,也许这个不适合linux下的吧。反正我看完了:)


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 17 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译