[已解决]mplayer启动的速度慢

Totem,mplayer,sopcast,realplayer,bmp
头像
aric286
帖子: 943
注册时间: 2007-12-03 9:54
送出感谢: 0
接收感谢: 0
联系:

[已解决]mplayer启动的速度慢

#1

帖子 aric286 » 2008-04-13 16:17

系统已经升级到最新,核心16。程序都挺快的,包括mplayer播放的时候都很快,可就是mplayer启动的速度很慢,谁知道怎么能设置的速度快点?谢谢了,现在这个系统是越用越顺手了,基本没有再用过windows了,哎,那叫一个爽。

解决办法:
修改mplayer的设置如图或者参考下面意见。
1。修改 /etc/mplayer/mplayer.conf 里面有项是
#Screensaver support (for non gmplayer)
stop-xscreensaver = "yes"
改为stop-xscreensaver = "no"
2。修改~/.mplayer/gui.conf里面有一项是
stopxscreensaver = "yes"修改为
stopxscreensaver = "no"
如速度还是慢的话,可以考虑有没有其他的mplayer配置文件,再进行修改。
附件
Screenshot-P.png
上次由 aric286 在 2008-04-14 17:10,总共编辑 3 次。
头像
qkthomas
帖子: 503
注册时间: 2006-12-16 22:05
来自: 肇庆
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 qkthomas » 2008-04-13 16:31

菜单延迟gnome是比kde大,但是性能gnome是比kde好的
头像
aric286
帖子: 943
注册时间: 2007-12-03 9:54
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 aric286 » 2008-04-13 16:39

qkthomas 写了:菜单延迟gnome是比kde大,但是性能gnome是比kde好的
呵呵,不想讨论这个问题,我只是想问问怎么加快mplayer启动的速度,谢谢了。
为了避免误会,我把对K的评价删除。谢谢
zabbey
帖子: 296
注册时间: 2006-05-06 2:03
送出感谢: 0
接收感谢: 0

#4

帖子 zabbey » 2008-04-13 16:41

在终端下输入mplayer试试,看看你就知道了,我猜应该又是屏保xscreen-saver或gnome-screen-saver的问题。
头像
aric286
帖子: 943
注册时间: 2007-12-03 9:54
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 aric286 » 2008-04-13 16:53

$ gmplayer
MPlayer 1.0rc2-4.2.3 (C) 2000-2007 MPlayer Team
CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 4000+ (Family: 15, Model: 107, Stepping: 1)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
Warning unknown option buffersize at line 136
xscreensaver_disable: Could not find XScreenSaver window.
GNOME screensaver disabled
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Exiting... (Quit)
这是什么意思?速度还是慢。弱弱的问一句,为什么输入mplayer打不开,要输入gmplayer?
头像
syrano
帖子: 4313
注册时间: 2007-10-06 18:40
送出感谢: 0
接收感谢: 5 次

#6

帖子 syrano » 2008-04-13 19:51

mplayer 文件
zabbey
帖子: 296
注册时间: 2006-05-06 2:03
送出感谢: 0
接收感谢: 0

#7

帖子 zabbey » 2008-04-13 22:54

xscreensaver_disable: Could not find XScreenSaver window.
应该是在这里等了很久吧~我以前就是开启时会在这里等一段时间。
sunzhaoyu2000
帖子: 700
注册时间: 2006-10-18 15:48
送出感谢: 0
接收感谢: 0

#8

帖子 sunzhaoyu2000 » 2008-04-13 23:12

zabbey 写了:在终端下输入mplayer试试,看看你就知道了,我猜应该又是屏保xscreen-saver或gnome-screen-saver的问题。
是这个问题
请问怎么解决呀?
Leyil
帖子: 24
注册时间: 2007-07-22 4:48
送出感谢: 0
接收感谢: 0

#9

帖子 Leyil » 2008-04-14 7:32

修改 /etc/mplayer/mplayer.conf 里面有项是
#Screensaver support (for non gmplayer)
stop-xscreensaver = "yes"

改了试试看
sunzhaoyu2000
帖子: 700
注册时间: 2006-10-18 15:48
送出感谢: 0
接收感谢: 0

#10

帖子 sunzhaoyu2000 » 2008-04-14 8:41

Leyil 写了:修改 /etc/mplayer/mplayer.conf 里面有项是
#Screensaver support (for non gmplayer)
stop-xscreensaver = "yes"

改了试试看

是的,改成no就行了
谢谢哈哈
头像
aric286
帖子: 943
注册时间: 2007-12-03 9:54
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 aric286 » 2008-04-14 16:58

sunzhaoyu2000 写了:
zabbey 写了:在终端下输入mplayer试试,看看你就知道了,我猜应该又是屏保xscreen-saver或gnome-screen-saver的问题。
是这个问题
请问怎么解决呀?
确实是这个问题。不过我的不太一样。我把问题的经过发在1楼,谢谢
zhuge000
帖子: 101
注册时间: 2008-04-18 17:06
送出感谢: 0
接收感谢: 0

#12

帖子 zhuge000 » 2008-04-29 9:33

搞定了,就是楼主的办法,太好了,谢谢~!
dolphing
帖子: 33
注册时间: 2006-08-15 1:08
送出感谢: 0
接收感谢: 0

#13

帖子 dolphing » 2008-06-27 22:04

我的问题也解决了~
好像以前没有这个问题的,为什么会突然出现呢?升级的缘故?
头像
Jarson
帖子: 2371
注册时间: 2008-07-21 9:44
来自: 深圳
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 Jarson » 2008-08-31 11:26

哈哈,我的问题也解决了
头像
Lavande
论坛版主
帖子: 5349
注册时间: 2008-12-21 15:27
来自: TARDIS
送出感谢: 1 次
接收感谢: 8 次

Re: [已解决]mplayer启动的速度慢

#15

帖子 Lavande » 2009-04-03 12:22

很凑效,哈哈!!
回复

回到 “影音多媒体”