当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]MPlayer声音和视频不同步怎么解决?
帖子发表于 : 2008-04-17 21:15 

注册: 2008-04-17 21:11
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
rt~~


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-04-18 16:25 

注册: 2008-04-15 12:35
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
我一小时前也遇到这个问题了,正确安装显卡驱动就解决了。

我机器是AMD 64 30000
512的内存
------------------
majian@majian-desktop:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon X1200 Series
OpenGL version string: 2.0.6473 (8.37.6)

majian@majian-desktop:~$ glxinfo |grep -e 'direct' -e 'OpenGL'
direct rendering: Yes
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon X1200 Series
OpenGL version string: 2.0.6473 (8.37.6)
OpenGL extensions:
majian@majian-desktop:~$


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-06-30 2:12 
头像

注册: 2007-04-13 15:08
帖子: 49
送出感谢: 0 次
接收感谢: 0 次
这个问题有解决方法,只不过麻烦一点,我刚刚试了一下, 可以做到,用命令行模式运行mplayer。

mplayer -autosync 30 <file path>

播放的时候左右键是前进后退,上下键是音量,F键是全屏和返回键。

缺点:
1. 比较是麻烦
2. 画面的质量就跟在windows上播放差不多。不过也不影响什么。

目前在设置界面里还没找到解决办法。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-06-30 2:17 
头像

注册: 2007-04-13 15:08
帖子: 49
送出感谢: 0 次
接收感谢: 0 次
不过这样运行一次以后,好像直接点击看其它文件也会正常同步了!

:D


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-06-30 10:21 
头像

注册: 2007-03-07 9:35
帖子: 198
送出感谢: 0 次
接收感谢: 0 次
可能视频特大了点吧。
可以试试 -framedrop参数

我放高清时也存在不同步,加上-framedrop参数就OK了,虽然要掉点帧,不过看不出来。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: [问题]MPlayer声音和视频不同步怎么解决?
帖子发表于 : 2009-02-21 16:53 

注册: 2009-02-11 22:07
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
up一下
我笔记本是E5750+8600gs,驱动也安装正常,但是同样出现mplayer播放视频不同步现象 :em06


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译