Ubuntu8.04声卡问题的最终解决方案

Totem,mplayer,sopcast,realplayer,bmp
perfect
帖子: 22
注册时间: 2006-10-24 6:43
送出感谢: 0
接收感谢: 0

Ubuntu8.04声卡问题的最终解决方案

#1

帖子 perfect » 2008-04-27 1:17

1.安装编译环境

代码: 全选

sudo apt-get install build-essential gettext libncurses5-dev
2.安装hwinfo,查看声卡的Driver Modules:

代码: 全选

   sudo apt-get install hwinfo
   hwinfo --sound
   
找到Driver Modules:"XXX",XXX就代表你的声卡驱动类型.例如,我的声卡:

代码: 全选

$ hwinfo --sound
20: PCI 10.1: 0403 Audio device                                 
  [Created at pci.296]
  UDI: /org/freedesktop/Hal/devices/pci_10de_26c
  Unique ID: wRyD.uNrQ0R67Yj2
  SysFS ID: /devices/pci0000:00/0000:00:10.1
  SysFS BusID: 0000:00:10.1
  Hardware Class: sound
  Model: "ASUSTeK MCP51 High Definition Audio"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x026c "MCP51 High Definition Audio"
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x1153 
  Revision: 0xa2
  Driver: "HDA Intel"
  Driver Modules: "snd_hda_intel"  #这里就是你的声卡类型,在下面编译的时候要用到
  Memory Range: 0xdbfb8000-0xdbfbbfff (rw,non-prefetchable)
  IRQ: 23 (3051 events)
  Module Alias: "pci:v000010DEd0000026Csv00001043sd00001153bc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
3.下载最新的Alsa驱动包
ftp://ftp.alsa-project.org/pub/driver/a ... 16.tar.bz2
ftp://ftp.alsa-project.org/pub/lib/alsa ... 16.tar.bz2
ftp://ftp.alsa-project.org/pub/utils/al ... 16.tar.bz2

4.解压、编译、安装驱动程序

假设下载的三个bz2文件在主目录下($),执行以下命令:

代码: 全选

    bunzip2  *.bz2
    tar -xf alsa-driver-1.0.16.tar 
    tar -xf alsa-lib-1.0.16.tar 
    tar -xf alsa-util-1.0.16.tar 
    cd alsa-driver-1.0.16
    sudo ./configure --with-cards=hda-intel --with-sequencer=yes ; sudo make ; sudo  make install
    #注意,with-cards的值要和上面的红字部分一致
    cd ..
    cd alsa-lib-1.0.16
    sudo ./configure ; sudo make; sudo make install;
    cd ..
    cd alsa-util-1.0.16
    sudo ./configure ; sudo make; sudo make install;
   
5.重启电脑,一切OK,不用更改任何配置文件。
头像
aqiu
帖子: 71
注册时间: 2007-06-06 14:53
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 aqiu » 2008-04-27 21:31

不好使
头像
dr_liu
帖子: 42
注册时间: 2008-01-07 16:53
送出感谢: 0
接收感谢: 0

#3

帖子 dr_liu » 2008-04-27 22:17

代码: 全选

sudo apt-get install linux-image-2.6.22-14-generic
vipeason
帖子: 178
注册时间: 2007-12-12 1:56
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 vipeason » 2008-04-30 15:20

試過了不行,殘念……
alinney
帖子: 23
注册时间: 2007-01-06 12:20
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 alinney » 2008-04-30 17:46

确实不好使阿。。。
chb
帖子: 4
注册时间: 2008-04-29 20:41
送出感谢: 0
接收感谢: 0

#6

帖子 chb » 2008-04-30 23:08

挺好用的啊,我就是这样解决的。但我用第一步那个工具没有得到我的声卡类型,所以编译时,直接sudo ./configure,没有带参数。
三个都编译好之后,重启,喇叭的叉没了,双击,把面板上的叉给去掉,就有声音了。
bacu
帖子: 29
注册时间: 2007-06-03 11:26
送出感谢: 0
接收感谢: 0

#7

帖子 bacu » 2008-05-02 7:50

HWinfo时候就没有查到drivermodule, 我的是X1250
然后全部装完,重启之后完全没反映
xufund
帖子: 184
注册时间: 2007-05-06 2:11
送出感谢: 0
接收感谢: 0

#8

帖子 xufund » 2008-05-14 22:44

确实不好使我是ONDA A690G主板,自带的声卡为realtek AC97(SB600)
lhtoo
帖子: 60
注册时间: 2007-09-24 22:28
送出感谢: 0
接收感谢: 0

#9

帖子 lhtoo » 2008-06-25 22:23

唉,同楼上的一样,这声卡研究了半个月了依然不能解决。期待高手解决
haiyusimon
帖子: 5
注册时间: 2008-06-24 18:04
送出感谢: 0
接收感谢: 0

#10

帖子 haiyusimon » 2008-06-25 23:44

方法正确!!!多谢你了,兄弟!!
头像
wdyx
帖子: 42
注册时间: 2007-11-11 20:48
送出感谢: 0
接收感谢: 0

#11

帖子 wdyx » 2008-07-02 23:48

楼主,我的声卡应该和你的一样,但是我试过了你的方法,不行啊。
我的系统装完了以后,小喇叭是正常的,但是就是没声音。
vipeason
帖子: 178
注册时间: 2007-12-12 1:56
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 vipeason » 2008-07-13 1:07

[Created at pci.296]
UDI: /org/freedesktop/Hal/devices/pci_1002_437b
Unique ID: 5Dex.gZcd3Z3nzY5
SysFS ID: /devices/pci0000:00/0000:00:14.2
SysFS BusID: 0000:00:14.2
Hardware Class: sound
Model: "Hewlett-Packard Company Audio device"
Vendor: pci 0x1002 "ATI Technologies Inc"
Device: pci 0x437b
SubVendor: pci 0x103c "Hewlett-Packard Company"
SubDevice: pci 0x30ba
Revision: 0x01
Driver: "HDA Intel"
Driver Modules: "snd_hda_intel"
Memory Range: 0xc0500000-0xc0503fff (rw,non-prefetchable)
IRQ: 16 (1447748 events)
Module Alias: "pci:v00001002d0000437Bsv0000103Csd000030BAbc04sc03i00"
Driver Info #0:
Driver Status: snd_hda_intel is active
Driver Activation Cmd: "modprobe snd_hda_intel"
Config Status: cfg=new, avail=yes, need=no, active=unknown
以上是我book 的 hwinfo 信息,死活没声音,音量调节什么都正常
maybeloveu
帖子: 31
注册时间: 2008-02-05 16:27
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 maybeloveu » 2008-07-16 13:11

谢谢 支持一下
maybeloveu
帖子: 31
注册时间: 2008-02-05 16:27
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 maybeloveu » 2008-07-16 13:23

很不幸我的声卡和你的一样,笔记本喇叭有声 ,插上耳机还是 喇叭响,耳机不响啊
arobot
帖子: 24
注册时间: 2007-02-05 12:05
送出感谢: 0
接收感谢: 0

#15

帖子 arobot » 2008-07-20 19:56

我的声卡也哑了 :(
回复

回到 “影音多媒体”