[原创]完美解决8.04用totem播放RMVB有声音无图像的问题!!

Totem,mplayer,sopcast,realplayer,bmp
头像
robulu
帖子: 63
注册时间: 2007-07-22 12:26
送出感谢: 0
接收感谢: 0

[原创]完美解决8.04用totem播放RMVB有声音无图像的问题!!

#1

帖子 robulu » 2008-04-27 22:49

此篇文章适用于Ubuntu 8.04 Hardy按照快速设置指南安装totem播放rmvb只有声音没有图像的问题,对于Ubuntu的以前版本不确定是否适用,根据我的经验Ubuntu以前版本按照对应的快速设置指南一步步设置是可以播放RMVB的
8.04快速设置指南里面所给出的设置Totem播放tmvb文件的步骤 如果按照顺序做完后会发现当播放rmvb文件的时候只有声音没有图像,而且totem也无法正确搜索到合适的解码器,为此我郁闷了很久,终于功夫不负苦心人,总算找到解决方法了,下面我就把解决步骤列出如下:(其中的部分内容引用自快速设置指南,下面的步骤已经是一个完整安装totem播放机的过程了!)
1、推荐能连接国外网的用户加入Medibuntu源,输入命令

代码: 全选

 sudo wget http://www.medibuntu.org/sources.list.d/hardy.list -O /etc/apt/sources.list.d/medibuntu.list
 sudo apt-get update && sudo apt-get install medibuntu-keyring && sudo apt-get update
2、其他用户要确保已加入ubuntu-cn源

* 安装多媒体解码器,输入命令

代码: 全选

sudo apt-get install libdvdcss2 libxine1-ffmpeg libxine1-plugins w32codecs gcc-3.3-base libstdc++5
3、配置电影播放器,输入命令

代码: 全选

sudo apt-get remove totem-gstreamer -y
sudo apt-get install totem totem-xine totem-mozilla -y
以上内容引用自Ubuntu 8.04快速设置指南!!

4、注意(重要!):此步骤不要按照快速设置指南的“若无法正常播放RMVB,请参考Xine前端播放器设置问题”步骤设置

5、配置音乐播放器

代码: 全选

sudo apt-get install gstreamer0.10-plugins-ugly gstreamer0.10-ffmpeg gstreamer0.10-fluendo-mpegdemux gstreamer0.10-gnonlin
6、安装gstreamer的解码器(最后一步也是最重要的一步!)

代码: 全选

sudo apt-get install gstreamer0.10-pitfdll gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse
以上是我今天忙乎了一天才搞定的,如果版主觉得这样能解决问题,请修改快速设置指南的内容,现在我也看见很多网友抱怨这个问题,通过以上步骤就可以解决了Ubuntu 8.04 播放 rmvb时有声音无图像的问题
tandkzy
帖子: 512
注册时间: 2006-02-12 19:29
送出感谢: 1 次
接收感谢: 0

#2

帖子 tandkzy » 2008-04-27 23:36

同感。觉得应该快点改了。虽然我个人更喜欢用kaffeine,但是要想自己的openoffice能够播放视频的话,就必须得弄好这个。
头像
robulu
帖子: 63
注册时间: 2007-07-22 12:26
送出感谢: 0
接收感谢: 0

#3

帖子 robulu » 2008-04-28 9:36

恩 是阿 那些配置还是以前7.10时的配置方法 那些文件有些根本不复存在了
tandkzy 写了:同感。觉得应该快点改了。虽然我个人更喜欢用kaffeine,但是要想自己的openoffice能够播放视频的话,就必须得弄好这个。
zing
帖子: 225
注册时间: 2008-04-07 14:50
送出感谢: 0
接收感谢: 0

#4

帖子 zing » 2008-04-28 10:31

折腾这久,不如安装realplayer来得直接。 :P
头像
callia
帖子: 171
注册时间: 2006-04-10 19:25
来自: 北京
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 callia » 2008-04-28 11:39

搞定,谢谢LZ勇于探索
头像
robulu
帖子: 63
注册时间: 2007-07-22 12:26
送出感谢: 0
接收感谢: 0

#6

帖子 robulu » 2008-04-28 12:06

个人感觉realplayer比较耗资源,系统自带的totem播放不错
zing 写了:折腾这久,不如安装realplayer来得直接。 :P
恋鸟之伊
帖子: 135
注册时间: 2008-01-17 15:13
来自: 江苏南通
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 恋鸟之伊 » 2008-04-28 22:37

谢谢楼主,解决了我的问题啊!
衣带渐宽终不悔,为伊消得人憔悴。
qianfengw
帖子: 6
注册时间: 2008-03-24 15:03
送出感谢: 0
接收感谢: 0

#8

帖子 qianfengw » 2008-04-29 16:10

借问一下,我也是因为这个问题,装了个realplay,但是发现放视频的时候,人脸都发青啊,颜色明显不对,这个是什么问题啊?怎么解决啊?
头像
desper
帖子: 95
注册时间: 2006-10-03 4:28
送出感谢: 0
接收感谢: 0

#9

帖子 desper » 2008-04-29 18:20

Why totem?
Mplayer + w32codecs works fine.
头像
ebok
帖子: 852
注册时间: 2008-02-15 0:09
送出感谢: 0
接收感谢: 0

#10

帖子 ebok » 2008-04-29 19:02

这个不得不顶,我就郁闷了,按快速设置一步一步来还是播放不了,原来是快速设置也出问题。
再弱弱地问下,mplayer用xv和x11有什么不同,用不了xv.
Somebody think they are full of niubility, so they play a zhuangbility, but only reflect their shability.
zcjdm
帖子: 3
注册时间: 2008-04-29 21:56
送出感谢: 0
接收感谢: 0

#11

帖子 zcjdm » 2008-04-30 8:24

晕阿,开始是有声音没图像,用了你的方法后有图像没声音了,怎么半阿
头像
小淘
帖子: 23
注册时间: 2007-05-20 10:59
来自: 湖南长沙
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 小淘 » 2008-04-30 20:15

多谢lz啦,问题解决了,不过美中不足的是播放时标题栏上显示的是乱码,不知这个该怎么解决?
Show自己
走自己的路,让别人去说吧!
头像
cnshzj007
帖子: 685
注册时间: 2006-05-24 21:38
来自: 上海
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 cnshzj007 » 2008-04-30 20:23

顶。只是w32下载太慢了。
我只是一个ARCH的FANS,来自RH和UBUNTU的滋润!
linjiang_82
帖子: 13
注册时间: 2005-05-26 9:49
送出感谢: 0
接收感谢: 0

#14

帖子 linjiang_82 » 2008-04-30 21:53

不错,终于解决了这个问题了
头像
robulu
帖子: 63
注册时间: 2007-07-22 12:26
送出感谢: 0
接收感谢: 0

#15

帖子 robulu » 2008-04-30 22:17

x11 和xv的区别是视频驱动的选择把 一般都是x11 当然如果x11用不了 你可以试试xv
mplayer -vo help 可以查看当前的视频输出
mplayer -ao help 可以查看当前的音频输出
ebok 写了:这个不得不顶,我就郁闷了,按快速设置一步一步来还是播放不了,原来是快速设置也出问题。
再弱弱地问下,mplayer用xv和x11有什么不同,用不了xv.
回复

回到 “影音多媒体”