[问题]mplayer运行时有下面问题

Totem,mplayer,sopcast,realplayer,bmp
回复
byygxs002
帖子: 24
注册时间: 2008-04-26 14:58
送出感谢: 0
接收感谢: 0

[问题]mplayer运行时有下面问题

#1

帖子 byygxs002 » 2008-04-30 23:53

mplayer运行时有下面问题

打开文件后会弹出错误窗口

点OK后可以播放,但是全屏有问题,只是窗口全屏了,画面还是没变,而且在窗口左上角会显示一幅截取的图片


求高手指点

下面是我的mplayer.conf文件

#
# MPlayer configuration file
#
# Configuration files are read system-wide from /usr/local/etc/mplayer.conf
# and per user from ~/.mplayer/config, where per-user settings override
# system-wide settings, all of which are overrriden by the command line.
#
# The configuration file settings are the same as the command line
# options without the preceding '-'.
#
# See the CONFIGURATION FILES section in the man page
# for a detailed description of the syntax.


##################
# video settings #
##################

# Specify default video driver (see -vo help for a list).
vo=xv

vo=xv, # To specify default video driver (see -vo help for

# Use SDL video with the aalib subdriver by default.
#vo = sdl:aalib

# FBdev driver:
#
# mode to use (read from fb.modes)
#fbmode = 640x480-120
#
# location of the fb.modes file
#fbmodeconfig = /etc/fb.modes

# Specify your monitor timings for the vesa and fbdev video output drivers.
# See /etc/X11/XF86Config for timings. Be careful; if you specify settings
# that exceed the capabilities of your monitor, you may damage it.
#
# horizontal frequency range (k stands for 1000)
#monitor-hfreq = 31.5k-50k,70k
#
# vertical frequency range
#monitor-vfreq = 50-90
#
# dotclock (or pixelclock) range (m stands for 1000000)
#monitor-dotclock = 30M-300M

# Start in fullscreen mode by default.
#fs=yes

# Change to a different videomode when going fullscreen.
#vm=yes

# Override the autodetected color depth, may need 'vm=yes' as well.
#bpp=0

# Enable software scaling (powerful CPU needed) for video output
# drivers that do not support hardware scaling.
#zoom=yes

# standard monitor size, with square pixels
#monitoraspect=4:3

# Use this for a widescreen monitor, non-square pixels.
#monitoraspect=16:9

# Keep the player window on top of all other windows.
#ontop=yes


##################
# audio settings #
##################

# Specify default audio driver (see -ao help for a list).
ao=pulse,alsa,

# Use SDL audio driver with the esd subdriver by default.
#ao = sdl:esd

# Specify the mixer device.
#mixer = /dev/mixer

# Resample the sound to 44100Hz with the lavcresample audio filter.
#af=lavcresample=44100

# Specify default audio codec (see -ac help for a list).
ac=mad,


##################
# other settings #
##################

# Drop frames to preserve audio/video sync.
#framedrop = yes

# Specify your preferred skin here (skins are searched for in
# /usr/local/share/mplayer/skins/<name> and ~/.mplayer/skins/<name>).
#skin = Abyss

# Resample the font alphamap.
# 0 plain white fonts
# 0.75 very narrow black outline (default)
# 1 narrow black outline
# 10 bold black outline
#ffactor = 0.75

# cache settings
#
# Use 8MB input cache by default.
#cache = 8192
#
# Prefill 20% of the cache before starting playback.
#cache-min = 20.0
#
# Prefill 50% of the cache before restarting playback after the cache emptied.
#cache-seek-min = 50

# DVD: Display English subtitles if available.
#slang = en

# DVD: Play English audio tracks if available.
#alang = en


# You can also include other configuration files.
#include = /path/to/the/file/you/want/to/include

#Screensaver support (for non gmplayer)
stop-xscreensaver = "yes"

#Disable joystick support
#It seems to cause very odd problems on laptops
#With accelerometers (See LP: #75925)
nojoystick = yes
附件
Screenshot.png
错误窗口
Screenshot-1.png
全屏截图
上次由 byygxs002 在 2008-04-30 23:55,总共编辑 1 次。
头像
cnshzj007
帖子: 685
注册时间: 2006-05-24 21:38
来自: 上海
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 cnshzj007 » 2008-04-30 23:54

你试着开用X11来播放,你知道在哪里改用X11来放吧?
我只是一个ARCH的FANS,来自RH和UBUNTU的滋润!
byygxs002
帖子: 24
注册时间: 2008-04-26 14:58
送出感谢: 0
接收感谢: 0

#3

帖子 byygxs002 » 2008-04-30 23:57

cnshzj007 写了:你试着开用X11来播放,你知道在哪里改用X11来放吧?
不知道
头像
sanmeimu
帖子: 5
注册时间: 2007-10-09 10:50
来自: 中国-山东
送出感谢: 0
接收感谢: 0
联系:

[讨论]

#4

帖子 sanmeimu » 2008-05-01 0:41

我的是全屏后,half size / normal size / double size / fullscreen 切换有问题,不是切换到double size,就是全屏后没有图像,郁闷。。。。。
Athlon64
帖子: 72
注册时间: 2006-04-13 13:43
送出感谢: 0
接收感谢: 1 次

#5

帖子 Athlon64 » 2008-05-01 1:57

把配置文件里“zoom=yes”这行前面的“#”去掉,把“vo=xv”改成“vo=x11"
头像
sanmeimu
帖子: 5
注册时间: 2007-10-09 10:50
来自: 中国-山东
送出感谢: 0
接收感谢: 0
联系:

[讨论]好像。。。

#6

帖子 sanmeimu » 2008-05-05 13:21

我感觉可能是我显卡配置的问题,我还没装显卡受限驱动,可能视频输出有问题,最近装显卡驱动,反烦死了
回复

回到 “影音多媒体”