当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : [分享]8.04HARDY流媒体、多媒体音频视频全攻略[RMVB、在线音乐、格式转换][转]
帖子发表于 : 2008-05-01 21:33 

注册: 2008-04-04 22:38
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
REVISED ON THE 25TH OF APRIL 2008


--PART 1/5, ESSENTIAL PACKAGES--(精华包)
--PART 2/5, STREAMING WITH FIREFOX--(FF流媒体)
--PART 3/5, SOUND & VIDEO CONVERSION--(格式转换)
--PART 4/5, DVD PLAYBACK/RIPPING/BURNING--(DVD回放/RIP/烧录)
--PART 5/5, MISCELLANEOUS & TROUBLESHOOTING--(常见问题)


INTRODUCTION


Reason for how-to: I still see some users struggling and becoming frustrated over getting streaming media or Java to work, and having general multimedia issues, so I thought I'd post my own how-to on the subject. Please keep in mind however that Ubuntu has a feature where if you click on a certain file, or try to view flash videos, a dialog should pop-up and ask if you want to install proprietary packages that are neccessary to play those formats. This how-to is for users who are still having issues, or simply want as many different formats working as possible with just a few commands.

Please note: You will see a reaccurance of certain packages in different parts of this how-to (Sound & Video Conversion for example), this is just to make certain that you have the necessary packages installed to enable whatever feature you're looking to have available to you on your system. This goes for Part 1 also, as you may have some of the packages installed already. Anything you already have installed will be skipped, it will not cause any problems.

Unrelated to streaming, multimedia and indeed video: I see quite a few newbies have been watching YouTube videos and are curious about the whole 3D rotating desktop feature of Linux, and other such effects. Part 1 of my how-to now includes the CCSM package (compizconfig-settings-manager). Here is a link to help you get the most out of it and understand the various plugins and settings.


--PART 1/5, ESSENTIAL PACKAGES--
第一步:安装核心包

IMPORTANT: If you haven't already, you need to enable the Medibuntu repository. These commands are aimed at Gutsy users, so if you are using a different version of Ubuntu, please edit the first command in your Terminal and change it from "gutsy" to whatever version you are running. Open the Terminal (Applications>Accessories>Terminal or KMenu>System>Terminal Program (Konsole) in Kubuntu and Applications>System>Terminal in Xubuntu) and paste these wget commands into it:
如果还没有将Medibuntu源加入APT-GET,执行下面命令,后面会用到其中的几个关键包:
引用:
sudo wget http://www.medibuntu.org/sources.list.d/hardy.list -O /etc/apt/sources.list.d/medibuntu.list

wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add - && sudo apt-get update


If that didn't work and you received an error, you will have to add the repositoriess manually, which is actually quite easy. First of all, you need to open the sources file with your default or favourite text editor (replace "gedit" with "kwrite" in Kubuntu and "mousepad" in Xubuntu:
也可以手动编辑sources.list加入
引用:
gksudo gedit /etc/apt/sources.list


Now just add these lines at the bottom, remembering to change the Ubuntu version accordingly. After you have added the two lines, save the changes and wget the GPG key as instructed above:
将以下两行加入到/etc/apt/sources.list文件
引用:
deb http://packages.medibuntu.org/ hardy free non-free
deb-src http://packages.medibuntu.org/ hardy free non-free


It's also a good idea to make sure the Multiverse and Universe repositories are enabled, although they should be enabled by default on the latest versions of Ubuntu. To make sure they are, or to choose a local server for downloads, navigate to System>Administration>Software Sources and tick whichever sources you wish to use. While you're there, you can also untick the CD-ROM/DVD source and choose a local server instead of using the main server. There are two good reasons for this - Firstly, you give the main server a break because you're using a local mirror, and secondly, it will improve download speeds when updating or installing software on to the system.


ADOBE FLASH INSTALLATION
FLASH安装

There appear to be some users still havng issues installing Adobe Flash. If you tried installing it already and are having issues, read on. First of all, it's worth completely purging the package from your system, along with any others which may be interfering with it and then reinstall it again. Will both 32-Bit and 64-Bit users execute this command:

32位与64位都可执行以下语句
引用:
sudo apt-get purge flashplugin-nonfree gnash gnash-common && sudo apt-get install flashplugin-nonfree


Still no joy? Please cut and paste the "purge" part of the command (stop before the "&&" symbols) to completely remove the package. Next, I would suggest following the intructions below for your particular architecture:

32-Bit Users: Install it manually by downloading the tar here and extract the contents to your desktop or home folder. Press Alt-F2" and enter "gksudo nautilus" into the run command dialog, another dialog will pop-up asking for your password, enter your password and then navigate to your desktop or home folder within the file browser. Finally, click on the installer and instruct it to install the plugin to "/usr/lib/firefox" (without quotation marks), or to wherever your favourite browser is located, and then you're done. You can now exit the installer.

64-Bit Users: It should be harder for you to install the plugin, as it's a 32-Bit package, but thanks to a handy script by Kilz, it's actually quite easy. Please visit this thread and run the recommended script to install an older and more compatible version of Adobe Flash, along with a wrapper that will enable it to work on your 64-Bit system.

An easy and quick way to install most of the packages you need (Java, codecs for playing/ripping/converting music and video etc) is to use the command line. If you would rather use a graphical application with descriptions of packages, you can either use Add/Remove, Synaptic in Ubuntu and Xubuntu (System>Administration>Synaptic Package Manager in Ubuntu and Applications>System>Synaptic Package Manager in Xubuntu) and Adept in Kubuntu (KMenu>System>Adept). For the sake of speed, I suggest you use the Terminal for most of this how-to. Open the Terminal and paste these commands into it:


UBUNTU FAMILY 8.04 HARDY HERON USERS ONLY
UBUNTU8。04系列的用户,按32位或64位及UBUNTU、KUBUNTU、XUBUNTU分别在终端输入如下命令安装软件:

32-Bit Ubuntu Users:
32位UBUNTU用户(大多数网友都是用32位UBUNTU的吧)
引用:
sudo apt-get remove icedtea-gcjwebplugin openjdk-6-jre && sudo apt-get install alsa-oss compizconfig-settings-manager faad gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse gstreamer0.10-pitfdll libflashsupport liblame0 sun-java6-fonts sun-java6-jre sun-java6-plugin unrar w32codecs


32-Bit Kubunu Users:

sudo apt-get remove icedtea-gcjwebplugin openjdk-6-jre && sudo apt-get install alsa-oss libflashsupport libk3b2-extracodecs liblame0 libtunepimp5-mp3 libxine1-ffmpeg sun-java6-fonts sun-java6-jre sun-java6-plugin unrar w32codecs

32-Bit Xubuntu Users:

sudo apt-get remove icedtea-gcjwebplugin openjdk-6-jre && sudo apt-get install alsa-oss libflashsupport liblame0 libxine1-ffmpeg sun-java6-fonts sun-java6-jre sun-java6-plugin unrar w32codecs

64-Bit Ubuntu Users:
64位UBUNTU用户:
sudo apt-get install alsa-oss compizconfig-settings-manager faad gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse icedtea-gcjwebplugin libflashsupport liblame0 unrar w64codecs

64-Bit Kubuntu Users:

sudo apt-get install alsa-oss icedtea-gcjwebplugin libk3b2-extracodecs libflashsupport liblame0 libtunepimp5-mp3 libxine1-ffmpeg unrar w64codecs

64-Bit Xubuntu Users:

sudo apt-get install alsa-oss icedtea-gcjwebplugin libflashsupport liblame0 libxine1-ffmpeg unrar w64codecs

Kubuntu Users: I didn't feel it was suitable to add the command to install the CCSM package above. Go here for instructions on what you need to enable Compiz Fusion on your system.


PRE-UBUNTU FAMILY 8.04 HARDY HERON USERS ONLY
下面是针对使用预发行的非正式版8。04HARDY HERON的用户

32-Bit Ubuntu Users:

sudo apt-get install alsa-oss compizconfig-settings-manager faad gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse gstreamer0.10-pitfdll liblame0 sun-java6-fonts sun-java6-jre sun-java6-plugin unrar w32codecs

32-Bit Kubunu Users:

sudo apt-get install alsa-oss libk3b2-mp3 liblame0 libtunepimp5-mp3 libxine1-ffmpeg sun-java6-fonts sun-java6-jre sun-java6-plugin unrar w32codecs

32-Bit Xubuntu Users:

sudo apt-get install alsa-oss liblame0 libxine1-ffmpeg sun-java6-fonts sun-java6-jre sun-java6-plugin unrar w32codecs

64-Bit Ubuntu Users:

sudo apt-get install alsa-oss compizconfig-settings-manager faad gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse icedtea-java7-jre icedtea-java7-plugin liblame0 unrar w64codecs

64-Bit Kubuntu Users:

sudo apt-get install alsa-oss icedtea-java7-jre icedtea-java7-plugin libk3b2-mp3 liblame0 libtunepimp5-mp3 libxine1-ffmpeg unrar w64codecs

64-Bit Xubuntu Users:

sudo apt-get install alsa-oss icedtea-java7-jre icedtea-java7-plugin liblame0 libxine1-ffmpeg unrar w64codecs

Kubuntu Users: I didn't feel it was suitable to add the command to install the CCSM package above. Go here for instructions on what you need to enable Compiz Fusion on your system.


DID YOU HAVE ERRORS?
出错了?

If you had errors while trying to do the above, one of these following commands may help. Did the Terminal tell you to run "dpkg --configure -a"? All you have to do is add "sudo" to the front of that command, like so:

sudo dpkg --configure -a

Or if it was the install -f command:

sudo apt-get install -f

Was that not the error you had? You may have a currupt apt list due to an interrupted "apt-get update". Try these commands instead:

sudo rm /var/lib/apt/lists/partial/*

sudo apt-get update

Now try repeating the command to install the restricted packages for your particular Ubuntu variant.


--PART 2/5, STREAMING WITH FIREFOX--
火狐游览器在线流媒体播放

You may already be happy with your streaming after installing the packages in Part 1, but if you want advanced playback and features, I recommend you give the MPlayer plugin a try:

引用:
sudo apt-get remove totem-mozilla mozilla-plugin-vlc xine-plugin kaffeine-mozilla helix-player mozilla-helix-player

sudo apt-get install mplayer mozilla-mplayer


Please Note: New users of Ubuntu or MPlayer should open the main MPlayer application after installing it for the first time, this will then cause it to create it's default folder in your home directory. Also, please navigate to Preferences>Audio in MPlayer, and then tick the "Enable Software Mixer" option.
mplayer安装好后打开一次,自动在用户目录下生成相应的文件夹。打开MPLAYER后右键Preferences>Audio下,选中"Enable Software Mixer"

Option 1 - 32/64-Bit Ubuntu Family Users - All Versions: MPlayer will stream virtually all media formats, the most simple method and works on both
architectures. Paste either of these commands into the Terminal: (Substitute "gedit" for "kwrite" if you are using Kubuntu and "mousepad" if you are an Xubuntu user)

修改mplayer配置文件
引用:
gedit $HOME/.mplayer/mplayerplug-in.conf


or if you have multiple users and want them all to use this method for streaming:

gksudo gedit /etc/mplayerplug-in.conf

If you chose to edit the "/etc/" file, please remove the settings already present and make sure that the "$HOME" version is blank or deleted in all user accounts. Now you need to paste the following settings into the configuraton file:
将以下内容贴到mplayerplug-in.conf中,保存
引用:
download=1
cachesize=1024
cache-percent=25
keep-download=0
dload-dir=$HOME
noembed=0
autoplay=1
enable-wmp=1
enable-qt=1
enable-rm=1
enable-gmp=1
enable-dvx=1
enable-mpeg=1
enable-mp3=1
enable-midi=0
enable-pls=1
enable-ogg=1
enable-smil=1
enable-helix=1
nomediacache=0
nopauseonhide=1
black-background=1
rtsp-use-http=0
rtsp-use-tcp=0

Close and save the file, then paste this important command into the Terminal:
然后在终端执行
引用:
rm $HOME/.mozilla/firefox/pluginreg.dat (Firefox recreates it with the updated plugin information).


Options 2 - 32-Bit Pre-Ubuntu 8.04 Hardy Heron Users Only: MPlayer will stream most formats still, but RealPlayer will handle it's native formats. This is a slightly more complicated method and some users may initially have problems with RealPlayer. Also, this method is more suited for 32-Bit users, as RealPlayer isn't packaged for 64-Bit systems. RealPlayer isn't in the repos, so download it here. Don't worry that it's packaged for Fiesty, it should work and install fine. You can remove it in Synaptic or with "sudo dpkg -r realplay". Install it by double or single-clicking on the deb, or by using the right-click context menu. Type your password when prompted.

Now that you have installed RealPlayer, we need to configure MPlayer so that it can work together with the RealPlayer browser plugin. Paste either of these commands into the Terminal: (Substitute "gedit" for "kwrite" if you are using Kubuntu and "mousepad" if you are an Xubuntu user)

gedit $HOME/.mplayer/mplayerplug-in.conf

or if you have multiple users and want them all to use this method for streaming:

gksudo gedit /etc/mplayerplug-in.conf

If you chose to edit the "/etc/" file, please remove the settings already present and make sure that the "$HOME" version is blank or deleted in all user accounts. Now you need to paste the following settings into the configuraton file:

download=1
cachesize=1024
cache-percent=25
keep-download=0
dload-dir=$HOME
noembed=0
autoplay=1
enable-wmp=1
enable-qt=1
enable-rm=0
enable-gmp=1
enable-dvx=1
enable-mpeg=1
enable-mp3=1
enable-midi=0
enable-pls=1
enable-ogg=1
enable-smil=0
enable-helix=0
nomediacache=0
nopauseonhide=1
black-background=1
rtsp-use-http=0
rtsp-use-tcp=0

Close and save the file, then paste this important command into the Terminal:

rm $HOME/.mozilla/firefox/pluginreg.dat (Firefox recreates it with the updated plugin information).

"Keep-download" is an easy way to save streaming media, just change the value to "1" and it will then download to your home directory. For an explaination of what the other settings do check out this link.

Note: Please REBOOT if you are not carrying on with the rest of the how-to, as you have made lot's of changes to your system and could have some strange problems until you start a fresh session. If you still have problems after rebooting with certain applications, please read the "Troubleshooting" section at the bottom.
我挺喜欢smplayer的
引用:
sudo apt-get install smplayer


--PART 3/5, SOUND & VIDEO CONVERSION--


SOUND CONVERSION


It is not recommended to convert one group of compressed music files of a certain format, to another type of compressed format. However, if you wish to do so, you can accomplish most tasks with Sound Converter, OggConvert or Sound Konverter. Some GNOME users prefer Sound Konverter despite the fact it is a KDE application (perhaps because it's had better support for AAC audio, such as iTunes music files). Install whichever varient you wish, but make sure you have completed Part 1 of this how-to first:

sudo apt-get install soundconverter oggconvert

or the KDE varient:

sudo apt-get install soundkonverter aacplusenc alac-decoder cdparanoia faac ffmpeg flac lame vorbis-tools

If you want to try and convert a large number of iTunes m4a files, and keep as much tag information as possible, please refer to this page.

Tag editing can be done in various music applications, but if you want to try a dedicated tag editor, install Ex Falso:

sudo apt-get install exfalso

You may also want to try EasyTag:

sudo apt-get install easytag easytag-aac

Kubuntu users might want to install KID3 instead:

sudo apt-get install kid3


VIDEO CONVERSION


For video converting, first make sure you have these packages installed:

sudo apt-get install ffmpeg faac

Then download a GUI frontend for FFmpeg called WinFF. Install it by double or single-clicking on the deb, or by using the right-click context menu. Type your password when prompted.

To make a video for a mobile phone in WinFF, select 3g2 as the type of video you want to make. Use 3gp if you want (doesn't work for me right now however). To increase the audio quality, click on "Options" and in the "Audio Bit Rate" box type "96000" (default is 64000, which is 64kbps). However, your phone might not play it properly with the audio at 96kbps for video, depends really. Test it yourself. For some reason, when you type in the "Video Bit Rate" box to change the default setting, you only have to type in "180" (for example), instead of "180000. I'm not sure why. Also, you may need to change the extension from "3g2" to "mp4" or "3gp" in order for it to play. I suggest mp4 as this worked flawlessly on my W810i, but only with the default settings for some reason. I'd appreciate some feedback on how the videos work on other handsets.


--PART 4/5, DVD PLAYBACK/RIPPING/BURNING--
DVD播放、提取与烧录

PLAYBACK


To stop Ubuntu asking for the installation CD when you install these next packages, navigate to System>Administration>Software Sources and untick the CD-ROM/DVD source, or open the Terminal and do the following:

gksudo gedit /etc/apt/sources.list

Go to the line which starts as "deb cdrom" (at the top in my sources list) and just put a # before it. Close and save the file.

For the best DVD playback in Ubuntu, including menu support, install this cross-format media player:
引用:
sudo apt-get install vlc


You can also use the Xine engine in Ubuntu for video/DVD playback. This can be done without having to change the backend of Totem - just install an alternative GNOME frontend for Xine called Gxine (this is optional, VLC will do just fine):
引用:
sudo apt-get install gxine libxine1-ffmpeg


To get encrypted DVDs playing properly (check out no. 9 in the "Troubleshooting" section if you are having problems with new DVDs), paste these commands into the Terminal:
引用:
sudo apt-get install libdvdcss2 libdvdread3 libdvdnav4 build-essential debhelper fakeroot


then:
引用:
sudo /usr/share/doc/libdvdread3/install-css.sh


or if you get an error with that command:

sudo /usr/share/doc/libdvdread3/examples/install-css.sh


VLC AS DEFAULT DVD PLAYER IN UBUNTU 8.04 HARDY HERON SYSTEMS
将VLC设为默认DVD播放软件

To change the default DVD player in Hardy Heron to VLC (I strongly advise you do), open the Terminal and copy and paste this command into it:
引用:
gksudo gedit /etc/gnome/defaults.list


Press Ctrl+f and search for "x-content/video", then change the "totem.desktop" entries to "vlc.desktop". Close and save.
查找x-content/video内容,将totem.desktop替换为vlc.desktop,别忘了在改动前要备份原文件
Next, right-click on "Applications" in the top panel and select "Edit Menus" to open the default menu editor. Navigate down to "Sound & Video" in the left pane and click on it to show all those applications in the pane to the right. Scroll down the list of applications displayed until you see "VLC media player", right-click on it, then click on "Properties" in the context menu to open "Launcher Properties" and change the launch command from "wxvlc %F" to:
在左上角面板上右键[编辑菜单],找到vlc media player,修改属性,播放命令改为
引用:
vlc --vout-filter deinterlace --deinterlace-mode blend --volume 512 --fullscreen %m


Close the VLC properties dialog and exit the menu editor. Finally, navigate to Nautilus>Edit>Preferences>Media>DVD Video and select VLC.


VLC AS DEFAULT DVD PLAYER IN PRE-UBUNTU 8.04 HARDY HERON SYSTEMS


To set VLC as your default DVD player in a pre-Hardy Heron systems, navigate to System>Preferences>Removable Drives and Media>Multimedia and replace the existing “Video DVD Discs” command ("totem %m") with:

vlc --vout-filter deinterlace --deinterlace-mode blend --volume 512 --fullscreen %m

If you don't want VLC to automatically launch into fullscreen when a DVD movie is inserted, all you have to do is delete the "--fullscreen" part of the command. To exit and enter fullscreen in VLC, just press the "f" key.


RIPPING


You can rip a standard disc image by right-clicking on the disc icon and then selecting the "Write to Disk" option in the context menu. Alternatively, you can open it with your file browser and drag the ISO image to your desktop. For more advanced options, give dvd::rip a try:

sudo apt-get install dvdrip

Kubuntu users might be interested in this application instead:

sudo apt-get install k9copy


BURNING


Basic burning can be done by right-clicking on an ISO image and then selecting the "Write to Disc" option in the context menu. If you want to burn DVDs for use in standard DVD players, then your best bet is an application called Tovid. Go to the Tovid Wiki and download the deb file, then just double or single-click to install, or use the right-click context menu. Type your password when prompted. Also, read this guide on using the Tovid GUI and another guide on the basics of using Tovid.

Note: If you wish to change the region of a DVD drive so you can play/rip foreign discs, you will need to install the following terminal based application:

sudo apt-get install regionset

Please be aware that most drives limit you to about 5 changes (regionset should tell you how many you have left). So maybe it's best to have a secondary external DVD drive and have it set to a different region to the one in your machine. To make the change, put any disc into your drive and type "sudo regionset" into the Terminal and change the region. Here is the list of region codes and which countries they cover:

RC1 = North America (USA and Canada)
RC2 = Europe, Middle East, South Africa and Japan
RC3 = Southeast Asia, Taiwan, Korea
RC4 = Latin America, Australia, New Zealand
RC5 = Former Soviet Union (Russia, Ukraine, etc.), rest of Africa, India
RC6 = China


--PART 5/5, MISCELLANEOUS & TROUBLESHOOTING--


--MISCELLANEOUS--


TOUCHPAD TIPS & TRICKS


Using a laptop? If your cursor shoots off all over the place when you type, you might want to (carefully) do the following:

gksudo gedit /etc/X11/xorg.conf

Now find the section concerning your touchpad and copy the bold text below into your conf file, so it look similar to the example below:

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
Option "SHMConfig" "on"
EndSection

Make sure it all looks okay and that the "EndSection" text is in the right place, then close and save. Now, navigate to System>Preferences>Sessions and click on "Add". Name it something like "Touchpad Syndaemon", the description can be "Disables touchpad while typing", and the all important command you need is "syndaemon -i .5 -d". For it to take effect, REBOOT. Why isn't it default for laptop users? Well, apparently it's insecure. If you share your laptop with others, technically they could disable your touchpad. Personally, I think there should be an option in System>Preferences>Mouse to enable this feature, with a warning if necessary.


FONTS TIPS & TRICKS


I always insist my fonts are used instead of webpage defaults (Firefox>Preferences>Content>Fonts & Colours>Advanced) and I also increase the minimum font size to "12", that might interest some of you. Make sure you're using DejaVu (Ubuntu default) in Firefox, msttcorefonts are pointless and redundant in my opinion now, so no need to install and use them. I also recommend setting all the font sizes to 9 in System>Preferences>Appearance>Fonts.


APPLICATIONS & GAMES


View and fill in PDF forms online with Adobe Reader and it's browser plugins:

sudo apt-get remove mozplugger && sudo apt-get install acroread-plugins mozilla-acroread

Give these audio players a try:

sudo apt-get install exaile audacious

Exaile is a GTK fork of Amarok and Audacious is a nice small and simple Winamp style audio player. You might also like to try a newish and unfinished jukebox-like media player called Songbird. Just download the correct version for your architecture and give it a whirl. To install the downloaded deb package, just double or single-click on it, or install using the right-click context menu. Type your password when prompted to do so.

You might be interested in having Google Earth too:

sudo apt-get install googleearth

For P2P file sharing, give Frostwire a try. Always worked pretty well for me. To install the deb package, just double or single-click on it , or use the right-click context menu. Type your password when prompted.

If you want an easy way to edit usplash (Ubuntu loading screen) then you have to try this application:

sudo apt-get install startupmanager

It installs into System>Administration. Keep the colour depth to 16-Bits or you may experience strange shutdown behaviour.

Don't forget to check out some of the games in Synaptic. Briquolo is fun, try that. Some games will not create menu entries, make them yourself if that happens (the name of the game is often the command to launch it).


--TROUBLESHOOTING--


1. If your RealPlayer's playback is terrible (mine was) you have to do some manual editing. First of all, install "alsa-oss" (added to "Essential" in Part 1). Now you need to copy and paste these commands into the Terminal and do some manual editing:

gksudo gedit /usr/bin/realplay

Find the line "echo "Warning: LD_PRELOAD=\"$LD_PRELOAD\"" and underneath "fi" paste these two lines:

LD_PRELOAD="$LDPRELOAD:/usr/lib/libaoss.so"
export LD_PRELOAD

Save and close. Also, open RealPlayer's preferences and go to "Transport" and select "Use specified transport". Then go into the two configure options beneath that and untick everything except "http". You can also select your connection speed in preferences and tell RealPlayer not to send connection info back to real.com.

2. Sometimes you will click on a video link and Firefox will ask if you want to download it or open it with a certain application. Many times though, you will want to play or open it with a different application to the one offered. Click to choose your own application and navigate to /usr/bin and you will find your audio and video apps there.

3. Use the "xv" video driver if you can. Open MPlayer and right click on the video window, then click on "Preferences". Click on the "Video" tab and select "xv", or if you can't use that try "gl". As a last restort you should select "x11" (unaccelerated). Please note: If you are having trouble using the "xv" video driver, you should search the forums and google as it's highly unlikely your card doesn't support it. Some users have to make a few changes to get it working.

4. Sometimes MPlayer looks like it is about to start playing a video, but it does not. Try pressing play and don't just give up and navigate away. BBC wmv radio streams take a long time to start playing, the ram streams start quicker and sound better.

5. If Firefox doesn't recognise that you have changed your plugins and says "Plugin Required", or something like that, then you need to:

rm $HOME/.mozilla/firefox/pluginreg.dat

You have to do this EVERYTIME you change plugins or edit your mplayerplug-in.conf file. Then open Firefox and type "about:plugins" in the address bar and press enter. You should now see a very long list of plugins (Java, Flash, RealPlayer, Windows Media etc).

6. Are you using a non-default web browser? You may need to link your plugins folder to that browser. To create a symbolic link, you need to do something like this "ln -s /usr/lib/firefox/plugins /fullpathtobrowser". Rename or delete the plugins folder it already has, or use the "ln -sf" symlink command as it forces the link to replace whatever plugins folder is already present.

7. Having problems with the Adobe Flash plugin after updating? Close Firefox, then cut and paste this command into the Terminal:

sudo apt-get purge flashplugin-nonfree && sudo apt-get install flashplugin-nonfree

Also, if you don't have any sound in flash videos or you notice strange random behaviour by Firefox, you should try this next solution. Make sure you have the package "alsa-oss" from Part 1 and then paste this command into the Terminal:

gksudo gedit /etc/firefox/firefoxrc

Edit the line "FIREFOX_DSP=”none”" and change "none" to "aoss". Then close and save the file. Restart Firefox.

Still having issues? If you're a 64-Bit Ubuntu user, you might get better results using an older version of Adobe Flash. Please refer to the following thread and use the recommended script.

8. Java not working correctly? Close Firefox and then try this command below. Make sure you select the latest Java, which will be somewhere in /usr/lib:

sudo update-alternatives --config java

Still no go? Ubuntu 32-Bit users who are trying to use Sun Java might want to make sure they don't have IcedTea/OpenJDK Java and it's plugin installed, as it will conflict with the Sun Java plugin:

sudo apt-get remove icedtea-java7-bin icedtea-java7-jre icedtea-java7-plugin icedtea-gcjwebplugin openjdk-6-jre

Same goes for 64-Bit users trying to use IcedTea/OpenJDK Java, it might be a good idea to check you don't have any version of Sun Java installed and it's relevant plugin:

sudo apt-get remove sun-java6-bin sun-java6-fonts sun-java6-jre sun-java6-plugin sun-java5-bin sun-java5-fonts sun-java5-jre sun-java5-plugin

If you have followed those steps and still can't get IcedTea Java applets working properly, it may be worth adding the unofficial repository for Gutsy, which can be done in System>Administration>Software Sources in Ubuntu, or the command line way:

gksudo gedit /etc/apt/sources.list

Then copy and paste these two lines into it:

deb http://people.ubuntu.com/~doko/ubuntu/ gutsy/
deb-src http://people.ubuntu.com/~doko/ubuntu/ gutsy/

Make sure you save your changes, then perform a "sudo apt-get update", or alternatively just reload Synaptic/Adept. After you have refreshed your list of packages you can perform a "sudo apt-get upgrade", or just wait for the update manager to realise there are updates. IcedTea Java will be updated and hopefully work much better than previously.

9. Are you having trouble with new DVDs? Please refer to this link and concentrate on the solution for VLC.

10. Still have problems? REBOOT. You have made lots of changes to your system.

Enjoy,

Nathan


最后由 jerrycgc 编辑于 2008-05-01 22:07,总共编辑了 3 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-01 21:36 
头像

注册: 2007-12-09 14:35
帖子: 1230
送出感谢: 0 次
接收感谢: 0 次
晕一个


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-05-01 22:00 

注册: 2008-04-04 22:38
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
原文是从ubuntu英文论坛转来的,大家需要的话,有时间可以翻译一下,看大家需不需要啦


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-05-02 12:01 

注册: 2007-06-11 10:56
帖子: 83
送出感谢: 0 次
接收感谢: 0 次
= = 看幾個人能看懂~


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-05-09 11:16 

注册: 2007-02-21 21:57
帖子: 79
送出感谢: 0 次
接收感谢: 0 次
看不懂啊,晕了


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-05-09 22:00 

注册: 2007-10-06 21:37
帖子: 119
送出感谢: 0 次
接收感谢: 0 次
当然需要,不过很多人看不懂,翻译后就需要了 :D


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-05-09 23:41 

注册: 2008-05-07 23:53
帖子: 42
送出感谢: 0 次
接收感谢: 0 次
8) 很强的帖子哦,不过就是看不太懂,期待翻译出现哦。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-05-09 23:53 
头像

注册: 2008-04-14 23:29
帖子: 2114
地址: 曾也在NB大学呆过
送出感谢: 3
接收感谢: 10
本来还想看看的,结果一拉。。这么长。。。。。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-05-10 17:27 

注册: 2007-09-06 16:07
帖子: 466
送出感谢: 0 次
接收感谢: 0 次
复杂


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-05-11 21:57 

注册: 2007-07-14 22:39
帖子: 229
送出感谢: 0 次
接收感谢: 0 次
需要。哪位达人翻译一下啊。懒得看英文长篇。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-05-12 0:26 

注册: 2008-03-09 14:23
帖子: 35
送出感谢: 0 次
接收感谢: 0 次
研究一下!看看是什么意思


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-05-12 6:16 

注册: 2007-06-30 17:40
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
太多了,你应该精简一下


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-05-12 8:42 
头像

注册: 2007-12-26 11:55
帖子: 88
地址: Ubuntu 社区
送出感谢: 0 次
接收感谢: 0 次
azm_1981 写道:
当然需要,不过很多人看不懂,翻译后就需要了 :D


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2008-05-27 15:53 

注册: 2007-02-09 14:01
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
把上面的内容精简了下,但只适合32位用户
上面的内容还有Xbuntu、Kbuntu、Ubuntu 8.04 64bit的一些设置,不过我没写上去
1.Essential Pcakages
#sudo gedit /etc/apt/souces.list 原地址修正一下
deb http://mirror.lupaworld.com/ubuntu hardy main restricted universe multiverse
deb http://mirror.lupaworld.com/ubuntu hardy-security main restricted universe multiverse
deb http://mirror.lupaworld.com/ubuntu hardy-updates main restricted universe multiverse
deb http://mirror.lupaworld.com/ubuntu hardy-backports main restricted universe multiverse
deb http://mirror.lupaworld.com/ubuntu hardy-proposed main restricted universe multiverse
deb-src http://mirror.lupaworld.com/ubuntu hardy main restricted universe multiverse
deb-src http://mirror.lupaworld.com/ubuntu hardy-security main restricted universe multiverse
deb-src http://mirror.lupaworld.com/ubuntu hardy-updates main restricted universe multiverse
deb-src http://mirror.lupaworld.com/ubuntu hardy-backports main restricted universe multiverse
deb-src http://mirror.lupaworld.com/ubuntu hardy-proposed main restricted universe multiverse

update

Adobe Flash Installation
#apt-get purge flashplugin-nonfree gnash gnash-common && sudo apt-get install

flashplugin-nonfree

#sudo apt-get remove icedtea-gcjwebplugin openjdk-6-jre && sudo apt-get install alsa-oss

compizconfig-settings-manager faad gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad

gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly

gstreamer0.10-plugins-ugly-multiverse gstreamer0.10-pitfdll libflashsupport liblame0

sun-java6-fonts sun-java6-jre sun-java6-plugin unrar w32codecs

had errors(如果发生错误的话)
#sudo dpkg --configure -a
Or print it was command
#sudo apt-get install -f
Was that not the error you had?Try these commands instead:
#sudo rm /var/lib/apt/lists/partial/*
#sudo apt-get update

2.Streaming with Firefox 安装Firefox插件
#sudo apt-get remove totem-mozilla mozilla-plugin-vlc xine-plugin kaffeine-mozilla

helix-player mozilla-helix-player 在线多媒体播放
#sudo apt-get install mplayer mozilla-mplayer
Mplayer Preferences>select Audio>"Enable Software Mixer"
#gedit ~/.mplayer/mplayerplug-in.conf
复制
download=1
cachesize=1024
cache-percent=25
keep-download=0
dload-dir=$HOME
noembed=0
autoplay=1
enable-wmp=1
enable-qt=1
enable-rm=0
enable-gmp=1
enable-dvx=1
enable-mpeg=1
enable-mp3=1
enable-midi=0
enable-pls=1
enable-ogg=1
enable-smil=0
enable-helix=0
nomediacache=0
nopauseonhide=1
black-background=1
rtsp-use-http=0
rtsp-use-tcp=0
Close and save the file
#rm ~/.mozilla/firefox/pluginreg.dat
#sudo apt-get install smplayer
3.Sound & Video Conversion
#sudo apt-get install soundconverter oggconvert
#sudo apt-get install ffmpeg faac
4.DVD Playback/Ripping/Burning DVD播放与刻录
#sudo /etc/apt/sources.list
Go to the line which starts as "deb cdrom" (at the top in my sources list) and just put a #
找的deb cdrom把#去掉
before it. Close and save the file.
#sudo apt-get install vlc
#sudo apt-get install gxine libxine1-ffmpeg
#sudo apt-get install libdvdcss2 libdvdread3 libdvdnav4 build-essential debhelper fakeroot
#sudo /usr/share/doc/libdvdread3/install-css.sh
或者#sudo /usr/share/doc/libdvdread3/examples/install-css.sh
#sudo gedit /etc/gnome/defaults.list
Search x-content/video
totem.desktop (R) vlc.desktop (找到totem.desktop替换成vlc.desktop)
Edit vlc Meus to Launcher Properties(打开 VLC 设置)
vlc --vout-filter deinterlace --deinterlace-mode blend --volume 512 --fullscreen %m
Close the VLC properties dialog and exit the menu editor. Finally

#sudo apt-get install dvdrip
#sudo apt-get install regionset
RC1 = North America (USA and Canada)
RC2 = Europe, Middle East, South Africa and Japan
RC3 = Southeast Asia, Taiwan, Korea
RC4 = Latin America, Australia, New Zealand
RC5 = Former Soviet Union (Russia, Ukraine, etc.), rest of Africa, India
RC6 = China

5.Miscellaneous &Troubleshotting
#gedit /etc/x11/xorg.conf
copy the blod into you conf file (把以下的复制到conf的文件里)

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
Option "SHMConfig" "on"
EndSection

Make sure it all looks okay and that the "EndSection" text is in the right place, then close

and save. Now, navigate to System>Preferences>Sessions and click on "Add". Name it something

like "Touchpad Syndaemon", the description can be "Disables touchpad while typing", and the

all important command you need is "syndaemon -i .5 -d". For it to take effect, REBOOT. Why

isn't it default for laptop users? Well, apparently it's insecure. If you share your laptop

with others, technically they could disable your touchpad. Personally, I think there should

be an option in System>Preferences>Mouse to enable this feature, with a warning if

necessary.


#sudo apt-get remove mozplugger && sudo apt-get install acroreader
#sudo apt-get install exaile audacious
#sudo apt-get install googleearth
#sudo apt-get install startupmanager
It installs into System>Administration. Keep the colour depth to 16-Bits or you may

experience strange shutdown behaviour

①Are you using a non-default web browser? You may need to link your plugins folder to that

browser. To create a symbolic link, you need to do something like this "ln -s

/usr/lib/firefox/plugins /fullpathtobrowser". Rename or delete the plugins folder it already

has, or use the "ln -sf" symlink command as it forces the link to replace whatever plugins

folder is already present

②Having problems with the Adobe Flash plugin after updating? Close Firefox, then cut and

paste this command into the Terminal:

#sudo apt-get purge flashplugin-nonfree && sudo apt-get install flashplugin-nonfree

③Also, if you don't have any sound in flash videos or you notice strange random behaviour

by Firefox, you should try this next solution. Make sure you have the package "alsa-oss"

from Part 1 and then paste this command into the Terminal:

#sudo gedit /etc/firefox/firefoxrc

Edit the line "FIREFOX_DSP=”none”" and change "none" to "aoss". Then close and save the

file. Restart Firefox.

④Java not working correctly? Close Firefox and then try this command below. Make sure you

select the latest Java, which will be somewhere in /usr/lib:

#sudo update-alternatives --config java

Still no go? Ubuntu 32-Bit users who are trying to use Sun Java might want to make sure they

don't have IcedTea/OpenJDK Java and it's plugin installed, as it will conflict with the Sun

Java plugin:

⑤#sudo apt-get remove icedtea-java7-bin icedtea-java7-jre icedtea-java7-plugin

icedtea-gcjwebplugin openjdk-6-jre
如果有错误的话请帮忙纠正。。本人英文水平也不是很好


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2008-05-28 9:30 
头像

注册: 2008-01-19 1:21
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
E文不好的说!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译