当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : amd 64下mplay播放rmvb及rm格式电影常见问题和解决方法
帖子发表于 : 2008-05-08 0:37 
头像

注册: 2008-05-03 23:32
帖子: 60
送出感谢: 0 次
接收感谢: 0 次
在前人基础上总结的:

在新立得中有mplay下载安装

mplay不能播放rmvb
我再补充下,amd64的不要下载那个w32codecs,我因为这个郁闷了N久
到http://www.mplayerhq.hu/design7/dload.html

Binary Codec Packages下载 Linux AMD64
然后
mkdir codecs in the /usr/lib
ln -s /usr/lib/codecs /usr/lib/win32
别再走冤路

如果你是cn99或是cn.ubuntu的源的话可以
*代码:*
sudo apt-get install w32codecs

,如果是其他源的话,可以到mplayer的官方站点下载http:
//www.mplayerhq.hu/MPlayer/releases/codecs/all-20061022.tar.bz2,在
/usr/lib目录里新建codecs目录,将下载的文件中的解码文件复制到codecs目录,
然后
*代码:*
sudo ln -s /usr/lib/codecs /usr/lib/win32

.mplayer需要在第一次启动的时候选定视频输出驱动。启动mplayer,右键单击控
制窗口,选择 “prefenece"->"video”->"xv"[/code]

mplayer不能全屏播放?

关掉mplayer

gksudo gedit /etc/mplayer/mplayer.conf

找到#zoom = yes 行去掉前边的#
保存

看到论坛中有不少问题是关于Mplayer的,我根据自己碰到的问题整理几个。借此抛砖引玉,希望大家能够把碰到的关于Mplayer的问题及解决方法拿出来共享。


1.点击视频,提示“Error opening/initializing the selected video_out(-vo) device"。点击“ok“后,可以播放音频,但是无图像。
解决方法:
右键点击Mplayer主程序,选择“preferences",弹出选项窗口,选择“video“标签,在“Availble drivers"下面选择 “X11 X11(Ximage/Shm),点击“ok“确定即可。

2.播放视频进行全屏显示时,图像大小保持不变,无法填充整个屏幕
解决方法:打开终端,运行以下命令
引用:
gedit ~/.mplayer/config

在弹出的文件中写入一行
引用:
zoom=yes

保存退出即可。



我的也只有声音没有图像
报错是:Error opening/initializing the selected video_put(-vo)device.
references->video:选X11(XImage/shm),然后OK

我想我知道原因了。
MPlayer使用的声卡驱动默认是OSS。当你使用的声卡驱动是Alsa时,当然就听不
到,也找不到设备了。解决办法了有了。
右键点播放器,然后点"Preferences"进入"Audio",双击"alsa",然后,"Configure
diver",使用默认设备,这样就可以听到声音了


_________________
AMD64 Athlon Core 3600+ 
onda A69T
ATI X1250
Kingston DDR2 667 1G
Ubuntu 8.10

[size=100]
本人是unix/linux爱好者,欢迎曲靖的朋友联系一起交流,本人有刻录机,如有需要可以免费为朋友们刻盘。
联系电话18982675258[/size]


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-08 1:24 
头像

注册: 2006-03-04 23:10
帖子: 888
地址: 江西高安
送出感谢: 0 次
接收感谢: 2
不用这么麻烦,64位可以使用解码器w64codecs。
1.使用下面的命令进行安装。
引用:
sudo apt-get install w64codecs

2.如果源中没有w64codecs,可以下载w64codecs安装包进行安装。
引用:
wget -c http://www.debian-multimedia.org/pool/m ... _amd64.deb
sudo dpkg -i w64codecs_20071007-0.3_amd64.deb


_________________
QQ:273247606
EMAIL:yanghui1986527@gmail.com


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-05-09 13:44 
头像

注册: 2008-05-09 11:52
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
我的播放rm格式的时候只有图画没有声音怎么办呀?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-05-10 13:21 
头像

注册: 2008-05-03 23:32
帖子: 60
送出感谢: 0 次
接收感谢: 0 次
dandanfeng160 写道:
我的播放rm格式的时候只有图画没有声音怎么办呀?


1.点击视频,提示“Error opening/initializing the selected video_out(-vo) device"。点击“ok“后,可以播放音频,但是无图像。
解决方法:
右键点击Mplayer主程序,选择“preferences",弹出选项窗口,选择“video“标签,在“Availble drivers"下面选择 “X11 X11(Ximage/Shm),点击“ok“确定即可。


_________________
AMD64 Athlon Core 3600+ 
onda A69T
ATI X1250
Kingston DDR2 667 1G
Ubuntu 8.10

[size=100]
本人是unix/linux爱好者,欢迎曲靖的朋友联系一起交流,本人有刻录机,如有需要可以免费为朋友们刻盘。
联系电话18982675258[/size]


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-05-10 17:19 

注册: 2007-09-06 16:07
帖子: 466
送出感谢: 0 次
接收感谢: 0 次
好像不需要建立符号链接吧?
我是这样搞的:
apt-get install mplayer
然后到www.mplayerhq.hu下载amd64的codecs,只有几百k
然后 sudo mkdir /usr/lib/codecs,然后把解压出来的解码器(一共就4个文件)一起cp到刚建立的目录里。
然后启动mplayer选好vo和ao,就能放rm、rmvb了。

根本就不需要w32codecs,也不需要ln -s /usr/lib/codecs /usr/lib/win32


页首
 用户资料  
 
6 楼 
 文章标题 : Re: amd 64下mplay播放rmvb及rm格式电影常见问题和解决方法
帖子发表于 : 2009-07-09 17:53 

注册: 2008-08-01 10:09
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
嘿嘿。。。。非常好。。谢谢拉。。。。解码器收下了。 :em11 :em11


页首
 用户资料  
 
7 楼 
 文章标题 : Re: amd 64下mplay播放rmvb及rm格式电影常见问题和解决方法
帖子发表于 : 2009-11-28 21:30 
头像

注册: 2009-05-08 20:29
帖子: 210
地址: 广东
送出感谢: 0 次
接收感谢: 0 次
如果cpu是amd64,但是装的是32位的ubuntu,应该下载w32codecs 还是 w64codecs?


页首
 用户资料  
 
8 楼 
 文章标题 : Re: amd 64下mplay播放rmvb及rm格式电影常见问题和解决方法
帖子发表于 : 2009-11-28 21:33 
头像

注册: 2007-05-06 2:46
帖子: 15634
送出感谢: 0 次
接收感谢: 2
w32codecs
引用:
装的是32位的ubuntu


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译