gcc版本太过装不了mplayer,应该怎么办?

Totem,mplayer,sopcast,realplayer,bmp
回复
zehn
帖子: 5
注册时间: 2006-04-03 16:31
送出感谢: 0
接收感谢: 0

gcc版本太过装不了mplayer,应该怎么办?

#1

帖子 zehn » 2006-04-06 19:42

能否重装gcc?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-04-06 20:23

再安装对应版本的。
要不就把现有的ln一个假版本出来。
● 鸣学
zehn
帖子: 5
注册时间: 2006-04-03 16:31
送出感谢: 0
接收感谢: 0

#3

帖子 zehn » 2006-04-07 8:51

装了pacth,好像就可以装了。不过cantnot load font /usr/local/share/mplayer/font/font.desc
我装的是vera***那个字体,怎么弄呢?
ps:主页上的mplayer 帮助好像老了点,有些错误
fuhuizn
帖子: 740
注册时间: 2006-01-06 22:55
系统: ubuntu
送出感谢: 0
接收感谢: 14 次
联系:

#4

帖子 fuhuizn » 2006-04-13 11:31

apt-get install gcc-3.4
GPX-ZERO
帖子: 38
注册时间: 2005-08-04 14:37
来自: 中国香港
送出感谢: 0
接收感谢: 0

#5

帖子 GPX-ZERO » 2006-04-13 19:48

不知这样可以不可以
CC=/usr/bin/gcc-3.4 CXX=/usr/bin/g++-3.4 ./configure

另外字体需要修改config档––可以打开gedit按Ctrl+l后输入 ~/.mplayer/config, 然后在空白地方输入 font=字体位置
这样MPlayer的OSD和字幕都会选用那字体
yoshubom
帖子: 233
注册时间: 2005-12-28 16:23
送出感谢: 0
接收感谢: 0

#6

帖子 yoshubom » 2006-04-15 21:40

我用的是FC5 在编译的时候加上一个选项 --c=gcc32 就可以了。前提是系统要装上gcc3.2,也可以是其他的3x版本吧。
回复

回到 “影音多媒体”