Mplayer有声音无图像+选x11(ximage+shm)也无效

Totem,mplayer,sopcast,realplayer,bmp
头像
pedant
帖子: 1093
注册时间: 2005-12-23 0:29
送出感谢: 0
接收感谢: 0

Mplayer有声音无图像+选x11(ximage+shm)也无效

#1

帖子 pedant » 2008-05-24 20:47

Mplayer有声音无图像+选x11(ximage+shm)也无效

出错截图如附件
附件
mplayer.png
mplayer.png (10.33 KiB) 查看 3196 次
发行版本:Ubuntu 11.04
桌面环境:GNOME 2.32.1
文件系统:ext4
内核:Linux 2.6.38-9-generic
平台:i686
CPU:Intel(R) Celeron(R) CPU 550 @ 2.00GHz
内存:993.2 MB
显卡芯片:Intel(R) GM965
电脑型号:DELL 500笔记本
头像
jarlyyn
论坛版主
帖子: 4671
注册时间: 2006-04-12 18:54
送出感谢: 0
接收感谢: 6 次
联系:

#2

帖子 jarlyyn » 2008-05-24 20:54

win32codec装了没?
youxin
帖子: 81
注册时间: 2006-11-05 8:07
送出感谢: 0
接收感谢: 0

#3

帖子 youxin » 2008-06-13 18:20

win32codec,我是装了。但播放网络电视有声音没图像。
头像
hellojinjie
帖子: 1144
注册时间: 2007-09-14 21:03
来自: 浙江
送出感谢: 0
接收感谢: 0

Re: Mplayer有声音无图像+选x11(ximage+shm)也无效

#4

帖子 hellojinjie » 2008-08-20 19:31

pedant 写了:Mplayer有声音无图像+选x11(ximage+shm)也无效

出错截图如附件
我也出现这样的情况,怎么解决?
Say hello to everyday!
头像
jianglichao
帖子: 90
注册时间: 2007-12-13 10:50
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 jianglichao » 2008-08-24 14:11

我也是 - - 声音非常不错 。。。。速度也很快 。
就是没图像。。。郁闷的
头像
kwindva
帖子: 562
注册时间: 2007-05-05 23:30
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 kwindva » 2008-08-24 20:25

mplayer,最好自己编译吧。
coolow
帖子: 124
注册时间: 2007-03-24 20:09
送出感谢: 0
接收感谢: 0

#7

帖子 coolow » 2008-08-26 13:37

代码: 全选

   1. 下载w32codecs,解压到/usr/lib/win32
   2. sudo ln -s /usr/lib/win32 /usr/lib/codecs
   3. sudo aptitude install libstdc++5
查了n多资料才摸索出来的 :lol: :lol:
头像
追疯少年
帖子: 950
注册时间: 2008-03-13 23:37
送出感谢: 0
接收感谢: 1 次
联系:

#8

帖子 追疯少年 » 2008-08-27 7:43

在首选项里,进入 常规 再 视频选项里,不是有好几个有关视频输出的吗??想 x11,gl,什么的。 不行的话就欢一个。
一一个的换,肯定可以滴!前提是你装了wincode32
coolow
帖子: 124
注册时间: 2007-03-24 20:09
送出感谢: 0
接收感谢: 0

#9

帖子 coolow » 2008-08-27 15:00

追疯少年 写了:在首选项里,进入 常规 再 视频选项里,不是有好几个有关视频输出的吗??想 x11,gl,什么的。 不行的话就欢一个。
一一个的换,肯定可以滴!前提是你装了wincode32
试过了。不行的。以前的版本可以。但8.04不行了。
头像
hellojinjie
帖子: 1144
注册时间: 2007-09-14 21:03
来自: 浙江
送出感谢: 0
接收感谢: 0

#10

帖子 hellojinjie » 2008-08-28 23:05

coolow 写了:

代码: 全选

   1. 下载w32codecs,解压到/usr/lib/win32
   2. sudo ln -s /usr/lib/win32 /usr/lib/codecs
   3. sudo aptitude install libstdc++5
查了n多资料才摸索出来的 :lol: :lol:
thx 搞定
Say hello to everyday!
头像
JCheung
帖子: 95
注册时间: 2008-08-14 0:53
送出感谢: 0
接收感谢: 0

#11

帖子 JCheung » 2008-08-30 10:35

coolow 写了:

代码: 全选

   1. 下载w32codecs,解压到/usr/lib/win32
   2. sudo ln -s /usr/lib/win32 /usr/lib/codecs
   3. sudo aptitude install libstdc++5
查了n多资料才摸索出来的 :lol: :lol:

我也是这个问题,谢谢你阿!!!
:em53 :em53 :em53
hominidzl
帖子: 1
注册时间: 2008-08-30 19:04
送出感谢: 0
接收感谢: 0

#12

帖子 hominidzl » 2008-08-30 19:40

发一个做好的W32codecs包。把原来那个卸了,再装这个试试 :)
http://sk.archive.ubuntu.com/debian-mul ... 1_i386.deb
gjwanghaicheng
帖子: 18
注册时间: 2008-11-08 22:28
送出感谢: 0
接收感谢: 0

Re:

#13

帖子 gjwanghaicheng » 2008-12-26 16:57

JCheung 写了:
coolow 写了:

代码: 全选

   1. 下载w32codecs,解压到/usr/lib/win32
   2. sudo ln -s /usr/lib/win32 /usr/lib/codecs
   3. sudo aptitude install libstdc++5
查了n多资料才摸索出来的 :lol: :lol:

我也是这个问题,谢谢你阿!!!
:em53 :em53 :em53
我的还是老问题。弄了一个下午了,还没有成功
gjwanghaicheng
帖子: 18
注册时间: 2008-11-08 22:28
送出感谢: 0
接收感谢: 0

Re: Mplayer有声音无图像+选x11(ximage+shm)也无效

#14

帖子 gjwanghaicheng » 2008-12-26 16:59

我是先下载了w32codecs,桌面解压后再用sudo cp -r 命令把它复制到/usr/lib/win32下去的。
然后再执行这两个命令:
sudo ln -s /usr/lib/win32 /usr/lib/codecs
sudo aptitude install libstdc++5
过程中也没有提示出错,libstdc++5也提示正确下载安装了。
可问题还没有解决 .
gjwanghaicheng
帖子: 18
注册时间: 2008-11-08 22:28
送出感谢: 0
接收感谢: 0

Re: Mplayer有声音无图像+选x11(ximage+shm)也无效

#15

帖子 gjwanghaicheng » 2008-12-26 19:13

播放avi的文件没问题,可播放rm,rmvb等文件时候就只有声音没有图像了。
回复

回到 “影音多媒体”