[问题]SOS!! mplayer播放时没有声音?

Totem,mplayer,sopcast,realplayer,bmp
回复
头像
flysohigh
帖子: 129
注册时间: 2007-09-28 21:56
送出感谢: 0
接收感谢: 0
联系:

[问题]SOS!! mplayer播放时没有声音?

#1

帖子 flysohigh » 2008-06-03 23:53

返回代码如下:

代码: 全选

Audio file file format detected.
==========================================================================
Forced audio codec: mad
Opening audio decoder: [libmad] libmad mpeg audio decoder
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
Selected audio codec: [mad] afm: libmad (libMAD MPEG layer 1-2-3)
==========================================================================
AO: [pulse] Failed to connect to server: Invalid argument
[AO_ALSA] alsa-lib: conf.c:1589:(snd_config_load1) _toplevel_:22:2:Unexpected char
[AO_ALSA] alsa-lib: conf.c:2850:(snd_config_hook_load) /etc/asound.conf may be old or corrupted: consider to remove or fix it
[AO_ALSA] alsa-lib: conf.c:2714:(snd_config_hooks_call) function snd_config_hook_load returned error: Invalid argument
[AO_ALSA] alsa-lib: conf.c:3079:(snd_config_update_r) hooks failed, removing configuration
[AO_ALSA] Playback open error: Invalid argument
[AO OSS] audio_setup: Can't open audio device /dev/dsp: Device or resource busy
[AO_ALSA] alsa-lib: conf.c:1589:(snd_config_load1) _toplevel_:22:2:Unexpected char
[AO_ALSA] alsa-lib: conf.c:2850:(snd_config_hook_load) /etc/asound.conf may be old or corrupted: consider to remove or fix it
[AO_ALSA] alsa-lib: conf.c:2714:(snd_config_hooks_call) function snd_config_hook_load returned error: Invalid argument
[AO_ALSA] alsa-lib: conf.c:3079:(snd_config_update_r) hooks failed, removing configuration
[AO_ALSA] Playback open error: Invalid argument
mcop warning: user defined signal handler found for SIG_PIPE, overriding
[AO ARTS] can't connect to aRts soundserver
[AO ESD] latency: [server: 0.19s, net: 0.00s] (adjust 0.19s)
AO: [esd] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
帮我看看呀!
上次由 flysohigh 在 2008-06-05 9:12,总共编辑 3 次。
头像
flysohigh
帖子: 129
注册时间: 2007-09-28 21:56
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 flysohigh » 2008-06-04 0:01

我之前按 wiki上说的去混音,结果就这样了!
http://wiki.ubuntu.org.cn/Ubuntu%E9%97% ... 7.E9.9F.B3
头像
flysohigh
帖子: 129
注册时间: 2007-09-28 21:56
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 flysohigh » 2008-06-04 0:18

代码: 全选

MPlayer 1.0rc2-4.2.3 (C) 2000-2007 MPlayer Team
CPU: AMD Turion(tm) 64 Mobile Technology MK-36 (Family: 15, Model: 76, Stepping: 2)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
Cannot load bitmap font: ~/.fonts/simsun.ttc
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing Track01.mp3.
Audio file file format detected.
==========================================================================
Forced audio codec: mad
Opening audio decoder: [libmad] libmad mpeg audio decoder
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
Selected audio codec: [mad] afm: libmad (libMAD MPEG layer 1-2-3)
==========================================================================
AO: [alsa] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...

乱弄了一下,又成这样的,还是没声音!
附件
Screenshot-音量控制器首选项.png
Screenshot-音量控制器首选项.png (9.33 KiB) 查看 986 次
头像
flysohigh
帖子: 129
注册时间: 2007-09-28 21:56
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 flysohigh » 2008-06-04 0:26

代码: 全选

 aplay -l
**** PLAYBACK硬件设备列表 ****
卡 0: NVidia [HDA NVidia], 设备 0: ALC861VD Analog [ALC861VD Analog]
  子设备: 1/1
  子设备:#0: subdevice #0
卡 0: NVidia [HDA NVidia], 设备 6: Si3054 Modem [Si3054 Modem]
  子设备: 1/1
  子设备:#0: subdevice #0
回复

回到 “影音多媒体”