当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [讨论]我在ubuntu下安装软件的一次经历及对ubuntu的使用感想
帖子发表于 : 2006-04-14 17:32 

注册: 2006-03-31 17:48
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
自从上个月安装使用ubuntu以来,一直运行良好,很多朋友遇到的安装配置问题我都没有出现(唯一的问题是桌面图标不显示文字,但不影响使用,这个我发在另一个帖子里了)。

前2天为了安装mysql5.0,结果系统的底层库架构被损坏。新立德里没有版本5.0,我从debian package网站下载相关包进行安装,由于5.0版是unstable,而我的系统是一个完整的stable版,因此前后共下载了60多个新装及升级包,升级了一部分系统的底层支持包,没想到安装到一半的时候,底层库依赖关系被破坏,安装不能进行下去,试着想退回去,也不行了,用 -f install运行一下,提示要卸载300多个软件包!呵呵相当于重装系统了。无赖只好强行继续安装,卸掉所有影响安装的组件,最后终于把mysql5.0安装成功,其中在最困难的阶段,libbonobo,gstream,xmms,bmp,mplayer,scim被卸载,nautilus,firefox,终端均不能启动(libbonobo是图形系统必须的库,缺了它大部分软件都无法启动)差不多已经打算重装系统了!能使用的工具只有xterm与以前安装的dillo浏览器,就凭着这2个工具下载需要的安装包继续安装,最终度过难关。

现在我的系统check完整性没有问题,但是底层库里stable与unstable版本相混杂。scim只剩下一个主包(升级了),而他却还能使用拼音输入法(奇怪!),xmms的firefox插件没了,gstream不能安装,播放视频音频totem,xmms都没问题,但是在网页上播放不了(在线播放以前没有测试过)。

装完5.0之后的好处是,firefox升级到1.5,thunderbird升级到1.5轻松实现(dpkg -i 就可以,没有依赖性问题),不再需要坛子里的朋友介绍的安装方法(以前用介绍的方法升级失败)。firefox,thunderbire的语言支持包全部卸掉,虽然菜单不是中文,但显示,输入中文都没有问题。mysql5.0运行正常,但是mysql-query-browser同样无法安装(碰到与装5.0时类似的问题,赶紧退回)。

装完5.0之后的难题是,gstream0.8装不上了,而且也没有相应的升级包可用,mplayer,bmp也安装不上,在gaim里不能使用输入法(敲一个字母gaim就崩溃),系统稳定性不如以前,偶尔有莫名其妙的自动退出现象(很少出现,不能确定是否装5.0导致)

我希望解决的是在线播放问题,由于没有mplayer,firefox少了很多插件,装了一个vlc插件,有时能播放在线mp3,在线电影无法做到,不知道各位有木有什么建议。

最后谈一下我对ubuntu的感觉,总体来说是一个相当不错的系统,系统稳定,软件众多(安装软件很方便),界面漂亮,我已经基本上不使用XP了。也有不少缺点,一些是作为一个开源OS,复杂多变是难免的,另一些我感觉是底层架构上有些缺陷,软件包依赖性太严重(比如2个软件包互相依赖,导致哪个也无法升级,安装5.0时多次碰到这种情况),更严重的是不同版本的软件包接口不一致,不提供向后兼容(即使很小的一个修改版也不行),结果可能一个软件包在系统里有多个版本,如果不同版本不能兼容,就导致有的软件安装不了。我想这也是新立德里只能安装stable版本的理由了,也因此很多人都认为新立德里的软件太旧,不能及时升级。比如mysql5.0发行已经很久了,新立德里却还只有4.0版(不是他不想,他是做不到,除非把整个系统升级了!呵呵)。我认为这是linux发行版底层架构上的最大缺陷(不是指linux内核),其他发行版估计也有类似问题。我本人作了多年软件开发,向后兼容是很容易做到的,不知道为什么linux下这些软件都是依赖指定的库版本,这样库包就没有存在的意义了,大家开发linux软件时把所有需要的库包都做成静态的不是更方便,也就不会出现安装不了的情况。

PS:关于中文支持,我感觉系统刚安装时出现的系统自带的中文字体很漂亮,虽然字体有点模糊,字号也小一点,但比后来安装的宋体漂亮,后来安装的感觉太土,圆体宋体是漂亮,但不是任何地方都适合使用,而且字体都那么大(圆体需要更多的修饰当然要大一点才行)。

这是我在ubuntu在安装使用软件的经历及感想,欢迎拍砖,呵呵!

##


最后由 nobug 编辑于 2006-04-14 17:41,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-04-14 17:37 
头像

注册: 2005-03-26 9:38
帖子: 521
送出感谢: 0 次
接收感谢: 0 次
你自己使用了debian里的包,不能怨ubuntu的依赖有问题。我们再三告诉大家不要使用debian的包,会有问题的。ubuntu中可以 apt-get isntall mysql-server5的


_________________
图片


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-04-14 17:49 

注册: 2006-03-31 17:48
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
freeflying 写道:
你自己使用了debian里的包,不能怨ubuntu的依赖有问题。我们再三告诉大家不要使用debian的包,会有问题的。ubuntu中可以 apt-get isntall mysql-server5的


遗憾,有这么方便的方法!看来俺孤陋寡闻阿(可是我在新立德里搜索不到server5,更换了多个源也没有找到:()

另外纠正一下,俺没有怪ubuntu的依赖性有木有问题,俺以前的整个stable版本系统很完整。

我在写下这个过程的想法也是想让大家知道,不要轻易尝试unstable的东西,不要轻易升级系统的底层库,我当时也是恰好能把各种包都装好,否则肯定是要重装了。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-04-15 12:47 

注册: 2006-04-11 9:01
帖子: 723
送出感谢: 0 次
接收感谢: 0 次
呵呵总体感觉ubuntu是很方便的。尤其是那个新手指南还有国内cn99镜像那速度,ubuntu给人有家的感觉。呵呵......
用linux一年了,感觉越来越方便快捷,又不失可配置性。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-04-25 17:34 
头像

注册: 2006-04-07 14:22
帖子: 64
送出感谢: 0 次
接收感谢: 0 次
赞楼主一个,正考虑要不要尝试ubuntu呢,呵呵

看来还是很值得尝试一下的


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-05-12 21:52 
头像

注册: 2006-03-23 17:11
帖子: 220
送出感谢: 0 次
接收感谢: 0 次
不错,都用了一个多月了,比WIN好玩多了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译