[已解决] mplayer on Ubuntu 8.04 srt 字幕部分乱码。累死了,截个图大家瞧瞧~

Totem,mplayer,sopcast,realplayer,bmp
回复
gagiel
帖子: 62
注册时间: 2007-03-05 16:57
送出感谢: 0
接收感谢: 0
联系:

[已解决] mplayer on Ubuntu 8.04 srt 字幕部分乱码。累死了,截个图大家瞧瞧~

#1

帖子 gagiel » 2008-07-06 0:08

情况如下:

Ubuntu 8.04 amd64

font 没有设置。(设置过雅黑和 ukai 都不成功)
Font 页选择 unicode
Subtitles 页选择 unicode

根据各位以往帖子的讨论,将字幕用 oo.o 2.4 转成 utf8。

但是却出来这么一个搞笑的问题:就是有时候乱码,有时候不是乱码……汗。。。
附件
Screenshot-MPlayer - Video.png
第一行正常,第二行乱码。
Screenshot-MPlayer - Video-1.png
反正不定都是乱码~
上次由 gagiel 在 2008-07-06 0:22,总共编辑 1 次。
Just an Ubuntu newbie.
gagiel
帖子: 62
注册时间: 2007-03-05 16:57
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 gagiel » 2008-07-06 0:22

搞定了。

命令行可以加 -subcp utf8(正好是 srt 字幕的编码)

或者 Subtitles 页就不要选任何 Encoding 了,选 None 。(汗)

真折腾人……
上次由 gagiel 在 2008-07-06 15:34,总共编辑 1 次。
Just an Ubuntu newbie.
头像
laowu2141
帖子: 530
注册时间: 2007-06-19 11:25
系统: kubuntu 13.04
来自: 北京
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 laowu2141 » 2008-07-06 1:47

装个smplayer吧!
头像
kofshower
帖子: 1343
注册时间: 2007-03-13 11:23
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 kofshower » 2008-07-06 3:12

这个是你的包里编译的时候config没有加cn吧,我编译完默认就ok
"We are all in the mud, but some of us are looking at the stars." (Oscar Wilde)
We are not born for ourselves.
人生天地间,并非为自己
Homepage:http://sites.google.com/site/polarisnotme/
gagiel
帖子: 62
注册时间: 2007-03-05 16:57
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 gagiel » 2008-07-06 15:33

kofshower 写了:这个是你的包里编译的时候config没有加cn吧,我编译完默认就ok
什么包?我这都是8.04默认的源下的。
Just an Ubuntu newbie.
gagiel
帖子: 62
注册时间: 2007-03-05 16:57
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 gagiel » 2008-07-06 19:35

laowu2141 写了:装个smplayer吧!
用了 smplayer ,也需要调整Subtitle 页 Encoding 到 UTF-8,不过感觉确实是比 gmplayer 好多了。
Just an Ubuntu newbie.
回复

回到 “影音多媒体”