[问题]有关realplayer一个怪问题

Totem,mplayer,sopcast,realplayer,bmp
回复
zrh617
帖子: 2
注册时间: 2006-04-07 22:02
送出感谢: 0
接收感谢: 0

[问题]有关realplayer一个怪问题

#1

帖子 zrh617 » 2006-04-22 16:21

直接用sudo apt-get install realplay安装好,放rm和rmvb格式的影片时只有声音没有图象。请问有人遇到过这种问题么,都是怎么解决的?
头像
zlfaigo
帖子: 220
注册时间: 2006-03-23 17:11
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 zlfaigo » 2006-05-09 22:07

我的只有图像,没有声音,提示说什么打不开音频设备。另一应用程序可能正在使用它。无论有没有程序有使用,不过只要重设一下就又好了,但等到下一次启动的时候又出现同样的情况了
头像
madoldman
帖子: 599
注册时间: 2006-02-27 20:19
来自: works system
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 madoldman » 2006-05-10 0:09

呵呵,是不是有其他的程序在占用声卡阿,Linux下声卡好像是独占的,如果有其他程序占用就播不出声了,以前有人发过关于混音的帖子,你搜索一下吧,或许对你有用,不过我按照那个配置后仍然不能两个程序同时发声,看你运气了,呵呵
东西路,南北走
十字路口人咬狗
拿起狗来打砖头
砖头咬了狗一口
图片
头像
zlfaigo
帖子: 220
注册时间: 2006-03-23 17:11
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 zlfaigo » 2006-05-10 17:35

怎么这个论坛的人怎么这么少啊,难道用ubuntu就这么几个人吗
xiechy
帖子: 1074
注册时间: 2006-01-18 15:01
送出感谢: 0
接收感谢: 1 次

#5

帖子 xiechy » 2006-05-11 21:20

realplay is using oss , not alsa, but it can still share the sound device(sometimes a little buggy). you may turn off the other software using sound device, and try again

to find out which program is using sound device , you can type:

代码: 全选

lsof /dev/snd/controlC0
头像
守望伊人
帖子: 189
注册时间: 2006-05-18 18:24
来自: 四川广安
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 守望伊人 » 2006-05-18 21:01

我的是其它软件都可以同时发声,但是就realplayer不行,只有单独用时才有声音
头像
cnshzj007
帖子: 685
注册时间: 2006-05-24 21:38
来自: 上海
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 cnshzj007 » 2006-06-01 18:55

lsof /dev/snd/controlC0

我没有显示有什么使用了音频,可是REALPLAY还是不能放音频。

那怎么办?
我只是一个ARCH的FANS,来自RH和UBUNTU的滋润!
回复

回到 “影音多媒体”