关于compiz和mplayer的冲突问题

Totem,mplayer,sopcast,realplayer,bmp
nosiop
帖子: 15
注册时间: 2007-11-30 10:12
来自: 重庆
送出感谢: 0
接收感谢: 0

关于compiz和mplayer的冲突问题

#1

帖子 nosiop » 2008-07-16 21:21

刚装了ubuntu8.04,希望使用mplayer作为视频播放软件。但是当开启了compiz之后,mplayer播放会有问题,在此想请教一下诸位。
我的显卡是使用的ATI的,mplayer的vo参数使用的x11,虽然更改了zoom,cache和cache_size参数,但是使用全屏播放时效果并不好。于是希望vo改用gl进行播放,但是当compiz同时处于开启状态的时候,mplayer在gl状态下就会出现闪烁的情况。我想请教一下,这个冲突是怎么引起的,有没有什么办法可以解决该冲突,望诸位赐教。
头像
vic_su
帖子: 29
注册时间: 2007-02-24 22:01
来自: GDUFS-GD-CHN
送出感谢: 0
接收感谢: 0

#2

帖子 vic_su » 2008-07-17 8:27

我也有同样的问题,顶~~~~~
我开着compiz时,用totem和mplayer播放视频都有闪烁的情况~
nosiop
帖子: 15
注册时间: 2007-11-30 10:12
来自: 重庆
送出感谢: 0
接收感谢: 0

#3

帖子 nosiop » 2008-07-17 18:02

真的就没有牛人能回复一下吗,唉~~~ ,只能自己顶一下了:(
头像
command
帖子: 306
注册时间: 2007-10-14 0:50
来自: GUCAS
送出感谢: 0
接收感谢: 1 次

#4

帖子 command » 2008-07-17 18:11

这是ati驱动的问题,现在还解决不了。
OS: Debian GNU/Linux
Version: lenny
Kernel: 2.6.36
Xorg: 1.4.2
CPU: Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz
HD: 320G SATA
Memory: 2G DDRIII
Graphics:Mobility Radeon HD 3450
头像
kearolop
帖子: 143
注册时间: 2007-12-23 9:53
送出感谢: 0
接收感谢: 0

#5

帖子 kearolop » 2008-07-17 18:39

我就干脆把compiz去掉算了,反正也不怎么用得着的,用了总有错觉会慢一点
nosiop
帖子: 15
注册时间: 2007-11-30 10:12
来自: 重庆
送出感谢: 0
接收感谢: 0

#6

帖子 nosiop » 2008-07-17 21:55

既然是这样的话,可能就没有什么好办法了,只有忍了。对了,随便问一句,那如果不是ATI的显卡,NVIDIA的显卡会有这样的问题吗?
头像
command
帖子: 306
注册时间: 2007-10-14 0:50
来自: GUCAS
送出感谢: 0
接收感谢: 1 次

#7

帖子 command » 2008-07-18 19:23

没用过NVIDIA,不知道是不是有这个问题。mplayer打一个补丁程序,在ati下就不会闪了。
OS: Debian GNU/Linux
Version: lenny
Kernel: 2.6.36
Xorg: 1.4.2
CPU: Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz
HD: 320G SATA
Memory: 2G DDRIII
Graphics:Mobility Radeon HD 3450
头像
jarryson
帖子: 4002
注册时间: 2005-08-14 19:53
送出感谢: 1 次
接收感谢: 2 次
联系:

#8

帖子 jarryson » 2008-07-18 19:46

最简单的方法,看电影的时候去掉compiz。vista下用mplayer也是不能开启特效的

或者把视频输出改为x11

复杂的方法,给mplayer打混合补丁,然后compiz控制里面打开视频回放扩展。这样就不会闪了。

或者如果显卡不是太新,就使用开源驱动,这样就不会闪了
nosiop
帖子: 15
注册时间: 2007-11-30 10:12
来自: 重庆
送出感谢: 0
接收感谢: 0

#9

帖子 nosiop » 2008-07-20 13:18

对回复的兄弟们先谢了,有没有人能贴出来,关于打mplayer打混合补丁的方法步骤啊?
头像
jeffwei
帖子: 1344
注册时间: 2007-05-12 22:48
送出感谢: 0
接收感谢: 0

#10

帖子 jeffwei » 2008-07-20 16:26

ati的不知道,不过告诉你播放本地文件不要改cache和cache_size参数,默认0
bingo20
帖子: 21
注册时间: 2007-10-05 20:16
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 bingo20 » 2008-07-21 22:52

不是很确定的经验:
我的也是a卡,好像源里的驱动不存在冲突问题。我之前装的是realplayer,没装mplayer,印象中是装的源里的驱动,不闪,后来重装,换了最新的8.6驱动,realplayer闪,mplayer也闪,调整参数后不善闪。(之前源里的没調参数)。
aprilfool
帖子: 7
注册时间: 2007-09-19 21:12
送出感谢: 0
接收感谢: 0

#12

帖子 aprilfool » 2008-07-21 23:59

nosiop 写了:对回复的兄弟们先谢了,有没有人能贴出来,关于打mplayer打混合补丁的方法步骤啊?


参考这里:http://ubuntuforums.org/showthread.php?t=636277,有详细的步骤
头像
zebrattt
帖子: 629
注册时间: 2007-11-12 14:27
来自: 地球的角落
送出感谢: 0
接收感谢: 2 次

Re: 关于compiz和mplayer的冲突问题

#13

帖子 zebrattt » 2008-07-25 1:06

nosiop 写了:刚装了ubuntu8.04,希望使用mplayer作为视频播放软件。但是当开启了compiz之后,mplayer播放会有问题,在此想请教一下诸位。
我的显卡是使用的ATI的,mplayer的vo参数使用的x11,虽然更改了zoom,cache和cache_size参数,但是使用全屏播放时效果并不好。于是希望vo改用gl进行播放,但是当compiz同时处于开启状态的时候,mplayer在gl状态下就会出现闪烁的情况。我想请教一下,这个冲突是怎么引起的,有没有什么办法可以解决该冲突,望诸位赐教。



ati真是麻烦, 以前折腾我很久。 现在新机器是intel显卡, 什么问题都没有,爽
czj
帖子: 88
注册时间: 2008-01-28 12:48
送出感谢: 0
接收感谢: 0

#14

帖子 czj » 2008-08-02 18:11

bingo20 写了:不是很确定的经验:
我的也是a卡,好像源里的驱动不存在冲突问题。我之前装的是realplayer,没装mplayer,印象中是装的源里的驱动,不闪,后来重装,换了最新的8.6驱动,realplayer闪,mplayer也闪,调整参数后不善闪。(之前源里的没調参数)。


啥意思,到底调整后闪不闪了,俺听不懂。
头像
kts
帖子: 238
注册时间: 2008-07-31 17:03
送出感谢: 0
接收感谢: 0
联系:

#15

帖子 kts » 2008-08-03 22:38

我是u卡,一点问题也没有
这个世上有许多迷人的问题等着被解决,无聊而又单调的工作是有害的。
回复

回到 “影音多媒体”