当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 笔记本插上耳机后声音还能外放
帖子发表于 : 2008-08-08 8:25 

注册: 2006-05-03 9:10
帖子: 141
送出感谢: 0 次
接收感谢: 0 次
这是怎么回事,
难道华硕的笔记本牛比
我的本是x53series


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-08-08 10:49 
头像

注册: 2007-10-20 15:26
帖子: 175
送出感谢: 0 次
接收感谢: 0 次
耳机和那孔没咬合,旧耳机经常出现这问题,换个耳机试试


_________________
山高不挡云,水浅能溶月


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-08-08 17:27 
头像

注册: 2005-12-23 19:20
帖子: 1677
送出感谢: 0 次
接收感谢: 0 次
楼主 我的电脑和你的电脑是一个型号的 这是alsa驱动的问题 你要修改 /etc/modprobe.d/alsa-base

这个文件 把最后一行的的mode=写成 lenovo 如此就没有问题了


_________________
Kubuntu10.10& Windows 7 ultimate
Acer 4738ZG
Intel PM dual core P6100 2.00G
4G DDR1333
ATI Mobility Radeon HD5470
750G HDD
14.0 WXGA 1366×768


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-08-08 17:29 
头像

注册: 2005-12-23 19:20
帖子: 1677
送出感谢: 0 次
接收感谢: 0 次
gun 写道:
耳机和那孔没咬合,旧耳机经常出现这问题,换个耳机试试


————————————————

笔记本的电脑的插孔都不是靠 耳机机械咬合了 不信你可以在插入耳机的时候 看到孔里有红光
实际上是靠 感应的


这个问题是alsa驱动的问题


_________________
Kubuntu10.10& Windows 7 ultimate
Acer 4738ZG
Intel PM dual core P6100 2.00G
4G DDR1333
ATI Mobility Radeon HD5470
750G HDD
14.0 WXGA 1366×768


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-08-12 9:13 
头像

注册: 2008-08-03 10:06
帖子: 88
送出感谢: 0 次
接收感谢: 0 次
这个问题其实在某种程度上也是一种创新。你可以在声音管理器中把FRONT调到最小,这样就只有耳机发声了。其实有的时候还是有需要让两个都同时发声的。 :D


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-08-14 18:58 
头像

注册: 2008-05-11 11:10
帖子: 1078
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
我的笔记本(Acer)也有这样的问题,郁闷啊。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-08-15 12:21 

注册: 2007-12-05 10:13
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
驱动的问题,安装alsa的最新驱动可以解决,具体可以参考 http://www.5dlinux.com/article/1/2008/linux_13485.html


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 笔记本插上耳机后声音还能外放
帖子发表于 : 2008-12-24 16:45 

注册: 2008-10-18 23:36
帖子: 69
送出感谢: 0 次
接收感谢: 1
我的是联想的,也有这个问题,到底怎么解决啊# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; : ; }
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && { /sbin/modprobe --quiet snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer && { /sbin/modprobe --quiet snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq && { /sbin/modprobe --quiet snd-seq-midi ; /sbin/modprobe --quiet snd-seq-oss ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }

# Load snd-seq for devices that don't have hardware midi;
# Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
# non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
我这个文件怎么没有一个 把最后一行的的mode=写成 lenovo 如此就没有问题了

并且我在windows下就行


页首
 用户资料  
 
9 楼 
 文章标题 : Re:
帖子发表于 : 2009-04-17 11:43 

注册: 2006-05-03 9:10
帖子: 141
送出感谢: 0 次
接收感谢: 0 次
linuxwj 写道:
这个问题其实在某种程度上也是一种创新。你可以在声音管理器中把FRONT调到最小,这样就只有耳机发声了。其实有的时候还是有需要让两个都同时发声的。 :D

我把front调到最小耳机也就最小了,好像Front跟外放是一起控制的一样,


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 笔记本插上耳机后声音还能外放
帖子发表于 : 2009-04-18 1:20 

注册: 2008-11-25 12:14
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我的也是啊,哎!而且装上ubuntu后声音小很多了!


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 笔记本插上耳机后声音还能外放
帖子发表于 : 2010-10-17 13:34 

注册: 2008-10-09 21:17
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
我的是东芝的,也有这样的问题,求高人解决。


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 笔记本插上耳机后声音还能外放
帖子发表于 : 2010-10-17 14:51 

注册: 2010-10-17 13:15
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
我的插上耳机后,耳机没声音,只有外放


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 笔记本插上耳机后声音还能外放
帖子发表于 : 2010-10-25 0:52 

注册: 2010-10-25 0:49
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
在声音首选项里的"输出"下面的"连接器"里选择"Analog Headphones".

试试.我的是Acer的.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译