[求助]怎么解决MPLAYER播放MKV时的图像色彩失真

Totem,mplayer,sopcast,realplayer,bmp
回复
头像
RGVR250
帖子: 49
注册时间: 2005-10-27 19:41
送出感谢: 0
接收感谢: 0

[求助]怎么解决MPLAYER播放MKV时的图像色彩失真

#1

帖子 RGVR250 » 2006-05-10 14:25

在用MPLAYER播放MKV格式的电影时,图像严重失真,声音正常,字幕也没问题!用TOTEM就只听到声儿没影儿!<指南里的插件什么的都装了>!不知道有没有哪位也遇上这样的问题!这可怎么解决啊!请给指点指点!!!THX~
附件
screenshot-1.png
screenshot-2.png
screenshot-3.png
screenshot-4.png
头像
RGVR250
帖子: 49
注册时间: 2005-10-27 19:41
送出感谢: 0
接收感谢: 0

#2

帖子 RGVR250 » 2006-05-11 0:12

怎么没人给解答啊:( 还是就我给碰到这问题啊?!拜托啦!
xiechy
帖子: 1074
注册时间: 2006-01-18 15:01
送出感谢: 0
接收感谢: 1 次

#3

帖子 xiechy » 2006-05-11 21:13

MKV只是一种容器,并不是真正的编码格式。把你的MKV的video codec list 出来。不然很难帮你。
头像
RGVR250
帖子: 49
注册时间: 2005-10-27 19:41
送出感谢: 0
接收感谢: 0

#4

帖子 RGVR250 » 2006-05-12 22:25

该文件注释code里的VIDEO CODEC.....X264 485 1418kbps!DIVX编码的!谢谢~
上次由 RGVR250 在 2006-05-13 0:57,总共编辑 1 次。
头像
RGVR250
帖子: 49
注册时间: 2005-10-27 19:41
送出感谢: 0
接收感谢: 0

#5

帖子 RGVR250 » 2006-05-13 0:50

代码: 全选

86 audio & 200 video codecs
Cannot load font: /usr/share/fonts/truetype/hiweed/simsun.ttf
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such file or directory
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.
Playing cd2.mkv.
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_AC3), -aid 0, -alang und
[mkv] Will play video track 1
[mkv] Will play audio track 2
Matroska file format detected.
VIDEO:  [avc1]  704x288  24bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
SUB: Detected subtitle file format: subviewer
SUB: Read 642 subtitles.
SUB: Adjusted 11 subtitle(s).
SUB: added subtitle file (1): ./CD2.srt
==========================================================================
Trying to force audio codec driver family libmad...
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
AC3: 5.1 (3f+2r+lfe)  48000 Hz  448.0 kbit/s
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 448.0 kbit/29.17% (ratio: 56000->192000)
Selected audio codec: [a52] afm:liba52 (AC3-liba52)
==========================================================================
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm:ffmpeg (FFmpeg H.264)
==========================================================================
Building audio filter chain for 48000Hz/2ch/s16le -> 0Hz/0ch/??...
alsa-init: 1 soundcard found, using: default
alsa: 48000 Hz/2 channels/4 bpf/17832 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 48000Hz 2ch s16le (2 bps)
Building audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/s16le...
Starting playback...
[h264 @ 0x86703d0]custom scaling matrix not implemented
VDec: vo config request - 704 x 288 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 2.44:1 - prescaling to correct movie aspect.
VO: [xv] 704x288 => 704x288 Planar YV12
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
回复

回到 “影音多媒体”