当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : mplay 的一个图像问题。
帖子发表于 : 2008-09-07 20:07 

注册: 2008-09-07 19:17
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
。。。我是linux新手。。

自己下源码。装了个mplay 装好了。播放在shell里。用mplay /home/test.avi 电影 ,在shell里显示时间和百分比。就是没有图像。

用。open with other applicatin ....打开mplay....只有要后台运行.也只有声音.没有窗口出来.

请问一下.这是我在./configure或make时出错了吗.?还是什么别的原因.谢谢.


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-09-07 21:56 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
终端看提示。别是解码器没找到。或者编译的很多库都没 包括。


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-09-07 22:05 

注册: 2007-05-06 10:12
帖子: 1994
送出感谢: 0 次
接收感谢: 0 次
what is mplay ? mplayer?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-09-08 22:15 

注册: 2008-09-07 19:17
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
终端看提示。别是解码器没找到。或者编译的很多库都没 包括。


终端显示
AVI file format detected
[aviheader] Video stream found, -vid 0
[aviheader] Audio stream found, -vid 1
VIDEO: [H264] 960*540 24BPP 23.976 fps 1415.7kbps(172.8kbyte/s)
Clop info:


附件:
Screenshot.png
Screenshot.png [ 101.13 KiB | 被浏览 627 次 ]

页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-09-08 22:17 

注册: 2008-09-07 19:17
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
xeoc 写道:
what is mplay ? mplayer?


呵呵。。。一时心急。写错了,是mplayer。。我还是第一次在这上面发贴。
请见凉


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-09-08 23:55 
头像

注册: 2008-07-14 22:42
帖子: 8078
地址: Beijing
送出感谢: 0 次
接收感谢: 0 次
编译是否成功的标志是
使用gmplayer能不能调出mplayer
代码:
gmplayer


_________________
Ubuntu User


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-09-10 13:37 

注册: 2008-09-07 19:17
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
想入非非 写道:
编译是否成功的标志是
使用gmplayer能不能调出mplayer
代码:
gmplayer


提示。
the program 'gmplayer' is currently not installed . you can install it by typing : sudo apt-get install mplayer
bash:gmplayer:command not found


我用。sudo apt-get install mplayer
之后就可以了。谢谢。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-09-10 13:39 
头像

注册: 2007-09-29 3:09
帖子: 5773
送出感谢: 0 次
接收感谢: 3
想入非非 写道:
编译是否成功的标志是
使用gmplayer能不能调出mplayer
代码:
gmplayer


编译是没加--enable-gui的,编译后都会commoand not found是不是就证明我的编译失败了 :lol:


_________________
HUNT Unfortunately No Talent...


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-09-10 14:35 

注册: 2008-09-07 19:17
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
不过。我播放.AVI。有的文件。出现Fatal error?
Error opening/initialixing the selected video_out(-vo) device.

只有OK点。。。点了。还是没有图。。只有声音。

不知道.是什么原因.


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-09-10 17:17 
头像

注册: 2008-07-14 22:42
帖子: 8078
地址: Beijing
送出感谢: 0 次
接收感谢: 0 次
HuntXu 写道:
想入非非 写道:
编译是否成功的标志是
使用gmplayer能不能调出mplayer
代码:
gmplayer


编译是没加--enable-gui的,编译后都会commoand not found是不是就证明我的编译失败了 :lol:

那是我失败了 :lol:


_________________
Ubuntu User


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-09-10 19:54 

注册: 2007-05-13 15:20
帖子: 333
送出感谢: 0 次
接收感谢: 0 次
都说了用的vo为null了,怎么可能会有图像呢??

播放时加入-vo xv


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译