当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 在firefox中使用apt安装软件提示没有协议关联!
帖子发表于 : 2008-10-16 18:43 

注册: 2008-10-01 13:06
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
在firefox中是可以使用类似apt:vim来安装软件的,但是在我的机器上却提示"Firefox 不知道如何打开此地址,因为协议 (apt) 未和任何程序关联。",请教高手应该如何解决?谢谢!我用的是基于ubuntu 8.04的linuxmint。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 在firefox中使用apt安装软件提示没有协议关联!
帖子发表于 : 2011-10-04 16:55 
头像

注册: 2009-11-30 19:38
帖子: 95
送出感谢: 4
接收感谢: 3
引用自:https://help.ubuntu.com/community/AptURL

引用:
AptURL

Contents

Introduction
Installation
Firefox and Epiphany
Firefox 3
Konqueror
Opera
Swiftfox
Use of apturl
Create an apturl link
See also

Introduction

The APT protocol, or apturl, is a very simple way to install a software package from a web browser.

On computers where apturl is enabled, clicking on a special type of link on a web page starts the installation of one or several packages available in the package repositories of this computer.

For example, from a web page, when a Ubuntu user clicks on the link apt:packageexample , the apturl protocol will launch the package manager to propose the installation of the package called "packageexample" from the repositories available on the computer.

Please note that apturl is not aimed at replacing the current system of repositories and package manager. It is a complementary method.

Installation

To use this package installation method:

you need to be on Ubuntu 7.10 or later

you need the package apturl to be installed (it is generally installed by default)
you need a compatible web browser (see list below).

Firefox and Epiphany

apturl works by default with Firefox and Epiphany if they are normally installed from the repositories
if you use a version of Firefox2 or Epiphany that you didn't install from the repositories, you need to enable the apturl in your browser with the same procedure as Swiftfox (see below).
if you use a version of Firefox3, see below to enable the apturl in your browser.

Firefox 3

Enter about:config in the URL bar and add :

network.protocol-handler.app.apt in character chain with /usr/bin/apturl as value,

network.protocol-handler.app.apt+http in character chain with /usr/bin/apturl as value,

network.protocol-handler.warn-external.apt in boolean value and put true as value,

network.protocol-handler.warn-external.apt+http in boolean value and put true as value.

Close and restart Firefox.

Click on this link apt://mplayer , and in the "Application launch" windows, click on the "Choose" button and :

Click on File system, and the /usr/bin directory then on the apturl file.

Don't forget to enable "Remember my choice" and validate.

Konqueror

Execute the Kate text editor in administrator mode: <code>kdesudo kate</code>
Create a new text file containing these data :

[Protocol]
exec=apturl "%u"
protocol=apt
input=none
output=none
helper=true
reading=true
writing=true

Save this file under the name apt.protocol in the /usr/share/services folder.

Create a second text file containing these data :

[Protocol]
exec=apturl "%u"
protocol=apt+http
input=none
output=none
helper=true
reading=true
writing=true

Save this file under the name apt+http.protocol in the /usr/share/services folder.

Opera

If you use Opera, you just need to go in the menu Tools then Preferences. Click on the tab Advanced then Programs, and choose Add. In Protocol, enter apt and in Open with another application, enter apturl. Click on the button OK and restart Opera.

Swiftfox

To enjoy the APT protocol with Swiftfox, enter about:config in the URL bar and add :

network.protocol-handler.app.apt in character chain with /usr/bin/apturl as value,

network.protocol-handler.app.apt+http in character chain with /usr/bin/apturl as value,

network.protocol-handler.warn-external.apt in Boolean value and put false as value,

network.protocol-handler.warn-external.apt+http in Boolean value and put false as value.

Close and restart Swiftfox.

Use of apturl

In the Ubuntu Documentation, you will sometimes find sentences like for example:

" To install this software in Ubuntu, install the following package: supertux. "

Click on the name of the package ("supertux" in the example): if the apturl protocol is enabled on your computer, you will be proposed to install the package called "supertux".

Multiple packages can be linked to in documentation, they need only be separated by a comma. The following code is an example, first the source then the result.

[[InstallingSoftware#installing-a-package|install the following packages]]: '''''[[apt:rsync,xinetd|rsync xinetd]]'''''.

This would produce - install the following packages: rsync xinetd.

Create an apturl link

See https://wiki.ubuntu.com/AptUrl



页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译