当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 让audacious支持ape格式以及CUE不能打开或乱码问题
帖子发表于 : 2008-11-19 20:20 

注册: 2006-07-27 11:34
帖子: 13
送出感谢: 1
接收感谢: 0 次
论坛里面的方法国内连接过去有些困难,在网上搜索了一哈,有此方法,我已经搞定。。。。。
原文http://blog.chinaunix.net/u1/33254/showart_265434.html
让audacious支持ape格式
看了挺多文章,说是需要安装audacious-mac插件,可是怎么也弄不清楚这个插件是怎么回事。好在终于搞定了,现在可以听到刚刚才下载完的大自然轻音乐,真是开心呀。简单记录一下安装过程,需要的朋友可以参考一下。

1、安装audacious

虽然是说让audacious支持ape播放,但我还是想从audacious的安装说起,因为从这里会扯出支持ape的线索出来。

不管是用发行版自带的audacious包,还是自己下载的audacious二进制安装包,或者是自己从其他地方下载的源码编译的,我都强烈建议去audacious的官方主页去看看,因为那里会有大多数人要用audacious的人需要了解的信息。

audacious的主页:http://audacious-media-player.org/。

安装方法不说了,上边提到的三种方式都比较简单了。

2、安装ape解码包

喜欢自己摸索的朋友一定发现了audacious主页上的mac插件,既然看到了,我们就连接过去看看。这个插件站点的地址是:
http://www.netswarm.net/
网站比较简单,很容易就发现在misc类下边有audacious-mac插件了,那是不是赶快下载编译使用呢?先不要着急,看看关于插件的说明。
Basic port of the bmp-mac plugin for Audacious.
对了,仅仅是一个port,那么还需要下载ape解码包。这个解码包在什么地方呢?在这里:
http://supermmx.org/linux/mac/
这个网站也挺简单,在网页的最下边就是下载链接了。快下载吧,是第一个哦!下边两个是解码器作者写给bmp和xmms的插件,audacious用户用不到。可惜这个作者没有给audacious写个插件,要不是我们就没有这么麻烦了。

安装吧,源代码编译。

3、安装ape插件

准确来讲,是安装ape for auducious的插件。就在刚才看到的netswarm站点上下载,也在页面比较靠下的位置,不过要注意版本哟。

安装吧,还是源代码编译。

OK,打开你的audacious,看看decoder插件里边是不是多了一个ape插件。

oh ye,播放你的ape吧。


重要提醒:请注意每一个环节的安装目录!尤其是使用发行版自带的audacious,更应该注意安装目录。一个朋友的文章说,他在配置ape插件的时候,必须要增加--enable-local选项才能找到插件,我怀疑就是安装目录问题。

解决audacious导入cue分轨文件问题

这个问题比较郁闷,因为我的情况和论坛上大家的情况都不一样。照论坛上大家讨论的方法,也无法解决我的问题。具体就是,audacious无法导入cue 分轨文件,尽管装了audacious-plugins-extra;去掉“音频”->“格式检测” 的两个勾勾,将无法播放除ape之外的其他音频文件。

自己动手搞定这个问题:编辑cue文件,确保 FILE "CDImage.ape" WAVE 这行代码的ape与你的ape文件名一样,不要有空格和中文出现,都改名为CDImage.ape最好,如果导入cue分轨出现乱码,则编辑cue文件的时候以UTF-8编码保存。去掉“音频”->“格式检测” 的两个勾勾,导入cue文件,然后再 勾上“音频”->“格式检测” 的两个勾勾。


现在已经导入cue文件了,也可以播放其他的音频文件。注:以后每次导入cue,都要先去掉“音频”->“格式检测” 的两个勾勾,导入cue文件,然后再 勾上“音频”->“格式检测” 的两个勾勾。“不要有空格和中文出现”这个问题,有时间在好好确定一下问题的所在 :)




附件:
audacious-mac-0.3.10.tar.gz [315.78 KiB]
被下载 179 次
附件:
mac-3.99-u4-b5.tar.gz [411.36 KiB]
被下载 150 次


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 让audacious支持ape格式以及CUE不能打开或乱码问题
帖子发表于 : 2008-11-21 13:43 

注册: 2008-11-14 11:45
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
按照帖子装了,找不到ape插件阿,还是播不了 :em20


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 让audacious支持ape格式以及CUE不能打开或乱码问题
帖子发表于 : 2008-11-23 18:23 

注册: 2006-07-27 11:34
帖子: 13
送出感谢: 1
接收感谢: 0 次
编译如果通过了的话,应该在首选项音频里面找到一个MONKEY的插件,那个就是APE的,要把前面的钩选中。
BTW:不知道能不能帮到你,我也是新手,贴这个的目的是给自己的,怕以后重新安装系统忘记的时候好上这里抛抛来。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 让audacious支持ape格式以及CUE不能打开或乱码问题
帖子发表于 : 2008-11-23 20:57 

注册: 2008-11-14 11:45
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
你好,我是安装audacious-mac-0.3.10.tar.gz这个插件时,编译出了问题,编译的时候说找不到audacious1.41 or laster ,我都已经是最新的1.51了,晕死,还说我没装,冲装也找不到,前面那个插件mac-3.99-u4-b5.tar.gz却能编译,就这个不行,ape放不了了 :em20


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 让audacious支持ape格式以及CUE不能打开或乱码问题
帖子发表于 : 2008-11-23 21:27 
头像

注册: 2007-10-23 12:54
帖子: 1689
送出感谢: 0 次
接收感谢: 13
audacious 直接就可以播 ape 的吧?


附件:
audacious-ape.png
audacious-ape.png [ 15.53 KiB | 被浏览 3868 次 ]
页首
 用户资料  
 
6 楼 
 文章标题 : Re: 让audacious支持ape格式以及CUE不能打开或乱码问题
帖子发表于 : 2008-11-23 21:47 

注册: 2006-07-27 11:34
帖子: 13
送出感谢: 1
接收感谢: 0 次
icka128 写道:
你好,我是安装audacious-mac-0.3.10.tar.gz这个插件时,编译出了问题,编译的时候说找不到audacious1.41 or laster ,我都已经是最新的1.51了,晕死,还说我没装,冲装也找不到,前面那个插件mac-3.99-u4-b5.tar.gz却能编译,就这个不行,ape放不了了 :em20


我也有些忘记当初安装的时候有没有出过这个问题了,不过我记得我第一次编译也没有通过,什么提示忘记了,后来看了看INSTALL
里面有这样一句话

引用:
Note: when configuring, there is a option for local install -- --enable-local=yes.


你试试把这个参数加上。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 让audacious支持ape格式以及CUE不能打开或乱码问题
帖子发表于 : 2008-11-23 22:21 

注册: 2008-11-14 11:45
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
AutoXBC 写道:
audacious 直接就可以播 ape 的吧?

默认是可以播放ape没错,但是是杂声,mp3没问题! :em20


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 让audacious支持ape格式以及CUE不能打开或乱码问题
帖子发表于 : 2008-11-23 22:57 
头像

注册: 2007-10-23 12:54
帖子: 1689
送出感谢: 0 次
接收感谢: 13
不是杂声,完全是正常的播放。我不知道你的缺少什么,但是配置好可以播放 ape 是没有疑问的。

上一张音轨信息吧,不然你还是不理解。


附件:
audacious-ape1.png
audacious-ape1.png [ 59.46 KiB | 被浏览 3255 次 ]

页首
 用户资料  
 
9 楼 
 文章标题 : Re: 让audacious支持ape格式以及CUE不能打开或乱码问题
帖子发表于 : 2008-11-23 22:57 
头像

注册: 2007-06-30 0:27
帖子: 509
送出感谢: 0 次
接收感谢: 1
我的解决方案:
1.安装新版的audacious直接就可以播放APE
2.转换成FLAC格式,效果是一样的,但支持的播放器多,选择也就多了。方法
http://blog.sina.com.cn/s/blog_5252fdda0100b3y8.html


_________________
反对台独,反对藏独,反对孤独!
apt-get不是万能的:

代码:
sudo apt-get install girlfriend
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。
下列的信息可能会对解决问题有所帮助:
下列的软件包有不能满足的依赖关系:
girlfiend: 依赖: hourse但是它将不会被安装
girlfiend: 依赖: car但是它将不会被安装
house,car: 依赖: money但是它将不会被安装
E: 无法安装的软件包


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 让audacious支持ape格式以及CUE不能打开或乱码问题
帖子发表于 : 2008-11-23 23:24 
头像

注册: 2006-11-18 18:52
帖子: 450
送出感谢: 0 次
接收感谢: 0 次
.cue是万恶之源啊
老实说,改cue文件的编码不比用cue分割整轨的文件快多少
用cue在显示歌词的时候还会碰到这样那样的障碍
不如统统割成单轨,一劳永逸。


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 让audacious支持ape格式以及CUE不能打开或乱码问题
帖子发表于 : 2008-11-23 23:39 

注册: 2008-11-14 11:45
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
等一下上图,确实是杂声,没法听! :em20
图片
图片
图片
图片


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 让audacious支持ape格式以及CUE不能打开或乱码问题
帖子发表于 : 2008-11-24 9:00 

注册: 2008-11-14 11:45
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
编译到最后总是出现这句configure: error: *** Audacious 1.4 or later not found - please install first ***,明明我都装了1。51版了 :em20


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 让audacious支持ape格式以及CUE不能打开或乱码问题
帖子发表于 : 2008-11-24 11:03 

注册: 2006-07-27 11:34
帖子: 13
送出感谢: 1
接收感谢: 0 次
icka128 写道:
编译到最后总是出现这句configure: error: *** Audacious 1.4 or later not found - please install first ***,明明我都装了1。51版了 :em20

你是不是有一个DEV的库没有装上,仔细看看提示,要不然把所有的。/CONFIGURE时的信息贴上来,这里高手这么多,一定可以解决的,其实我一开始用LINUX也是没头苍蝇瞎撞,多撞几次就知道往哪撞了。哈哈。


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 让audacious支持ape格式以及CUE不能打开或乱码问题
帖子发表于 : 2008-11-24 11:07 

注册: 2006-07-27 11:34
帖子: 13
送出感谢: 1
接收感谢: 0 次
nsnl 写道:
.cue是万恶之源啊
老实说,改cue文件的编码不比用cue分割整轨的文件快多少
用cue在显示歌词的时候还会碰到这样那样的障碍
不如统统割成单轨,一劳永逸。


我觉得还算可以呀,如果只是另存的话只是需要几秒钟就可以了。如果歌名是乱码的话也不是太麻烦。


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 让audacious支持ape格式以及CUE不能打开或乱码问题
帖子发表于 : 2009-05-01 20:50 

注册: 2007-03-20 12:50
帖子: 555
送出感谢: 0 次
接收感谢: 0 次
configure: error: *** Audacious 1.4 or later not found - please install first ***
我也是这样子哦,怎么解决啊?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译