mplayer播放rmvb出错了``

Totem,mplayer,sopcast,realplayer,bmp
hupisha
帖子: 310
注册时间: 2007-03-07 14:56
来自: 山东菏泽成武
送出感谢: 0
接收感谢: 0
联系:

mplayer播放rmvb出错了``

#1

帖子 hupisha » 2008-12-15 16:11

提示如图,是咋回事?
附件
Screenshot-Error!.png
Screenshot-Error!.png (3.78 KiB) 查看 1783 次
头像
allarem
帖子: 1025
注册时间: 2008-05-31 17:27
来自: SUES
送出感谢: 0
接收感谢: 0
联系:

Re: mplayer播放rmvb出错了``

#2

帖子 allarem » 2008-12-15 16:27

你的显卡-vo选项参数不支持,建议换一个-vo 的参数
头像
想入非非
论坛版主
帖子: 8078
注册时间: 2008-07-14 22:42
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

Re: mplayer播放rmvb出错了``

#3

帖子 想入非非 » 2008-12-15 17:06

安装smplayer之后试一试。。。 :em06
Ubuntu User
hupisha
帖子: 310
注册时间: 2007-03-07 14:56
来自: 山东菏泽成武
送出感谢: 0
接收感谢: 0
联系:

Re: mplayer播放rmvb出错了``

#4

帖子 hupisha » 2008-12-15 18:04

allarem 写了:你的显卡-vo选项参数不支持,建议换一个-vo 的参数
有这么麻烦么?
晚上看看。现在做饭!
hupisha
帖子: 310
注册时间: 2007-03-07 14:56
来自: 山东菏泽成武
送出感谢: 0
接收感谢: 0
联系:

Re: mplayer播放rmvb出错了``

#5

帖子 hupisha » 2008-12-15 18:06

想入非非 写了:安装smplayer之后试一试。。。 :em06
已经试过了
有动静,没图像 :em04
附件
Screenshot-1.png
头像
想入非非
论坛版主
帖子: 8078
注册时间: 2008-07-14 22:42
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

Re: mplayer播放rmvb出错了``

#6

帖子 想入非非 » 2008-12-15 20:01

hupisha 写了:
想入非非 写了:安装smplayer之后试一试。。。 :em06
已经试过了
有动静,没图像 :em04
把视频参数改成x11看看 :em06
Ubuntu User
头像
mymathersname
帖子: 2870
注册时间: 2008-09-18 23:40
系统: Ubuntu 15.04 x64
来自: Mars
送出感谢: 1 次
接收感谢: 1 次

Re: mplayer播放rmvb出错了``

#7

帖子 mymathersname » 2008-12-15 20:18

大哥,去下载realplayer for ubuntu吧
转移各位校内,百毒朋友,把目标转向twitter和facebook,别总看局域网的内容
其实从那么多的ubuntu发行版和fedora的各个发行版中,我们不难看出,linux的进步是惊人的,从长久的发展规律和更加深远的意义来看,linux桌面版与微软的距离在缩小,这是值得庆幸的……
ubuntu是半年还去偷情一次的初恋。fedora是一生挚爱的正室。debian是和正室同等地位的妾侍。rh/cent是用来偷窥的正室大姐姐。suse是一夜夫妻百二蚊。gentoo是有内涵的才女。arch是久闻其名不敢接触的怪叔叔。其余发行版,我是帝皇它们是屁民,无福宠幸。
hupisha
帖子: 310
注册时间: 2007-03-07 14:56
来自: 山东菏泽成武
送出感谢: 0
接收感谢: 0
联系:

Re: mplayer播放rmvb出错了``

#8

帖子 hupisha » 2008-12-16 11:50

想入非非 写了:
hupisha 写了:
想入非非 写了:安装smplayer之后试一试。。。 :em06
已经试过了
有动静,没图像 :em04
把视频参数改成x11看看 :em06
修改哪里?

代码: 全选

#
# MPlayer configuration file
#
# Configuration files are read system-wide from /usr/local/etc/mplayer.conf
# and per user from ~/.mplayer/config, where per-user settings override
# system-wide settings, all of which are overrriden by the command line.
#
# The configuration file settings are the same as the command line
# options without the preceding '-'.
#
# See the CONFIGURATION FILES section in the man page
# for a detailed description of the syntax.


##################
# video settings #
##################

# Specify default video driver (see -vo help for a list).
vo=xv

# Use SDL video with the aalib subdriver by default.
#vo = sdl:aalib

# FBdev driver:
#
# mode to use (read from fb.modes)
#fbmode = 640x480-120
#
# location of the fb.modes file
#fbmodeconfig = /etc/fb.modes

# Specify your monitor timings for the vesa and fbdev video output drivers.
# See /etc/X11/XF86Config for timings. Be careful; if you specify settings
# that exceed the capabilities of your monitor, you may damage it.
#
# horizontal frequency range (k stands for 1000)
#monitor-hfreq = 31.5k-50k,70k
#
# vertical frequency range
#monitor-vfreq = 50-90
#
# dotclock (or pixelclock) range (m stands for 1000000)
#monitor-dotclock = 30M-300M

# Start in fullscreen mode by default.
#fs=yes

# Change to a different videomode when going fullscreen.
#vm=yes

# Override the autodetected color depth, may need 'vm=yes' as well.
#bpp=0

# Enable software scaling (powerful CPU needed) for video output
# drivers that do not support hardware scaling.
#zoom=yes

# standard monitor size, with square pixels
#monitoraspect=4:3

# Use this for a widescreen monitor, non-square pixels.
#monitoraspect=16:9

# Keep the player window on top of all other windows.
#ontop=yes


##################
# audio settings #
##################

# Specify default audio driver (see -ao help for a list).
ao=pulse,alsa,

# Use SDL audio driver with the esd subdriver by default.
#ao = sdl:esd

# Specify the mixer device.
#mixer = /dev/mixer

# Resample the sound to 44100Hz with the lavcresample audio filter.
#af=lavcresample=44100

# Specify default audio codec (see -ac help for a list).
ac=mad,


##################
# other settings #
##################

# Drop frames to preserve audio/video sync.
#framedrop = yes

# Specify your preferred skin here (skins are searched for in
# /usr/local/share/mplayer/skins/<name> and ~/.mplayer/skins/<name>).
#skin = Abyss

# Resample the font alphamap.
# 0     plain white fonts
# 0.75  very narrow black outline (default)
# 1     narrow black outline
# 10    bold black outline
#ffactor = 0.75

# cache settings
#
# Use 8MB input cache by default.
#cache = 8192
#
# Prefill 20% of the cache before starting playback.
#cache-min = 20.0
#
# Prefill 50% of the cache before restarting playback after the cache emptied.
#cache-seek-min = 50

# DVD: Display English subtitles if available.
#slang = en

# DVD: Play English audio tracks if available.
#alang = en


# You can also include other configuration files.
#include = /path/to/the/file/you/want/to/include

#Screensaver support (for non gmplayer)
stop-xscreensaver = "yes"

#Disable joystick support
#It seems to cause very odd problems on laptops
#With accelerometers (See LP: #75925)
nojoystick = yes
hupisha
帖子: 310
注册时间: 2007-03-07 14:56
来自: 山东菏泽成武
送出感谢: 0
接收感谢: 0
联系:

Re: mplayer播放rmvb出错了``

#9

帖子 hupisha » 2008-12-16 11:53

:em20

修改这里也不行

代码: 全选

# Specify default video driver (see -vo help for a list).
vo=x11
头像
HuntXu
论坛版主
帖子: 5778
注册时间: 2007-09-29 3:09
送出感谢: 0
接收感谢: 6 次

Re: mplayer播放rmvb出错了``

#10

帖子 HuntXu » 2008-12-16 13:02

www.sf.net
找一个mplayer for MacOs的项目,里面有real的解码器reallib,解压后放到mplayer的codecs目录...
HUNT Unfortunately No Talent...
头像
livelove
帖子: 46
注册时间: 2008-12-07 20:47
送出感谢: 0
接收感谢: 0

Re: mplayer播放rmvb出错了``

#11

帖子 livelove » 2008-12-16 20:12

应该是库文件位置不对。你可以通过命令行执行mplayer xxx.avi来看到错误信息。
不知道为什么,ubuntu 8.10自带的mplayer需要同时在/usr/lib/codecs和/usr/local/lib/codecs目录下找解码文件。这个可以通过重新编译搞定。

也可以用简单的方法:
把解码文件拷贝到/usr/lib/codecs,然后做一个连接到/usr/local/lib/codecs
sudo ln -s /usr/lib/codecs /usr/local/lib/codecs

如果错误信息提示需要libstdc++5, 那么就装上。
头像
brianlan
帖子: 23
注册时间: 2007-06-30 17:37
来自: Nanjing University of Science & Technology
送出感谢: 0
接收感谢: 0
联系:

Re: mplayer播放rmvb出错了``

#12

帖子 brianlan » 2009-02-22 14:35

在浏览器中敲入:http://ftp.ubuntu.org.cn/home/bora/package/
用户名:ubuntu
密码:ubuntuftp

下载w32codecs_20071007-0.0_i386.deb
安装之后再试试看,应该就可以了。我的就是这么搞定的。
头像
想入非非
论坛版主
帖子: 8078
注册时间: 2008-07-14 22:42
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

Re: mplayer播放rmvb出错了``

#13

帖子 想入非非 » 2009-02-25 17:05

这好像是很普遍的一个问题。。。不是显卡驱动的问题,就是mplayer安装的问题,试一试svn编译一次mplayer :em20
Ubuntu User
mimihu88
帖子: 551
注册时间: 2006-04-03 11:26
送出感谢: 0
接收感谢: 1 次

Re: mplayer播放rmvb出错了``

#14

帖子 mimihu88 » 2009-02-25 21:05

我曾经遇到过同样的问题,安装最新的svn版(mplayer官网下回来的或者lauch ppa 那个源的)就出现这种情况,换回源里面的mplayer就没事,与codecs无关
头像
zwld1
帖子: 35
注册时间: 2009-10-30 13:22
送出感谢: 0
接收感谢: 1 次

Re: mplayer播放rmvb出错了``

#15

帖子 zwld1 » 2009-12-07 19:56

我是升级后不能用了。怎么回事呀
放下包袱,开动机器。
回复

回到 “影音多媒体”