当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]mplayer无法播放,貌似程序停止响应[终于解决了,:P]
帖子发表于 : 2005-08-03 21:10 

注册: 2005-07-30 14:02
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
totem播放器没法加载字幕,没有办法,我只得动脑筋到mplayer的头上了
mplayer安装的686版本(我升级了linux-686),在新利得中安装的,mplayer-686(包含其依赖的如mplayer586,xmms等一些编码程序等),mplayer-front,修改mplayer.conf文件,vo=xv
安装完成后,启动(这里好像程序启动表现的非常慢),打开一个avi文件,没有任何响应,正常关闭已经不可能,我是通过强制关闭来结束mplayer的
不解阿,为什么播放个普通avi也这么难啊(不要bs我,我是菜鸟)


最后由 js_hzlz 编辑于 2005-08-03 22:06,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-08-03 21:20 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
安装快速设置中的解码了吗?
还有,mplayer播放字幕,建议搜索论坛。


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-08-03 21:38 

注册: 2005-07-30 14:02
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
这段时间一直在搞ubuntu,反复安装多次了
第一次安装,按照新手指南的步骤http://www.ubuntu.org.cn/support/documentation/guide/mplayer
编码,步骤一个没有拉下
第二次安装,sudo apt-get install beep-media-player totem-xine w32codecs gstreamer0.8-plugins
totem已经能正常播放,就是没法加载字幕,于是又不得不安装本不想安装的mplayer,用新利得安装的,mpalyer-686和mplayer-front,修改了config文件vo=xv
两次情况一样,都是程序失去响应
实在是搞不明白了,特来求助


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-08-03 22:10 

注册: 2005-07-30 14:02
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
最终还是声音的问题
无意中用命令-nosound发现可以正常播放,确认是声音设置有问题
选项中默然alsa,更改为esd后正常播放,呵呵
会不会是我没有设置混音的缘故?
到底新手指南推荐的混音有什么作用啊?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-08-03 22:12 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
混音那里是安装alsa-base0,并使用alsa或esd实现多音频流。


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-08-03 22:24 

注册: 2005-07-30 14:02
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
一波方平,一波又起
字幕乱码,气死人了
这个又如何设置?

ps:不设置混音是否对使用中有影响?具体表现在哪里?


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-08-03 22:30 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
1.
中文字体(可用你的中文字体代替simsun)
sudo cp /usr/share/fonts/simsun.ttf ~/.mplayer/subfont.ttf
2.
编码
这个要相对你的字幕来设定
Preferences --> Subtitle & OSD ,选上 "Unicode subtitle" ,"Encodeing" 中选择你的字幕编码


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2005-08-03 22:31 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
PS。这样答得好累啊。你发挥一下能动性,论坛是可以搜索的。


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2005-08-03 23:55 

注册: 2005-07-30 14:02
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
yongyi 写道:
1.
中文字体(可用你的中文字体代替simsun)
sudo cp /usr/share/fonts/simsun.ttf ~/.mplayer/subfont.ttf
2.
编码
这个要相对你的字幕来设定
Preferences --> Subtitle & OSD ,选上 "Unicode subtitle" ,"Encodeing" 中选择你的字幕编码


不好意思,其实问题我已经无意中解决了,只是我粗心,看到下面这个提示就认为没有加载字幕,其实快进到后面发现已经加载字幕了
ps:论坛搜索我是有用的,不过回答各种各样,自己情况不同,不敢乱用,呵呵


附件:
Screenshot.png [428.1 KiB]
被下载 139 次
页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:zbhigh 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译