当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 为什么我的amarok 无法使用?
帖子发表于 : 2006-06-21 8:25 

注册: 2005-12-06 14:30
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
我的amarok死活不能选择xine引擎,选择后出现的出错信息是:xine无法初始化任何音频驱动程序。我已经把libxine-extracodecs,amarok-xine,相关的libxine,及w32codecs都装上了。甚至把amarok升级到了1.4都不行。请问这是什么原因呢?bmp在我的机子上能正常使用。在SUSE10.1上amarok可以运行得很好,这应该可以排除硬件上的问题吧。如果把引擎换为arts的话又无法播放MP3。折腾了好几天,还是没有头绪。我尝试把amarok删除后再安装也不行,我把kubuntu重装了还是不行(我的/home是在一个单独的分区的,重装系统的时候不涉及这个目录,难道是这个有影响吗?)。请大家帮我找找原因,谢谢!!!!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-06-21 8:42 

注册: 2005-12-06 14:30
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
刚才又把amarok1.4删除了再重装上1.3.9版,现在能用aRTs引擎播放mp3了,但是xine还是不能用,总算有一点进展,但是就不知道是什么原因造成的,还是郁闷。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-06-21 14:50 
头像

注册: 2005-08-15 0:04
帖子: 1880
地址: 南7技校
送出感谢: 0 次
接收感谢: 0 次
好象有个包叫做 libxine-extracodecs把,装了就好了。
代码:
zhan@ubuntu:~$ apt-cache search libxine-extra
libxine-extracodecs - the xine video/media player library, binary files


/home单独分区是没有问题的。


_________________
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-06-22 10:59 

注册: 2005-12-06 14:30
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
libxine-extracodecs 我已经装了,基本上论坛里提到的与MP3相关的包我都装了。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-06-22 13:04 
头像

注册: 2005-08-15 0:04
帖子: 1880
地址: 南7技校
送出感谢: 0 次
接收感谢: 0 次
xine 引擎不能用?没办法了装一个 xine 看看又没有改进。我不用 amarok 很久了。要是还不能解决的话到 irc 频道问问去,那里有很多人用 amarok的。


_________________
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-06-22 18:10 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
我的全新安装到现在一直没问题。


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-06-23 20:48 

注册: 2006-01-18 15:01
帖子: 1074
送出感谢: 0 次
接收感谢: 1
你是如何装的amarok?
使用如下源:
代码:
deb http://kubuntu.org/packages/amarok-14/ dapper main
deb http://kubuntu.org/packages/amarok-latest/ dapper main
deb-src http://kubuntu.org/packages/amarok-latest/ dapper main

最好在CLI下运行。可以check error


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-06-27 12:05 

注册: 2005-12-06 14:30
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
还是不行啊.
用了上面的源只是升级到1.4(这个我以前做过了),aRTs不能在1.4里运行,只能安装xine引擎,但是xine引擎还是不工作,出错提示与以前一样:xine无法初始化任何音频驱动程序。
真是搞不懂是什么原因。
我把xine(xine movie player)装上了,版本好象是0.99.4。可以正常播放MP3,虽然中文显示是乱码。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-06-29 23:17 
头像

注册: 2006-06-01 12:42
帖子: 270
送出感谢: 0 次
接收感谢: 0 次
我的amarok才真是怪呢,xine和arts引擎都可以用,可就是没有gstreamer引擎选项,为了放APE格式,专门装全了gstreamer的插件,这下郁闷了。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-06-29 23:57 

注册: 2006-01-18 15:01
帖子: 1074
送出感谢: 0 次
接收感谢: 1
在1.4的说明中有说的:由于gstreamer0.10的开发程度不足,正式版没有加入对它的支持。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-06-30 0:03 

注册: 2006-01-18 15:01
帖子: 1074
送出感谢: 0 次
接收感谢: 1
aRts好象和alsa有些不对付(好久以前了,后来没用过)
删除的时候用purge吧,把配置文件删了,reinstall 一下alsa-base,我说的出错提示是在CLI下的,通常信息量大些。
另外,

代码:
ldd /usr/bin/amarok
试试,看看有没有什么库不正常


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2006-06-30 1:11 

注册: 2005-12-31 12:17
帖子: 340
送出感谢: 0 次
接收感谢: 0 次
引擎选xine
换一下音频设置。


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2006-07-19 11:15 

注册: 2005-12-06 14:30
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
请问音频设置应该怎么换?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译