当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : gmplayer播放正常, mplayer却不能播放任何视频各音频. ??
帖子发表于 : 2009-01-19 9:57 
头像

注册: 2008-05-02 19:50
帖子: 734
送出感谢: 0 次
接收感谢: 0 次
mplayer没有图面, 也没有声音. :em20
代码:
┌─(Fire@ubuntu:pts/1)────────────────────────────────────────────────────(~)─┐
└─(09:44:%)── mplayer Movies/\[功夫熊猫\].Kung.Fu.Panda.双语字幕.HR-HDTV.AC3.960X540.x264-人人影视.avi
MPlayer 1.0rc2-4.2.4 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU     T7250  @ 2.00GHz (Family: 6, Model: 15, Stepping: 13)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
Warning unknown option subfont-autoscale at line 14
Warning unknown option subfont-text-scale at line 18
/usr/share/fonts/msyh075/msyh.ttf doesn't look like a bitmap font description, ignoring.
Cannot load bitmap font: /usr/share/fonts/msyh075/msyh.ttf

Playing Movies/[功夫熊猫].Kung.Fu.Panda.双语字幕.HR-HDTV.AC3.960X540.x264-人人影视.avi.
AVI file format detected.
[aviheader] Video stream found, -vid 0
[aviheader] Audio stream found, -aid 1
VIDEO:  [H264]  960x540  24bpp  23.976 fps  1792.3 kbps (218.8 kbyte/s)
Clip info:
 Software: VirtualDubMod 1.5.10.1 (Build 2366/Release)
Error opening/initializing the selected video_out (-vo) device.
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 320.0 kbit/20.83% (ratio: 40000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
[AO OSS] audio_setup: Can't open audio device /dev/dsp: Device or resource busy
Opening /dev/dvb/adapter0/audio0
DVB AUDIO DEVICE: No such file or directory
AO: [null] 48000Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   9.5 (09.5) of 36556.0 (10:09:15.9)  1.3%


_________________
In a world without walls who needs Windows?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: gmplayer播放正常, mplayer却不能播放任何视频各音频. ??
帖子发表于 : 2009-01-19 9:59 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
-vo?
.mplayer/config


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 : Re: gmplayer播放正常, mplayer却不能播放任何视频各音频. ??
帖子发表于 : 2009-01-19 10:06 
头像

注册: 2008-05-02 19:50
帖子: 734
送出感谢: 0 次
接收感谢: 0 次
代码:
 vo=xv
  5         #  Adjust matching fuzziness when searching for subtitles:
  6 sub-fuzziness=2
  7         #  Sets the subtitle font.
  8 font=/usr/share/fonts/msyh075/msyh.ttf
  9 #font=/usr/share/fonts/iYaHei/iYaHei.ttf
 10         #  Sets fonts type. (while TTF font was used)
 11 #subcp=utf8
 12 subcp=cp936
 13         #  Sets the autoscale <0-3>
 14 subfont-autoscale=0
 15         #  do not load subtitle automatically
 16 noautosub=yes
 17         #  Sets of subtitle fonts
 18 subfont-text-scale=30
 19         # Sets audio out moulde

附上config


_________________
In a world without walls who needs Windows?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译