当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求助:命令行看电影的问题
帖子发表于 : 2009-01-31 1:16 

注册: 2009-01-16 11:39
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
我在命令行下输入命令:
mplayer -vo fbdev NADE-234.avi
但是最后只有声音,却没有图像,请问应该如何解决这个问题?
输入上边命令后的代码:
代码:
MPlayer 1.0rc2-4.3.2 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU     P7350  @ 2.00GHz (Family: 6, Model: 23, Stepping: 6)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing NADE-234.avi.
AVI file format detected.
[aviheader] Video stream found, -vid 0
[aviheader] Audio stream found, -aid 1
VIDEO:  [XVID]  640x480  24bpp  29.970 fps  1662.7 kbps (203.0 kbyte/s)
Can't open /dev/fb0: No such file or directory
Error opening/initializing the selected video_out (-vo) device.
==========================================================================
Forced audio codec: mad
Opening audio decoder: [libmad] libmad mpeg audio decoder
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [mad] afm: libmad (libMAD MPEG layer 1-2-3)
==========================================================================
AO: [pulse] 48000Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   1.8 (01.7) of 7056.8 ( 1:57:36.7)  0.7%


我输入mplayer -vo help后的提示有:
代码:
MPlayer 1.0rc2-4.3.2 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU     P7350  @ 2.00GHz (Family: 6, Model: 23, Stepping: 6)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
Available video output drivers:
   xmga   Matrox G200/G4x0/G550 overlay in X11 window (using /dev/mga_vid)
   mga   Matrox G200/G4x0/G550 overlay (/dev/mga_vid)
   tdfxfb   3Dfx Banshee/Voodoo3/Voodoo5
   3dfx   3dfx (/dev/3dfx)
   xv   X11/Xv
   x11   X11 ( XImage/Shm )
   xover   General X11 driver for overlay capable video output drivers
   gl   X11 (OpenGL)
   gl2   X11 (OpenGL) - multiple textures version
   dga   DGA ( Direct Graphic Access V2.0 )
   sdl   SDL YUV/RGB/BGR renderer (SDL v1.1.7+ only!)
   ggi   General Graphics Interface (GGI) output
   [color=#FF0000]fbdev   Framebuffer Device
   fbdev2   Framebuffer Device[/color]
   svga   SVGAlib
   aa   AAlib
   caca   libcaca
   dxr3   DXR3/H+ video out
   v4l2   V4L2 MPEG Video Decoder Output
   xvidix   X11 (VIDIX)
   cvidix   console VIDIX
   null   Null video output
   xvmc   XVideo Motion Compensation
   mpegpes   Mpeg-PES to DVB card
   yuv4mpeg   yuv4mpeg output for mjpegtools
   png   PNG file
   jpeg   JPEG file
   gif89a   animated GIF output
   tga   Targa output
   pnm   PPM/PGM/PGMYUV file
   md5sum   md5sum of each frame


由此可见,我应该是支持framebuffer的,但不知道为什么却不能有图像,只有声音 :em20
希望大家帮我看看,谢谢!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求助:命令行看电影的问题
帖子发表于 : 2009-01-31 1:40 

注册: 2009-01-16 11:39
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
ubuntu8.04下配置framebuffer使能在命令行下看电影
这篇文章我看过了
按照他的方法设置没有效果

我的系统是ubuntu8.10
64位的
显卡GeFore 9300 GS(自己安装了最新驱动)


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 求助:命令行看电影的问题
帖子发表于 : 2009-02-01 18:15 
头像

注册: 2008-03-08 8:07
帖子: 418
送出感谢: 0 次
接收感谢: 0 次
没装DirectFB吧


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 求助:命令行看电影的问题
帖子发表于 : 2009-02-02 10:17 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
mplayer -vo fbdev2 -zoom -fs -x 1024 -y 768 test.rmvb
多年前的例子。


_________________
● 鸣学


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译