当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : mplayer有时候不能放mp3,有错误信息
帖子发表于 : 2009-04-06 21:09 

注册: 2008-04-08 13:24
帖子: 225
送出感谢: 0 次
接收感谢: 0 次
ubuntu 8.10系统,启动以后放mp3是正常的,过一段时间,不知道做了什么操作,放mp3的时候出错,以下是出错信息:
代码:
AO: [pulse] Failed to connect to server: Connection refused
[AO_ALSA] alsa-lib: pcm_hw.c:1321:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Device or resource busy
[AO_ALSA] alsa-lib: pcm_dmix.c:1008:(snd_pcm_dmix_open) unable to open slave
[AO_ALSA] Playback open error: Device or resource busy
[AO OSS] audio_setup: Can't open audio device /dev/dsp: Device or resource busy
[AO_ALSA] alsa-lib: pcm_hw.c:1321:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Device or resource busy
[AO_ALSA] alsa-lib: pcm_dmix.c:1008:(snd_pcm_dmix_open) unable to open slave
[AO_ALSA] Playback open error: Device or resource busy
mcop warning: user defined signal handler found for SIG_PIPE, overriding
[AO ARTS] can't connect to aRts soundserver
[AO ESD] esd_open_sound failed: Connection timed out
AO: [pulse] Failed to connect to server: Connection refused
[JACK] cannot open server
ao_nas: init(): Can't open nas audio server -> nosound
[AO SDL] Samplerate: 44100Hz Channels: Stereo Format s16le
[AO_ALSA] alsa-lib: pcm_hw.c:1321:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Device or resource busy
[AO_ALSA] alsa-lib: pcm_dmix.c:1008:(snd_pcm_dmix_open) unable to open slave
[AO SDL] Unable to open audio: No available audio device
[AO_ALSA] alsa-lib: pcm_hw.c:1321:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Device or resource busy
[AO_ALSA] alsa-lib: pcm_dmix.c:1008:(snd_pcm_dmix_open) unable to open slave
[AO_ALSA] alsa-lib: pcm_hw.c:1321:(snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Device or resource busy
[AO_ALSA] alsa-lib: pcm_dmix.c:1008:(snd_pcm_dmix_open) unable to open slave
AL lib: alsa.c:344: Could not open playback device 'default': Device or resource busy
AL lib: oss.c:179: Could not open /dev/dsp: Device or resource busy
[OpenAL] could not open device
Opening /dev/dvb/adapter0/audio0
DVB AUDIO DEVICE: No such file or directory


现在只能通过重启来解决问题,不知道有没有更好的解决方法?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: mplayer有时候不能放mp3,有错误信息
帖子发表于 : 2009-04-08 18:00 

注册: 2008-04-05 15:18
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
我的有时间也会有问题,只好重启。
应该还是 音频服务 有问题阿。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: mplayer有时候不能放mp3,有错误信息
帖子发表于 : 2009-09-05 21:07 

注册: 2005-11-15 18:22
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
倒霉,最近也发现有这个问题了,华硕M2N68板载声卡nVidia Corporation MCP67 High Definition Audio/VIA VT1708B


页首
 用户资料  
 
4 楼 
 文章标题 : Re: mplayer有时候不能放mp3,有错误信息
帖子发表于 : 2009-09-05 21:15 

注册: 2005-11-15 18:22
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
搜了几下,原因还是声卡被占用了,用lsof看看被谁占用,杀掉就好了:
lsof |grep dsp
lsof |grep snd


页首
 用户资料  
 
5 楼 
 文章标题 : Re: mplayer有时候不能放mp3,有错误信息
帖子发表于 : 2009-09-06 14:17 

注册: 2008-04-08 13:24
帖子: 225
送出感谢: 0 次
接收感谢: 0 次
druggo 写道:
搜了几下,原因还是声卡被占用了,用lsof看看被谁占用,杀掉就好了:
lsof |grep dsp
lsof |grep snd

非常感谢!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译