MPLAYER安装依赖问题

Totem,mplayer,sopcast,realplayer,bmp
回复
头像
hkgood
帖子: 15
注册时间: 2006-07-10 23:31
来自: 上海
送出感谢: 0
接收感谢: 0
联系:

MPLAYER安装依赖问题

#1

帖子 hkgood » 2006-07-10 23:51

小弟是LINUX新手,刚装好UBUNTU6.06没几天,在安装MPLAYER的时候碰到关于安装依赖性的错误,因为以前没有LINUX经验,算是非常初级的用户了,那位大哥能帮忙看看,有什么方法解决没有~

rocky@rocky-desktop:~/Desktop/MPlayer-1.0pre8$ sudo apt-get install mplayer-586
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
mplayer-586: 依赖: libjack0.80.0-0 (>= 0.99.0) 但是它将不会被安装
E: 无法安装的软件包
rocky@rocky-desktop:~/Desktop/MPlayer-1.0pre8$


在我打算装libjack的时候又碰到另外一个依赖性问题,人要崩溃掉了

rocky@rocky-desktop:~/Desktop/MPlayer-1.0pre8$ sudo apt-get install libjack0.80.0-0
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libjack0.80.0-0: 依赖: jackd (= 0.99.0-2ubuntu1) 但是它将不会被安装
E: 无法安装的软件包
rocky@rocky-desktop:~/Desktop/MPlayer-1.0pre8$
头像
jazzi
帖子: 532
注册时间: 2005-10-16 23:26
来自: 泉州
送出感谢: 0
接收感谢: 3 次
联系:

#2

帖子 jazzi » 2006-07-12 19:54

先按照快速设置指南(Dapper 6.06)版设置好源,然后

代码: 全选

sudo apt-get update


然后

代码: 全选

sudo apt-get install mplayer-686 mplayer-fonts

最后最好到 Mplayer官网下载编码解码器,并把下载回来的essential-20060611
解压并放到 /usr/local/bin/codecs
You make it fun
It will make you fun
头像
hkgood
帖子: 15
注册时间: 2006-07-10 23:31
来自: 上海
送出感谢: 0
接收感谢: 0
联系:

找到原因了

#3

帖子 hkgood » 2006-07-19 22:08

写出来希望大家可以有点教训,我在装MPLAYER之前装了GAIM的QQ插件,但,这个插件只能用老版本,所以我一直没有升级,到最后,导致关联MPLAYER的一些库也没办法升级~
回复

回到 “影音多媒体”