当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 升级到9.04以后mpd不能用了?
帖子发表于 : 2009-04-09 11:36 

注册: 2006-05-30 20:48
帖子: 524
送出感谢: 0 次
接收感谢: 0 次
unable to bind port 6600: Address already in use
maybe MPD is still running?
Aborted
ps -A里看不到有mpd的进程
但是启动的时候就会有上面的提示


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 升级到9.04以后mpd不能用了?
帖子发表于 : 2009-04-09 11:43 

注册: 2006-05-30 20:48
帖子: 524
送出感谢: 0 次
接收感谢: 0 次
参照解决,呵呵
http://www.91linux.com/html/linux_pub/u ... /1689.html
引用:
ebian 装 mpd "unable to bind port 6600"的解决方法
来源: 作者: 时间:2007-04-17 Tag: 点击:
在hiweed下很轻松的就安装了mpd,听上了悦耳的歌曲。
接着在debian上装mpd,装完之后,执行mpd老是出现

unable to bind port 6600: Cannot assign requested address
maybe MPD is still running?

错误 照 ee 的说法是 rp 上升。(这两天有点黑~~)
google 了一下,没搜到有什么解决的办法,只是约摸有一个帖子说好像跟 ipv6 有关。
试着在 /etc/modprobe.d/aliases 把 ipv6 给禁了,没什么效果。

就快放弃的时候,无意中在 networking setting 里面看到很多 ipv6 开头的 hosts, 试着编辑
/etc/hosts,把里面127.0.0.1除外,其他都给注释掉

127.0.0.1 localhost.localdomain localhost debian

# The following lines are desirable for IPv6 capable hosts
#::1 ip6-localhost ip6-loopback
#fe00::0 ip6-localnet
#ff00::0 ip6-mcastprefix
#ff02::1 ip6-allnodes
#ff02::2 ip6-allrouters
#ff02::3 ip6-allhosts


接着
$sudo /etc/init.d/mpd stop
$sudo mpd --create-db
$mpc listall | mpc add
$mpd
$mpc play

哈哈,爽啊


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 升级到9.04以后mpd不能用了?
帖子发表于 : 2009-04-09 11:55 
头像

注册: 2008-04-26 12:41
帖子: 10971
送出感谢: 11
接收感谢: 38
:em09


_________________
[新手必读]wubi安装常见问题(FAQ)
[分享]装双系统的同学必看——Windows与Linux系统共享交换分区的方法
kde下唯美的暗黑内透主题(无需编译)
无穷老机上的Trinity Desktop Environment


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译