当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求助,谁能提供一个shake 4
帖子发表于 : 2009-05-08 10:45 
头像

注册: 2006-09-23 12:28
帖子: 485
送出感谢: 1
接收感谢: 0 次
买,我是肯定买不起的。。。下载,找了半天又找不到,ed2k下又几天都下不动。

谢谢!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求助,谁能提供一个shake 4
帖子发表于 : 2009-05-09 18:30 
头像

注册: 2008-05-13 20:40
帖子: 686
地址: 江南西道
送出感谢: 0 次
接收感谢: 0 次
什么东西?


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 求助,谁能提供一个shake 4
帖子发表于 : 2009-05-09 21:14 

注册: 2007-03-19 8:07
帖子: 174
送出感谢: 0 次
接收感谢: 0 次
我这里有一个4.1,等我压缩一下给你传到网盘上面吧。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 求助,谁能提供一个shake 4
帖子发表于 : 2009-05-09 21:29 

注册: 2007-03-19 8:07
帖子: 174
送出感谢: 0 次
接收感谢: 0 次
代码:
http://www.rayfile.com/files/0df6a1a1-3c9d-11de-ac7a-0019d11a795f/


doc目录好几十M,我去掉了。

应该不影响程序运行,你先用用看。

另外注意新版本的xlib上面运行可能需要preload no xcb的xlib库。

否则运行之后会没有反应。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 求助,谁能提供一个shake 4
帖子发表于 : 2009-05-10 15:35 
头像

注册: 2006-09-23 12:28
帖子: 485
送出感谢: 1
接收感谢: 0 次
谢谢楼上的好人啊。
preload no xcb啥意思?apt搜索不到,请指教。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 求助,谁能提供一个shake 4
帖子发表于 : 2009-05-10 17:26 

注册: 2007-03-19 8:07
帖子: 174
送出感谢: 0 次
接收感谢: 0 次
tonytam 写道:
谢谢楼上的好人啊。
preload no xcb啥意思?apt搜索不到,请指教。


8.10以下的版本应该是可以直接运行的。
所以你如果能正常运行的话就不用关心了 :em09

如果版本高于8.10,运行之后一直停留在命令行没有反应的话,需要拷贝一个8.10的xlib库。

然后编辑shake这个文件,把里面的/opt/libx11-noxcb/lib改成你放那个旧版本库的路径就行了。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 求助,谁能提供一个shake 4
帖子发表于 : 2009-05-10 21:58 
头像

注册: 2006-09-23 12:28
帖子: 485
送出感谢: 1
接收感谢: 0 次
fbsd4 写道:
tonytam 写道:
谢谢楼上的好人啊。
preload no xcb啥意思?apt搜索不到,请指教。


8.10以下的版本应该是可以直接运行的。
所以你如果能正常运行的话就不用关心了 :em09

如果版本高于8.10,运行之后一直停留在命令行没有反应的话,需要拷贝一个8.10的xlib库。

然后编辑shake这个文件,把里面的/opt/libx11-noxcb/lib改成你放那个旧版本库的路径就行了。


麻烦了,我的是9.04, 另一台机子是8.10,但是在/usr/lib里,没有libx11-noxcb.so这个文件。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 求助,谁能提供一个shake 4
帖子发表于 : 2009-05-11 0:38 

注册: 2007-03-19 8:07
帖子: 174
送出感谢: 0 次
接收感谢: 0 次
tonytam 写道:
fbsd4 写道:
tonytam 写道:
谢谢楼上的好人啊。
preload no xcb啥意思?apt搜索不到,请指教。


8.10以下的版本应该是可以直接运行的。
所以你如果能正常运行的话就不用关心了 :em09

如果版本高于8.10,运行之后一直停留在命令行没有反应的话,需要拷贝一个8.10的xlib库。

然后编辑shake这个文件,把里面的/opt/libx11-noxcb/lib改成你放那个旧版本库的路径就行了。


麻烦了,我的是9.04, 另一台机子是8.10,但是在/usr/lib里,没有libx11-noxcb.so这个文件。


不是libx11-noxcb.so,是libx11.so.6。

这里下,下了之后,直接进入deb包内(不是安装!fileroller可能有打开deb包这个功能吧?再不行直接用mc也可以直接进入deb包的)把libx11.so.6和另外一个链接文件libx11.so拷贝到shake的lib目录里面,或者拷贝到/opt/libx11-noxcb/lib目录下面也可。(这个目录自己建立)。

下载地址
http://packages.ubuntu.com/hardy/libx11-6

如果hardy的包不好用的话试试看dapper的,再不行就用fedora7的rpm包。

怀疑你的9.04恐怕没法正常运行,我用debian/sid(libc/xlib库版本应该和9.04差不多的),运行之后界面只能出来个大方框。

碰碰运气,你可以都试试看,8.10乃至以下我用的是正常的。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 求助,谁能提供一个shake 4
帖子发表于 : 2009-05-11 18:58 
头像

注册: 2006-09-23 12:28
帖子: 485
送出感谢: 1
接收感谢: 0 次
始终运行不了。还是谢谢fbsd4的热心帮助。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 求助,谁能提供一个shake 4
帖子发表于 : 2009-05-12 20:00 

注册: 2007-03-19 8:07
帖子: 174
送出感谢: 0 次
接收感谢: 0 次
tonytam 写道:
始终运行不了。还是谢谢fbsd4的热心帮助。


我这里弄好了,用一个fc7的库搞定了。

你下这个回去看看,需要的库已经放进去了,直接运行即可。


代码:
http://www.rayfile.com/files/cfb47feb-3eeb-11de-b784-0014221b798a/



不过shake现在都停止开发了,建议用nuke吧。

代码:
http://www.beeplat.org/explorer_0e0aa6433dc7aeb5c759c8481882d19d.htm


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 求助,谁能提供一个shake 4
帖子发表于 : 2009-05-16 21:03 
头像

注册: 2006-09-23 12:28
帖子: 485
送出感谢: 1
接收感谢: 0 次
fbsd4 写道:
tonytam 写道:
始终运行不了。还是谢谢fbsd4的热心帮助。


我这里弄好了,用一个fc7的库搞定了。

你下这个回去看看,需要的库已经放进去了,直接运行即可。


代码:
http://www.rayfile.com/files/cfb47feb-3eeb-11de-b784-0014221b798a/



不过shake现在都停止开发了,建议用nuke吧。

代码:
http://www.beeplat.org/explorer_0e0aa6433dc7aeb5c759c8481882d19d.htm


谢谢,得您帮助,shake终于运行起来了 :em11

nuke好像没法下载,有些分卷禁止访问。


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 求助,谁能提供一个shake 4
帖子发表于 : 2009-05-17 14:04 

注册: 2007-03-19 8:07
帖子: 174
送出感谢: 0 次
接收感谢: 0 次
tonytam 写道:
fbsd4 写道:
tonytam 写道:
始终运行不了。还是谢谢fbsd4的热心帮助。


我这里弄好了,用一个fc7的库搞定了。

你下这个回去看看,需要的库已经放进去了,直接运行即可。


代码:
http://www.rayfile.com/files/cfb47feb-3eeb-11de-b784-0014221b798a/



不过shake现在都停止开发了,建议用nuke吧。

代码:
http://www.beeplat.org/explorer_0e0aa6433dc7aeb5c759c8481882d19d.htm


谢谢,得您帮助,shake终于运行起来了 :em11

nuke好像没法下载,有些分卷禁止访问。


我当时下的时候还是正常的 :em04

先用shake吧 :em06


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 求助,谁能提供一个shake 4
帖子发表于 : 2009-06-29 18:16 

注册: 2009-06-29 18:14
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
:em11 你们真是好样的,谢谢了,我的buntu9.04也可以运行shake 4.1了,没办法啊!老板要求弄的,快逼疯了,还好哦,搞定了,真的感谢你们。 :em06 :em06


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
cron
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译